The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]



"QtCreator (9.0.1 Debian) debugging helpers don't work"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Программирование под UNIX (C/C++)
Изначальное сообщение [ Отслеживать ]

"QtCreator (9.0.1 Debian) debugging helpers don't work"  –2 +/
Сообщение от A.Stahl (ok), 01-Фев-23, 10:38 
I didn't pay attention so no idea when it broke, but now I don't see a human-readable variant of std::containers while debugging. Now I see something like this: https://imgur.com/a/QHim0PI

I tinkered a bit around, tried a repository version too (keeping an old config and without it). I was in the Edit->Preferences->Debugger. Played with different combinations of parameters. It feels like nothing has changed though...

Now I use the version from the net-installer. How should I enable the "debugging helpers"?

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения [Сортировка по времени | RSS]


1. "QtCreator (9.0.1 Debian) debugging helpers don't work"  +/
Сообщение от Аноним (-), 01-Фев-23, 20:31 
> I didn't pay attention so no idea when it broke, but now
> I don't see a human-readable variant of std::containers while debugging. Now
> I see something like this: https://imgur.com/a/QHim0PI
> I tinkered a bit around, tried a repository version too (keeping an
> old config and without it). I was in the Edit->Preferences->Debugger. Played
> with different combinations of parameters. It feels like nothing has changed
> though...
> Now I use the version from the net-installer. How should I enable
> the "debugging helpers"?

Есть такое подозрение, что все твои помогаторы для обезжучивателя дожны быть скриптами для gdb или что там используется вместо него. Вот оттуда и копай, не забудь удостовериться, что всё нужное собрано одним и тем же.

Но отвечаю я с дивана.

А уйти на английский навроде золотца - хорошая идея.

Ответить | Правка | Наверх | Cообщить модератору

2. "QtCreator (9.0.1 Debian) debugging helpers don't work"  +/
Сообщение от Аноним (2), 02-Фев-23, 10:09 
> I didn't pay attention so no idea when it broke, but now
> I don't see a human-readable variant of std::containers while debugging. Now
> I see something like this: https://imgur.com/a/QHim0PI
> I tinkered a bit around, tried a repository version too (keeping an
> old config and without it). I was in the Edit->Preferences->Debugger. Played
> with different combinations of parameters. It feels like nothing has changed
> though...
> Now I use the version from the net-installer. How should I enable
> the "debugging helpers"?

Are you sure your code is built with -ggdb?

Ответить | Правка | Наверх | Cообщить модератору

3. "QtCreator (9.0.1 Debian) debugging helpers don't work"  –1 +/
Сообщение от A.Stahl (ok), 02-Фев-23, 13:36 
> Are you sure your code is built with -ggdb?

No, actually. I use QtCreator + CMake, so can't be sure about the precise parameters I got after all these "layers".


Ответить | Правка | Наверх | Cообщить модератору

5. "QtCreator (9.0.1 Debian) debugging helpers don't work"  +/
Сообщение от Аноним (5), 16-Фев-23, 05:19 
>> Are you sure your code is built with -ggdb?
> No, actually. I use QtCreator + CMake, so can't be sure about
> the precise parameters I got after all these "layers".

Try finding out those parameters then.

Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Партнёры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2024 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру