The OpenNET Project / Index page

[ новости /+++ | форум | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Cisco 1841 периодически не маршрутизирует пакеты"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]

"Cisco 1841 периодически не маршрутизирует пакеты"  +/
Сообщение от vetallove (ok) on 05-Авг-10, 08:54 
В общем есть сеть, в которой присутствует 3 vlan'а. Один из vlan служит только для того, чтобы передавать данные во внешнюю корпоративную сеть (назовем его транспортным), в 2 других подключаются устройства. Все это маршрутизирует cisco 1841. Два клиентских vlan маршрутизируется между собой. Также обеспечено прохождение пакетов клиентских vlan'ов во внешнюю корпоратиыную сеть через ранспортный vlan. Cisco 1841 использует протокол ospf для агрегации во внешнюю сеть.

Проблема заключается в том, что иногда пакеты из клиентских сетей не доходят до внешнией сети. Причем только с определённых ip адресов. Т.е. например сегодня ip 155 не может достучатся до внешки, при этом все остальные работают нормально. На следующий день не работает какой-либо другой ip, а пакеты со 155 доходят до места назначения нормально.

Возникает вопрос в чем в принципе может быть проблема. Я подозреваю, что проблема может крыться в каком-то конфликте нашей сети с внешней корпоративной сетью. Однако возможно кто-то сталкивался с такими проблемами и эта проблема на нашем маршрутизаторе.

Я пробовал просто перезагружать маршрутизатор и проблемы это не решало. Так же посмотрел сети, анонсируемые по протоколу ospf во внешней сети, и не нашел там сетей, адреса которых совпадают с адресами нашей сети.

Возникла идея что пакет во внешyюю сеть все-таки уходит, однако не возвращается обратно. Может быть можно как-нибудь диагностировать подобного рода проблему?

Прилагаю также конфиг cisco 1841.


!
Using 3430 out of 196600 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cisco1841
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
no aaa new-model
ip cef
!
!
!
!
ip name-server 10.1.1.2
multilink bundle-name authenticated
!
!
vtp mode transparent
archive
log config
  hidekeys
!
!
!
!
!
interface FastEthernet0/0
description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.4092
description transport vlan
encapsulation dot1Q 4092
ip address 10.99.254.131 255.255.255.248
!
interface FastEthernet0/0.4093
description technet vlan
encapsulation dot1Q 4093
ip address 10.100.254.111 255.255.255.0
!
interface FastEthernet0/0.4094
description office vlan
encapsulation dot1Q 4094
ip address 10.100.1.111 255.255.255.0
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 10
log-adjacency-changes
network 10.99.254.131 0.0.0.0 area 99
network 10.100.1.111 0.0.0.0 area 99
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.99.254.129 254
!
!
ip http server
ip http access-class 23
ip http authentication local
ip http timeout-policy idle 60 life 86400 requests 10000
ip dns server
!
access-list 23 permit 10.10.10.0 0.0.0.7
!
!
control-plane
!
line con 0
login local
line aux 0
line vty 0 4
privilege level 15
login
transport input telnet
line vty 5 15
access-class 23 in
privilege level 15
login local
transport input telnet
!
scheduler allocate 20000 1000
end

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Cisco 1841 периодически не маршрутизирует пакеты"  +/
Сообщение от karen durinyan (ok) on 05-Авг-10, 10:25 
>[оверквотинг удален]
> transport input telnet
>line vty 5 15
> access-class 23 in
> privilege level 15
> login local
> transport input telnet
>!
>scheduler allocate 20000 1000
>end
>

круто :)

во первых если у вас только OSPF работает на транзит влан-е то лутше делать так:

router ospf 10
passive-interface default
no passive-interface FastEthernet0/0.4092

ето может быть из за "mac conflict". попробуите "show arp" для проблематичнеи IP и сравните MAC с MAC аддресом хоста. может кто то поставил тот же IP на другом хосте и у вас "mac conflict"?

на "cisco" можете активировать "flow cache" на итерфеисах и посматреть если покети проходят между интерфеисами так:

interface FastEthernet0/0.4092
ip flow ingress

interface FastEthernet0/0.4093
ip flow ingress

interface FastEthernet0/0.4094
ip flow ingress

show ip cache flow
...
...
Vl12          a.a.a.210    Fa0           x.x.x.193    11 CA6B 876C     3
Fa0           b.b.b.137    Vl12*         y.y.y.246    11 4D84 1BB3     3
...


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Партнёры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2024 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру