The OpenNET Project / Index page

[ новости /+++ | форум | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Два провайдера одновременно "
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]

"Два провайдера одновременно "  +/
Сообщение от kolyaniust email(ok) on 16-Авг-10, 17:51 
Доброго времени суток, прошу помочь специалистов.
Проблема уже обговаривалась, но есть нюанс.
Хочу что бы был доступ из ВНЕ одновременно по двум провайдерам.
1-    Оптоволокно
2-    Антенна WiMax , которая в роли бриджа работать не умеет, максимум, что удалось из нее выдавить это проброс всех портов на внутренний ип.
При отключённом основном провайдере, доступ из Вне есть, как только включается основной, доступ пропадает.

ip sla monitor 1
type echo protocol ipIcmpEcho 91.204.X.X source-interface GigabitEthernet0/0.1
timeout 2000
threshold 10
frequency 3
ip sla monitor schedule 1 life forever start-time now
ip sla monitor 2
type echo protocol ipIcmpEcho 213.238.Y.Y source-interface GigabitEthernet0/0.2
timeout 2000
threshold 10
frequency 3
ip sla monitor schedule 2 life forever start-time now

track 1 rtr 1 reachability
delay down 5 up 2
!
track 2 rtr 2 reachability
delay down 5 up 2


interface GigabitEthernet0/0
no ip address
ip flow ingress
ip flow egress
ip route-cache flow
duplex full
speed auto
no cdp enable
!
interface GigabitEthernet0/0.1
description ISP1
encapsulation dot1Q 2
ip address 91.204.X.X 255.255.255.248
ip flow ingress
ip flow egress
ip nat outside
no ip virtual-reassembly
no cdp enable
!
interface GigabitEthernet0/0.2
description ISP2
encapsulation dot1Q 3
ip address 10.2.2.2 255.255.255.0  (форвард всех портов с внешнего ИП антенны идет на этот ИП)
ip flow ingress
ip flow egress
ip nat outside
ip nat enable
no ip virtual-reassembly
no cdp enable
!
interface GigabitEthernet0/1
description lan
ip address 192.168.0.11 255.255.255.0
ip nat inside
ip virtual-reassembly
rate-limit input access-group 120 1512000 16000 16000 conform-action transmit exceed-action drop
rate-limit output access-group 121 1512000 16000 16000 conform-action transmit exceed-action drop
duplex auto
speed auto
!

ip local policy route-map track
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 91.204.X.X track 1
ip route 0.0.0.0 0.0.0.0 10.2.2.1 100 track 2
ip route 213.238.Y.Y 255.255.255.255 10.2.2.1

ip nat inside source route-map alternet interface GigabitEthernet0/0.2 overload
ip nat inside source route-map dataLINE interface GigabitEthernet0/0.1 overload
ip nat inside source static tcp 192.168.0.222 21 91.204.X.X 21 extendable
ip nat inside source static tcp 192.168.0.222 21 213.238.Y.Y 21 extendable


ip access-list extended alternet_nat_acl
permit tcp 192.168.0.0 0.0.0.255 any eq www
deny   ip 192.168.0.0 0.0.0.255 10.0.10.0 0.0.0.255
deny   ip 192.168.0.0 0.0.0.255 10.0.12.0 0.0.0.255
deny   ip 192.168.0.0 0.0.0.255 10.10.1.0 0.0.0.255
deny   ip 192.168.0.0 0.0.0.255 10.10.2.0 0.0.0.255
deny   ip 192.168.0.0 0.0.0.255 10.10.7.0 0.0.0.255
deny   ip 192.168.0.0 0.0.0.255 10.10.8.0 0.0.0.255
deny   ip 192.168.0.0 0.0.0.255 10.10.9.0 0.0.0.255
deny   ip 192.168.0.0 0.0.0.255 10.10.10.0 0.0.0.255
deny   ip 192.168.0.0 0.0.0.255 192.168.1.0 0.0.0.255
deny   ip 192.168.0.0 0.0.0.255 192.168.3.0 0.0.0.255
deny   ip 192.168.0.0 0.0.0.255 192.168.4.0 0.0.0.255
deny   ip 192.168.0.0 0.0.0.255 192.168.5.0 0.0.0.255
deny   ip 192.168.0.0 0.0.0.255 192.168.7.0 0.0.0.255
deny   ip 192.168.0.0 0.0.0.255 192.168.11.0 0.0.0.255
deny   ip 192.168.0.0 0.0.0.255 192.168.12.0 0.0.0.255
deny   ip 192.168.0.0 0.0.0.255 192.168.16.0 0.0.0.255
deny   ip 192.168.0.0 0.0.0.255 192.168.21.0 0.0.0.255
permit ip 192.168.0.0 0.0.0.255 any
deny   ip any any
ip access-list extended dataLINE_nat_acl
deny   ip 192.168.0.0 0.0.0.255 10.0.10.0 0.0.0.255
deny   ip 192.168.0.0 0.0.0.255 10.0.12.0 0.0.0.255
deny   ip 192.168.0.0 0.0.0.255 10.10.1.0 0.0.0.255
deny   ip 192.168.0.0 0.0.0.255 10.10.2.0 0.0.0.255
deny   ip 192.168.0.0 0.0.0.255 10.10.7.0 0.0.0.255
deny   ip 192.168.0.0 0.0.0.255 10.10.8.0 0.0.0.255
deny   ip 192.168.0.0 0.0.0.255 10.10.9.0 0.0.0.255
deny   ip 192.168.0.0 0.0.0.255 10.10.10.0 0.0.0.255
deny   ip 192.168.0.0 0.0.0.255 192.168.1.0 0.0.0.255
deny   ip 192.168.0.0 0.0.0.255 192.168.3.0 0.0.0.255
deny   ip 192.168.0.0 0.0.0.255 192.168.4.0 0.0.0.255
deny   ip 192.168.0.0 0.0.0.255 192.168.5.0 0.0.0.255
deny   ip 192.168.0.0 0.0.0.255 192.168.7.0 0.0.0.255
deny   ip 192.168.0.0 0.0.0.255 192.168.11.0 0.0.0.255
deny   ip 192.168.0.0 0.0.0.255 192.168.12.0 0.0.0.255
deny   ip 192.168.0.0 0.0.0.255 192.168.16.0 0.0.0.255
deny   ip 192.168.0.0 0.0.0.255 192.168.21.0 0.0.0.255
permit ip 192.168.0.0 0.0.0.255 any
deny   ip any any


ip access-list extended track1
permit icmp any host 91.204.X.X
ip access-list extended track2
permit icmp any host 213.238.Y.Y


route-map alternet permit 10
match ip address alternet_nat_acl
match interface GigabitEthernet0/0.2
!
route-map dataLINE permit 10
match ip address dataLINE_nat_acl
match interface GigabitEthernet0/0.1


route-map track permit 10
match ip address track1
set ip next-hop 91.204.X.X
set interface Null0
!
route-map track permit 20
match ip address track2
set ip next-hop 10.2.2.1
set interface Null0

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Два провайдера одновременно "  +/
Сообщение от kolyaniust email(ok) on 18-Авг-10, 10:36 
Может хоть кто то, что то посоветует ) ???
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "Два провайдера одновременно "  +/
Сообщение от gygygy email(ok) on 18-Авг-10, 12:30 
>Может хоть кто то, что то посоветует ) ???

Доступ на циску нужен? Если да то config для line VTY покажите.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "Два провайдера одновременно "  +/
Сообщение от kolyaniust email(ok) on 18-Авг-10, 13:11 
>>Может хоть кто то, что то посоветует ) ???
>
>Доступ на циску нужен? Если да то config для line VTY покажите.
>

Да доступ просто необходим.

line vty 0 4
privilege level 15
logging synchronous
transport input telnet ssh
escape-character 3

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "Два провайдера одновременно "  +/
Сообщение от gygygy email(ok) on 18-Авг-10, 13:43 
>[оверквотинг удален]
>>Доступ на циску нужен? Если да то config для line VTY покажите.
>>
>
>Да доступ просто необходим.
>
>line vty 0 4
> privilege level 15
> logging synchronous
> transport input telnet ssh
> escape-character 3

Как я понимаю, у вас есть 2 дефолтных маршрута. Причем первый в приоритете. При попытке залогинится через второго прова вы попадаете на 10.2.2.2, но так как у вас первый пров работает и маршрут дефолтный присутствует на первого провайдера то обратно пакет пойдет через него, а источником будет 10.2.2.2(НАТа я у вас не вижу). Поэтому он к вам не придет.
Мне так кажется.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

5. "Два провайдера одновременно "  +/
Сообщение от Guest (??) on 18-Авг-10, 13:55 
>[оверквотинг удален]
>> transport input telnet ssh
>> escape-character 3
>
>Как я понимаю, у вас есть 2 дефолтных маршрута. Причем первый в
>приоритете. При попытке залогинится через второго прова вы попадаете на 10.2.2.2,
>но так как у вас первый пров работает и маршрут дефолтный
>присутствует на первого провайдера то обратно пакет пойдет через него, а
>источником будет 10.2.2.2(НАТа я у вас не вижу). Поэтому он к
>вам не придет.
>Мне так кажется.

может route-map local ?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

6. "Два провайдера одновременно "  +/
Сообщение от gygygy email(ok) on 18-Авг-10, 14:04 
>[оверквотинг удален]
>>
>>Как я понимаю, у вас есть 2 дефолтных маршрута. Причем первый в
>>приоритете. При попытке залогинится через второго прова вы попадаете на 10.2.2.2,
>>но так как у вас первый пров работает и маршрут дефолтный
>>присутствует на первого провайдера то обратно пакет пойдет через него, а
>>источником будет 10.2.2.2(НАТа я у вас не вижу). Поэтому он к
>>вам не придет.
>>Мне так кажется.
>
>может route-map local ?

(НАТа я у вас не вижу) в смысле для ip 10.2.2.2 НАТа нет

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

7. "Два провайдера одновременно "  +/
Сообщение от Guest (??) on 18-Авг-10, 14:30 
>[оверквотинг удален]
>>>но так как у вас первый пров работает и маршрут дефолтный
>>>присутствует на первого провайдера то обратно пакет пойдет через него, а
>>>источником будет 10.2.2.2(НАТа я у вас не вижу). Поэтому он к
>>>вам не придет.
>>>Мне так кажется.
>>
>>может route-map local ?
>
>(НАТа я у вас не вижу) в смысле для ip 10.2.2.2 НАТа
>нет

а нужен ли там нат ? он ведь хочет попасть на 10.2.2.2 если я правильно его понял.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

8. "Два провайдера одновременно "  +/
Сообщение от gygygy email(ok) on 18-Авг-10, 14:43 
>[оверквотинг удален]
>>>>вам не придет.
>>>>Мне так кажется.
>>>
>>>может route-map local ?
>>
>>(НАТа я у вас не вижу) в смысле для ip 10.2.2.2 НАТа
>>нет
>
>а нужен ли там нат ? он ведь хочет попасть на 10.2.2.2
>если я правильно его понял.

Ну да, как я тоже понял он туда и хочет попасть. Но у него 2 маршрута, обратно пакет  пойдет по первому через interface GigabitEthernet0/0.1, с ip адреса 10.2.2.2.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

9. "Два провайдера одновременно "  +/
Сообщение от Guest (??) on 18-Авг-10, 15:02 
>[оверквотинг удален]
>>>
>>>(НАТа я у вас не вижу) в смысле для ip 10.2.2.2 НАТа
>>>нет
>>
>>а нужен ли там нат ? он ведь хочет попасть на 10.2.2.2
>>если я правильно его понял.
>
>Ну да, как я тоже понял он туда и хочет попасть. Но
>у него 2 маршрута, обратно пакет  пойдет по первому через
>interface GigabitEthernet0/0.1, с ip адреса 10.2.2.2.

вот я и писал route-map local :)

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

10. "Два провайдера одновременно "  +/
Сообщение от kolyaniust email(ok) on 26-Авг-10, 19:46 
>[оверквотинг удален]
>>>>нет
>>>
>>>а нужен ли там нат ? он ведь хочет попасть на 10.2.2.2
>>>если я правильно его понял.
>>
>>Ну да, как я тоже понял он туда и хочет попасть. Но
>>у него 2 маршрута, обратно пакет  пойдет по первому через
>>interface GigabitEthernet0/0.1, с ip адреса 10.2.2.2.
>
>вот я и писал route-map local :)

Простите с опозданием, болезнь выводит из колеи.
Антенна на которой добился только это :
http://i072.radikal.ru/1008/2a/82e1d0f28fe2.jpg
Больше ни чего она делать не умеет, если бы она заводилась в качестве БРИДЖА, проблем бы не было, как и вопросов.
Можно по подробнее версию с  «route-map local»

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Партнёры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2024 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру