The OpenNET Project / Index page

[ новости /+++ | форум | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Разграничение и резервация каналов связи через route-map+nat"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]

"Разграничение и резервация каналов связи через route-map+nat"  +/
Сообщение от Toster (ok) on 11-Мрт-11, 15:00 
Здравтсвуйте, подскажите пожалуйста как решить следующую задачу:
Имеется cisco 2811 к 2-м интерфейсам подключены 2 разных провайдера, к 3-ему интерфейсу компьютер. Компьютер выходит в интернет с одного из провайдеров в зависимости от ACL. Например, если я хочу зайти на 188.40.74.9 то я захожу через провайдера №1, если на 8.8.8.8 то через провайдера №2 и т.д.
Необходимо сделать так, чтобы при отключении провайдера №1 трафик с компьютера, который ходил через провайдера №1, выходил в через провайдера №2 и наоборот.

Пробовал реализовать данную схему.(192.168.1.2 - IP компьютера который выходит в интернет). Все работает до того момента, когда отключаешь один из провайдеров (трафик, который должен идти по отключенному провайдеру не идет на резервный провайдер)

Cisco 2811 (revision 53.51) with 247808K/14336K bytes of memory.
Processor board ID FCZ112570J9
4 FastEthernet interfaces
1 Virtual Private Network (VPN) Module
DRAM configuration is 64 bits wide with parity enabled.
239K bytes of non-volatile configuration memory.
62720K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x2102

track 110 ip sla 1 reachability
!
track 120 ip sla 2 reachability
!
!
!
!
interface FastEthernet0/0
ip address XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
ip address  YYY.YYY.YYY.YYY
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/0/0
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
ip policy route-map 1tssmap
duplex auto
speed auto
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 XXX.XXX.XXX.XXX 10
no ip http server
no ip http secure-server
!
!
ip nat inside source route-map 1tssmap interface FastEthernet0/1 overload
ip nat inside source route-map 2elmap interface FastEthernet0/0 overload
!
ip access-list extended elacl
permit udp host 192.168.1.2 host 8.8.8.8 eq domain
permit tcp host 192.168.1.2 any eq www
ip access-list extended tssacl
permit tcp host 192.168.1.2 host 188.40.74.9
permit tcp host 192.168.1.2 host 188.40.74.10
!
ip sla 1
icmp-echo XXX.XXX.XXX.XXX source-ip YYY.YYY.YYY.YYY
frequency 10
ip sla schedule 1 life forever start-time now
ip sla 2
icmp-echo XXX.XXX.XXX.XXX source-ip XXX.XXX.XXX.XXX
frequency 10
ip sla schedule 2 life forever start-time now
!
!
!
!
route-map 1tssmap permit 10
match ip address tssacl
set ip next-hop verify-availability YYY.YYY.YYY.YYY 10 track 110
set ip next-hop verify-availability XXX.XXX.XXX.XXX 20 track 120
!
route-map 2elmap permit 20
match ip address elacl
set ip next-hop verify-availability XXX.XXX.XXX.XXX track 120
set ip next-hop verify-availability YYY.YYY.YYY.YYY 20 track 110


Может кто подскажет в каком направлении думать или что попробовать...
Заранее спасибо!

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Разграничение и резервация каналов связи через route-map+nat"  +/
Сообщение от anonymous (??) on 11-Мрт-11, 18:18 
уберите роут мап с интерефйса 0/0/0 он у вас для policy nat на интерфейсе он не нуженвот у
на обоих внешних интерфейсах белые ип да ?
вот у вас упал один из каналов. Да дефолт для полиси поменялс,но поменялся только роут а нат так и снатировался на свой интерфейс в зависимости от полиси.
белый ип на который он снатировался принадлежит другому провайдеру (допустим первому)и второй пров этот пакет просто не пустит через себя.
единственный способ который я тут вижу:
1) регистрируете на себя подсеть белых ип
2) просите обоих провов анонсировать эту подсеть, а на вас прописать статик маршрут
2) прописываете его у себя на лупбеке
3) натируете свой комп на лупбек
4) прописываете роутами какие ресурсы видеть через какого прова
5) вешаете на эти ресурсы SLA
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Разграничение и резервация каналов связи через route-map+nat"  +/
Сообщение от Toster (ok) on 17-Мрт-11, 08:01 
>[оверквотинг удален]
> белый ип на который он снатировался принадлежит другому провайдеру (допустим первому)и
> второй пров этот пакет просто не пустит через себя.
> единственный способ который я тут вижу:
> 1) регистрируете на себя подсеть белых ип
> 2) просите обоих провов анонсировать эту подсеть, а на вас прописать статик
> маршрут
> 2) прописываете его у себя на лупбеке
> 3) натируете свой комп на лупбек
> 4) прописываете роутами какие ресурсы видеть через какого прова
> 5) вешаете на эти ресурсы SLA

Спасибо, буду пробовать.

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Партнёры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2024 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру