The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]



"Почему НЕ у всех пользователей debian 10 есть звук?"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Открытые системы на рабочей станции (Звук / Linux)
Изначальное сообщение [ Отслеживать ]

"Почему НЕ у всех пользователей debian 10 есть звук?"  +/
Сообщение от Isothiocyanate (ok), 19-Окт-19, 13:52 
Добрый день, уважаемые форумчане!

Есть два пользователя user1, user2 на debian 10   x64 LXDE, у первого есть звук, у второго нет.

Звук идет через наушники, подключенные к аудиовыходу на передней панеле корпуса
Корпус Deepcool Tesseract SW Midi-Tower,(DP-CCATX-
TSRBKBL), стоит материнка GIGABYTE Z390 UD
на ней аудиокарта
user1@debian999:~$ sudo cat /proc/asound/cards
0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0x51210000 irq 128
звук под юзером 1 идет.

Пробовал настраивать при помощи alsamixer, pavucontrol под юзер 2.

Разница в том, что на user2 Alsamixer позволяет выбрать нужную карту , но звук не пускает.
А PulseAudio на user2 не позволяет выбрать аудиокарту во вкладке конфигуратора Configuration.
У user1 там стоит Built-in audio, analog stereo duplex и звук есть.

Я пробовал искать и русскоязычную и англоязычную информацию по настройке звука, обнаружил что некоторые пакеты alsa у меня недоступны, например
user1@debian999:~$ sudo apt-get install alsa-utils alsa-base alsa-tools
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Package alsa-base is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'alsa-base' has no installation candidate

тем не менее алсамикшер работает и настройки с user1 вбить в alsamixer user2 можно но толку мало.

Может user2 не состоит в группе audio или еще какой другой вариант?
очень прошу помочь.

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения [Сортировка по времени | RSS]


1. "Почему НЕ у всех пользователей debian 10 есть звук?"  +/
Сообщение от Isothiocyanate (ok), 19-Окт-19, 14:01 

> Может user2 не состоит в группе audio или еще какой другой вариант?

Добавил user2 в группу audio, перезапустил pulseaudio

sudo pulseaudio -k
sudo pulseaudio -D
- выдало ошибку.
Перезагрузился.

Зашел под user2, pavucontrol  -  звуковая карта подтянулась так же как и в user1,
звук работает отлично.

Спасибо, извиняюсь за беспокойство.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Партнёры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2024 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру