The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"ааа.... помогите моей самбе увидеть iconv..."
Вариант для распечатки Архивированная нить - только для чтения! 
Пред. тема | След. тема 
Форумы OpenNET: Виртуальная конференция (Public)
Изначальное сообщение [Проследить за развитием треда]

"ааа.... помогите моей самбе увидеть iconv..."
Сообщение от sledge emailИскать по авторуВ закладки on 16-Окт-03, 11:59  (MSK)
Второй день бьюсь пока не допер...

samba-3.0.0 + FreeBSD 4.9RC

установлены iconv-2.0_3, iconv-extra-2.0, libiconv-1.9.1_1.

при конфигурации ( ./configure) самбы пишет среди прочего следующее:

configure:19925: WARNING: Sufficient support for iconv function was not found.
    Install libiconv from http://freshmeat.net/projects/libiconv/ for better charset compatibility!


при этом все компилится и работает, но проблемы с кодировками... и winbindd не пускается...

  Рекомендовать в FAQ | Cообщить модератору | Наверх

 Оглавление

Индекс форумов | Темы | Пред. тема | След. тема
Сообщения по теме

1. "ааа.... помогите моей самбе увидеть iconv..."
Сообщение от PJ Искать по авторуВ закладки on 16-Окт-03, 12:22  (MSK)
Компилировать надо с libiconv

configure --with-libiconv=/usr/local

остальную часть (а именно /lib) Самба подставит сама

  Рекомендовать в FAQ | Cообщить модератору | Наверх

2. "ааа.... помогите моей самбе увидеть iconv..."
Сообщение от sledge emailИскать по авторуВ закладки on 16-Окт-03, 12:33  (MSK)
YESSS!

спасибо - то что надо, теперь прокатило

  Рекомендовать в FAQ | Cообщить модератору | Наверх

3. "ан нет - подставлять-то подставляет, но"
Сообщение от sledge emailИскать по авторуВ закладки on 16-Окт-03, 16:24  (MSK)
>Компилировать надо с libiconv
>
>configure --with-libiconv=/usr/local
>
>остальную часть (а именно /lib) Самба подставит сама


checking for iconv in /usr/local... yes
checking can we convert from CP850 to UCS2-LE?... no
checking can we convert from IBM850 to UCS2-LE?... no
checking can we convert from ASCII to UCS2-LE?... no
checking can we convert from 646 to UCS2-LE?... no
checking can we convert from UTF-8 to UCS2-LE?... no
checking can we convert from UTF8 to UCS2-LE?... no
configure: WARNING: Sufficient support for iconv function was not found.
    Install libiconv from http://freshmeat.net/projects/libiconv/ for better charset compatibility!

=(((((

  Рекомендовать в FAQ | Cообщить модератору | Наверх


Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Пожалуйста, прежде чем написать сообщение, ознакомьтесь с данными рекомендациями.




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру