The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"после shutdown не стартует milter spamassassin"
Вариант для распечатки Архивированная нить - только для чтения! 
Пред. тема | След. тема 
Форумы OpenNET: Виртуальная конференция (Public)
Изначальное сообщение [Проследить за развитием треда]

"после shutdown не стартует milter spamassassin"
Сообщение от Lisa Искать по авторуВ закладки(ok) on 08-Ноя-04, 09:54  (MSK)
добрый день! никто не сталкивался с таким: после shutdown не стартует milter spamassassin. в логах тишина. руками скрипт запускается нормально. не пойму чего ему на этапе загрузки не хватает.
freebsd 4.10 + sendmail + spamassassin

в sendmail конф:
INPUT_MAIL_FILTER(`spamassassin', `S=local:/var/run/spamass-milter.sock, F=, T=C:15m;S:4m;R:4m;E:10m')dnl
define(`confMILTER_LOG_LEVEL',`16')

Скрипт разработчиков, собственно:
#!/bin/sh

DAEMON=/usr/local/sbin/spamass-milter
SOCKET=/var/run/spamass-milter.sock
PIDFILE=/var/run/spamass-milter.pid
SPAMADRESS=нужный@пользователь.ru

case "$1" in
start)
        if [ -f "${DAEMON}" -a -x "${DAEMON}" ]
        then
        "${DAEMON}" -p "${SOCKET}" -f -B "${SPAMADRESS}"&
                echo $! > "${PIDFILE}"
                sleep 5
                kill -HUP `head -1 /var/run/sendmail.pid`
                echo -n ' spamass-milter'
        fi
;;
stop)
        if [ -f "${PIDFILE}" ]
        then
                read -r pid junk < "${PIDFILE}"
#kill ${pid}
                killall spamass-milter
                rm -f "${SOCKET}" "${PIDFILE}"
                sleep 1
                kill -HUP `head -1 /var/run/sendmail.pid`
                echo -n ' spamass-milter'
        fi
;;
esac

  Рекомендовать в FAQ | Cообщить модератору | Наверх

 Оглавление

Индекс форумов | Темы | Пред. тема | След. тема
Сообщения по теме

1. "после shutdown не стартует milter spamassassin"
Сообщение от lavr emailИскать по авторуВ закладки on 09-Ноя-04, 13:25  (MSK)
>добрый день! никто не сталкивался с таким: после shutdown не стартует milter
>spamassassin. в логах тишина. руками скрипт запускается нормально. не пойму чего
>ему на этапе загрузки не хватает.
>freebsd 4.10 + sendmail + spamassassin
>
>в sendmail конф:
>INPUT_MAIL_FILTER(`spamassassin', `S=local:/var/run/spamass-milter.sock, F=, T=C:15m;S:4m;R:4m;E:10m')dnl
>define(`confMILTER_LOG_LEVEL',`16')
>
>Скрипт разработчиков, собственно:
>#!/bin/sh
>
>DAEMON=/usr/local/sbin/spamass-milter
>SOCKET=/var/run/spamass-milter.sock
>PIDFILE=/var/run/spamass-milter.pid
>SPAMADRESS=нужный@пользователь.ru
>
>case "$1" in
>start)
>        if [ -f "${DAEMON}"
>-a -x "${DAEMON}" ]
>        then
>        "${DAEMON}" -p "${SOCKET}" -f
>-B "${SPAMADRESS}"&
>                echo $! > "${PIDFILE}"
>            
>    sleep 5
>            
>    kill -HUP `head -1 /var/run/sendmail.pid`
>            
>    echo -n ' spamass-milter'
>        fi
>;;
>stop)
>        if [ -f "${PIDFILE}"
>]
>        then
>            
>    read -r pid junk < "${PIDFILE}"
>#kill ${pid}
>            
>    killall spamass-milter
>            
>    rm -f "${SOCKET}" "${PIDFILE}"
>            
>    sleep 1
>            
>    kill -HUP `head -1 /var/run/sendmail.pid`
>            
>    echo -n ' spamass-milter'
>        fi
>;;
>esac

spamd - запущен? его лучше раньше запустить, может быть порядок запуска?

возможно из-за наличия: spamass-milter.sock и spamass-milter.pid

сделай в скрипте проверки:

1) запущен ли уже демон
2) если НЕТ - удалить sock и pid

Странно, это вообще-то скрипты из /usr/local/etc/rc.subr должны делать,
извини, некогда твой скрипт внимательно посмотреть, посмотри свежие
порты как там сделано через rc.subr или вставь отладку в свой скрипт

  Рекомендовать в FAQ | Cообщить модератору | Наверх

2. "после shutdown не стартует milter spamassassin"
Сообщение от Lisa Искать по авторуВ закладки(ok) on 09-Ноя-04, 18:20  (MSK)
>>добрый день! никто не сталкивался с таким: после shutdown не стартует milter
>>spamassassin. >spamd - запущен? его лучше раньше запустить, может быть порядок запуска?

я заметила, что когда демон запускается первым, то так лучше. поменяла их порядок запуска.

>сделай в скрипте проверки:
>
>1) запущен ли уже демон
>2) если НЕТ - удалить sock и pid

Все запускается правильно.

Для таких криворуких как я. Азбучные правила: скрипты запуска должны иметь формат *.sh. У меня не было .sh. То ли при установке так стало, а я не обратила внимания, то ли сама потеряла.


  Рекомендовать в FAQ | Cообщить модератору | Наверх


Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Пожалуйста, прежде чем написать сообщение, ознакомьтесь с данными рекомендациями.




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру