The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"Не могу установить mrtg-2.9.9"
Вариант для распечатки Архивированная нить - только для чтения! 
Пред. тема | След. тема 
Форумы OpenNET: Виртуальная конференция (Public)
Изначальное сообщение [Проследить за развитием треда]

"Не могу установить mrtg-2.9.9"
Сообщение от Дмитрий emailИскать по авторуВ закладки on 23-Мрт-01, 17:26  (MSK)
При конфигурировании пишет:
checking for gd.h... no
Хотя этот файл имеется и находится там где и должен быть, т.е в /usr/local/include. Та же ситуация получается и в случае, если запустить конфигурирование с опцией --with-gd-inc=/usr/local/include. Ну не видит конфигуратор gd.h и все тут. Как это побороть?
  Рекомендовать в FAQ | Cообщить модератору | Наверх

 Оглавление

Индекс форумов | Темы | Пред. тема | След. тема
Сообщения по теме

1. "RE: Не могу установить mrtg-2.9.9"
Сообщение от Ivar emailИскать по авторуВ закладки on 23-Мрт-01, 21:58  (MSK)
Попробуй поставить с "port" коллекции
или через /stand/sysinstall (он привинтит все что надо: SNMP и тд)он оперирует пакаджами
  Рекомендовать в FAQ | Cообщить модератору | Наверх

2. "RE: Не могу установить mrtg-2.9.9"
Сообщение от Дмитрий emailИскать по авторуВ закладки on 26-Мрт-01, 11:40  (MSK)
>Попробуй поставить с "port" коллекции
А что это за коллекция и где ее взять?

>или через /stand/sysinstall (он привинтит все
>что надо: SNMP и тд)он
>оперирует пакаджами
У меня на Mandrake такого нет.


  Рекомендовать в FAQ | Cообщить модератору | Наверх

3. "RE: Не могу установить mrtg-2.9.9"
Сообщение от Sergey Vlasov Искать по авторуВ закладки on 27-Мрт-01, 23:50  (MSK)
А что по этому поводу пишется в config.log?

(Именно в этот файл стоит в первую очередь смотреть при проблемах с конфигураторами на базе GNU autoconf - т.е. практически со всеми.)

  Рекомендовать в FAQ | Cообщить модератору | Наверх

4. "RE: Не могу установить mrtg-2.9.9"
Сообщение от Дмитрий Искать по авторуВ закладки on 29-Мрт-01, 14:21  (MSK)
>А что по этому поводу пишется
>в config.log?
>
>(Именно в этот файл стоит в
>первую очередь смотреть при проблемах
>с конфигураторами на базе GNU
>autoconf - т.е. практически со
>всеми.)
А config.log пишет вот что:

configure:1305: checking for gd.h
configure:1315: gcc -E  -DGFORM_GD=gdImageGif -DGFORM_GD=gdImagePng conftest.c >/dev/null 2>conftest.out
*Initialization*:1: warning: `GFORM_GD' redefined
*Initialization*:1: warning: this is the location of the previous definition
configure: failed program was:
#line 1310 "configure"
#include "confdefs.h"
#include <gd.h>

  Рекомендовать в FAQ | Cообщить модератору | Наверх

5. "Напиши 'gd.h' вместо <gd.h> и все."
Сообщение от Dmitry Искать по авторуВ закладки on 29-Мрт-01, 15:12  (MSK)
.
  Рекомендовать в FAQ | Cообщить модератору | Наверх

6. "RE: Напиши "
Сообщение от Дмитрий emailИскать по авторуВ закладки on 29-Мрт-01, 15:54  (MSK)
В место чего?
  Рекомендовать в FAQ | Cообщить модератору | Наверх

7. "Скобки за ТАГ приняли и удалили :)"
Сообщение от Dmitry Искать по авторуВ закладки on 29-Мрт-01, 16:36  (MSK)
configure:
#line 1310 "configure"
#include "confdefs.h"
#include <gd.h>
         ^^^^^^
         "gd.h"
  Рекомендовать в FAQ | Cообщить модератору | Наверх

8. "RE: Скобки за ТАГ приняли и удалили :)"
Сообщение от Дмитрий emailИскать по авторуВ закладки on 30-Мрт-01, 18:02  (MSK)
>configure:
>#line 1310 "configure"
>#include "confdefs.h"
>#include <gd.h>
>      
>   ^^^^^^
>      
>   "gd.h"
Мне кажется, что интерпретатору все равно кавычки или скобки. Вобщем с исправлениями ничего не вышло. Дело наверное где-то в самом алгоритме скипта.
  Рекомендовать в FAQ | Cообщить модератору | Наверх


Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Пожалуйста, прежде чем написать сообщение, ознакомьтесь с данными рекомендациями.




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру