The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"PHP APACHE MYSQL"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы OpenNET: Виртуальная конференция (Public)
Изначальное сообщение [Проследить за развитием треда]

"PHP APACHE MYSQL"  
Сообщение от Denvut email(ok) on 26-Фев-06, 07:30 
Доброго времени суток! У меня такой вопрос: На текущий момент на серваке стоит Связка Апач Пхп МУскл и Резин -все замечательно работает за исключением того что пхп не видит мускл, как мне обновить версию пхп не меняя ни чего остального добавив лишь только поддержку мускула, я новичок поэтому делал по тупому скачал пхп4.4 зайдя в папку ./configure --with-mysqsl --with-apxs патом make make install - по ходу всех действий сообщений об ошибках не поступало, но в итоге ничего не произошло, апачь как юзал пхп4.2 так остался. Как подменить(заменить) библиотеку которую юзает Апач
Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

 Оглавление

  • PHP APACHE MYSQL, Rossa, 11:34 , 26-Фев-06, (1)  
    • PHP APACHE MYSQL, Denvut, 05:28 , 02-Мрт-06, (4)  
  • PHP APACHE MYSQL, redmoon, 16:28 , 26-Фев-06, (2)  
    • PHP APACHE MYSQL, Denvut, 05:26 , 02-Мрт-06, (3)  
      • PHP APACHE MYSQL, satelit, 06:24 , 02-Мрт-06, (5)  
      • PHP APACHE MYSQL, redmoon, 10:01 , 02-Мрт-06, (6)  
  • PHP APACHE MYSQL, usama, 14:26 , 02-Мрт-06, (7)  
  • PHP APACHE MYSQL, redmoon, 14:38 , 02-Мрт-06, (8)  
    • PHP APACHE MYSQL, Denvut, 04:26 , 03-Мрт-06, (9)  
  • PHP APACHE MYSQL, SubGun, 14:01 , 03-Мрт-06, (10)  

Сообщения по теме [Сортировка по времени, UBB]


1. "PHP APACHE MYSQL"  
Сообщение от Rossa on 26-Фев-06, 11:34 
>Доброго времени суток! У меня такой вопрос: На текущий момент на серваке
>стоит Связка Апач Пхп МУскл и Резин -все замечательно работает за
>исключением того что пхп не видит мускл, как мне обновить версию
>пхп не меняя ни чего остального добавив лишь только поддержку мускула,
>я новичок поэтому делал по тупому скачал пхп4.4 зайдя в папку
>./configure --with-mysqsl --with-apxs патом make make install - по ходу всех
>действий сообщений об ошибках не поступало, но в итоге ничего не
>произошло, апачь как юзал пхп4.2 так остался. Как подменить(заменить) библиотеку которую
>юзает Апач


Не путай PHP и mod_php.

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

4. "PHP APACHE MYSQL"  
Сообщение от Denvut email(??) on 02-Мрт-06, 05:28 
>>Доброго времени суток! У меня такой вопрос: На текущий момент на серваке
>>стоит Связка Апач Пхп МУскл и Резин -все замечательно работает за
>>исключением того что пхп не видит мускл, как мне обновить версию
>>пхп не меняя ни чего остального добавив лишь только поддержку мускула,
>>я новичок поэтому делал по тупому скачал пхп4.4 зайдя в папку
>>./configure --with-mysqsl --with-apxs патом make make install - по ходу всех
>>действий сообщений об ошибках не поступало, но в итоге ничего не
>>произошло, апачь как юзал пхп4.2 так остался. Как подменить(заменить) библиотеку которую
>>юзает Апач
>
>
>Не путай PHP и mod_php.
Так а можно разиличия? тоесть мне надо скачать архив не с пхп с а с мод_пхп и его уже конфигурять и инсталить?


Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

2. "PHP APACHE MYSQL"  
Сообщение от redmoon email(??) on 26-Фев-06, 16:28 
>Доброго времени суток! У меня такой вопрос: На текущий момент на серваке
>стоит Связка Апач Пхп МУскл и Резин -все замечательно работает за
>исключением того что пхп не видит мускл, как мне обновить версию
>пхп не меняя ни чего остального добавив лишь только поддержку мускула,
>я новичок поэтому делал по тупому скачал пхп4.4 зайдя в папку
>./configure --with-mysqsl --with-apxs патом make make install - по ходу всех
>действий сообщений об ошибках не поступало, но в итоге ничего не
>произошло, апачь как юзал пхп4.2 так остался. Как подменить(заменить) библиотеку которую
>юзает Апач

а рестартонул апач после обновления ?

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

3. "PHP APACHE MYSQL"  
Сообщение от Denvut email(??) on 02-Мрт-06, 05:26 
>>Доброго времени суток! У меня такой вопрос: На текущий момент на серваке
>>стоит Связка Апач Пхп МУскл и Резин -все замечательно работает за
>>исключением того что пхп не видит мускл, как мне обновить версию
>>пхп не меняя ни чего остального добавив лишь только поддержку мускула,
>>я новичок поэтому делал по тупому скачал пхп4.4 зайдя в папку
>>./configure --with-mysqsl --with-apxs патом make make install - по ходу всех
>>действий сообщений об ошибках не поступало, но в итоге ничего не
>>произошло, апачь как юзал пхп4.2 так остался. Как подменить(заменить) библиотеку которую
>>юзает Апач
>
>а рестартонул апач после обновления ?

Да рестартанул да и не один раз толку ноль

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

5. "PHP APACHE MYSQL"  
Сообщение от satelit on 02-Мрт-06, 06:24 
Если не сильно разбираешся в этом, то просто скачай готовый пакет для своего дистриба и переставь его.
Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

6. "PHP APACHE MYSQL"  
Сообщение от redmoon email(??) on 02-Мрт-06, 10:01 
>>>Доброго времени суток! У меня такой вопрос: На текущий момент на серваке
>>>стоит Связка Апач Пхп МУскл и Резин -все замечательно работает за
>>>исключением того что пхп не видит мускл, как мне обновить версию
>>>пхп не меняя ни чего остального добавив лишь только поддержку мускула,
>>>я новичок поэтому делал по тупому скачал пхп4.4 зайдя в папку
>>>./configure --with-mysqsl --with-apxs патом make make install - по ходу всех
>>>действий сообщений об ошибках не поступало, но в итоге ничего не
>>>произошло, апачь как юзал пхп4.2 так остался. Как подменить(заменить) библиотеку которую
>>>юзает Апач
>>
>>а рестартонул апач после обновления ?
>
>Да рестартанул да и не один раз толку ноль
ткни пхп мордой явно в МайСКЛ
--with-mysql=/path/to/you/mysql/lib-directory
--with-mysql-sock=/path/to/you/mysql.sock-file


Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

7. "PHP APACHE MYSQL"  
Сообщение от usama email(ok) on 02-Мрт-06, 14:26 
>Доброго времени суток! У меня такой вопрос: На текущий момент на серваке
>стоит Связка Апач Пхп МУскл и Резин -все замечательно работает за
>исключением того что пхп не видит мускл, как мне обновить версию
>пхп не меняя ни чего остального добавив лишь только поддержку мускула,
>я новичок поэтому делал по тупому скачал пхп4.4 зайдя в папку
>./configure --with-mysqsl --with-apxs патом make make install - по ходу всех
>действий сообщений об ошибках не поступало, но в итоге ничего не
>произошло, апачь как юзал пхп4.2 так остался. Как подменить(заменить) библиотеку которую
>юзает Апач

Посмотри в httpd.conf какую библиотеку php он поключает.

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

8. "PHP APACHE MYSQL"  
Сообщение от redmoon email(??) on 02-Мрт-06, 14:38 
>Доброго времени суток! У меня такой вопрос: На текущий момент на серваке
>стоит Связка Апач Пхп МУскл и Резин -все замечательно работает за
>исключением того что пхп не видит мускл, как мне обновить версию
>пхп не меняя ни чего остального добавив лишь только поддержку мускула,
>я новичок поэтому делал по тупому скачал пхп4.4 зайдя в папку
>./configure --with-mysqsl --with-apxs патом make make install - по ходу всех
>действий сообщений об ошибках не поступало, но в итоге ничего не
>произошло, апачь как юзал пхп4.2 так остался. Как подменить(заменить) библиотеку которую
>юзает Апач

да точно, зделай-ка
cat httpd.conf | grep libphp

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

9. "PHP APACHE MYSQL"  
Сообщение от Denvut email(ok) on 03-Мрт-06, 04:26 
>>Доброго времени суток! У меня такой вопрос: На текущий момент на серваке
>>стоит Связка Апач Пхп МУскл и Резин -все замечательно работает за
>>исключением того что пхп не видит мускл, как мне обновить версию
>>пхп не меняя ни чего остального добавив лишь только поддержку мускула,
>>я новичок поэтому делал по тупому скачал пхп4.4 зайдя в папку
>>./configure --with-mysqsl --with-apxs патом make make install - по ходу всех
>>действий сообщений об ошибках не поступало, но в итоге ничего не
>>произошло, апачь как юзал пхп4.2 так остался. Как подменить(заменить) библиотеку которую
>>юзает Апач
>
>да точно, зделай-ка
>cat httpd.conf | grep libphp

Всем спасибо за советы буду пробовать.

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

10. "PHP APACHE MYSQL"  
Сообщение от SubGun (??) on 03-Мрт-06, 14:01 
Удаляем /usr/local/libexec/apache2/libphp4.so
./configure  --with-apxs=путь --enable-so --with-mysql=путь
"Путь" нужен, если при устанавливали апач или мускуль из сырцов и использовали --prefix отличный от /usr/local.
Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру