The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"Не получается завести VLAN на FreeBSD"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы OpenNET: Виртуальная конференция (Public)
Изначальное сообщение [Проследить за развитием треда]

"Не получается завести VLAN на FreeBSD"  
Сообщение от Monty email(ok) on 02-Сен-06, 10:26 
Настроил на двух машинах с FreeBSD VLAN интерфейсы и подлключил к коммутатору в тэгированные порты. Пинг от сервера к серверу не идет, почему? Вот мои настройки:

FreeBSD сервер 1:
bge0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
        options=1a<TXCSUM,VLAN_MTU,VLAN_HWTAGGING>
        ether 00:02:a5:e7:56:45
        media: Ethernet autoselect (100baseTX <full-duplex>)
        status: active
vlan0: flags=9843<UP,BROADCAST,RUNNING,SIMPLEX,LINK0,MULTICAST> mtu 1500
        inet 10.3.0.1 netmask 0xffff0000 broadcast 10.3.255.255
        ether 00:02:a5:e7:56:45
        media: Ethernet autoselect (100baseTX <full-duplex>)
        status: active
        vlan: 3 parent interface: bge0

FreeBSD сервер 2:
bge0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
        options=1a<TXCSUM,VLAN_MTU,VLAN_HWTAGGING>
        ether 00:02:a5:e7:56:9f
        media: Ethernet autoselect (100baseTX <full-duplex>)
        status: active
vlan0: flags=9843<UP,BROADCAST,RUNNING,SIMPLEX,LINK0,MULTICAST> mtu 1500
        inet 10.3.0.2 netmask 0xffff0000 broadcast 10.3.255.255
        ether 00:02:a5:e7:56:9f
        media: Ethernet autoselect (100baseTX <full-duplex>)
        status: active
        vlan: 3 parent interface: bge0

Пунг с сервера 1:
PING 10.3.0.2 (10.3.0.2): 56 data bytes
ping: sendto: Host is down
ping: sendto: Host is down

В чем же проблема?

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


1. "Не получается завести VLAN на FreeBSD"  
Сообщение от TrecK on 02-Сен-06, 10:58 
>Настроил на двух машинах с FreeBSD VLAN интерфейсы и подлключил к коммутатору
>в тэгированные порты. Пинг от сервера к серверу не идет, почему?
>Вот мои настройки:
>
>FreeBSD сервер 1:
>bge0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
>        options=1a<TXCSUM,VLAN_MTU,VLAN_HWTAGGING>
>        ether 00:02:a5:e7:56:45
>        media: Ethernet autoselect (100baseTX <full-duplex>)
>        status: active
>vlan0: flags=9843<UP,BROADCAST,RUNNING,SIMPLEX,LINK0,MULTICAST> mtu 1500
>        inet 10.3.0.1 netmask 0xffff0000
>broadcast 10.3.255.255
>        ether 00:02:a5:e7:56:45
>        media: Ethernet autoselect (100baseTX <full-duplex>)
>        status: active
>        vlan: 3 parent interface:
>bge0
>
>FreeBSD сервер 2:
>bge0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
>        options=1a<TXCSUM,VLAN_MTU,VLAN_HWTAGGING>
>        ether 00:02:a5:e7:56:9f
>        media: Ethernet autoselect (100baseTX <full-duplex>)
>        status: active
>vlan0: flags=9843<UP,BROADCAST,RUNNING,SIMPLEX,LINK0,MULTICAST> mtu 1500
>        inet 10.3.0.2 netmask 0xffff0000
>broadcast 10.3.255.255
>        ether 00:02:a5:e7:56:9f
>        media: Ethernet autoselect (100baseTX <full-duplex>)
>        status: active
>        vlan: 3 parent interface:
>bge0
>
>Пунг с сервера 1:
>PING 10.3.0.2 (10.3.0.2): 56 data bytes
>ping: sendto: Host is down
>ping: sendto: Host is down
>
>В чем же проблема?

пропиши на bge0 любой IP адрес, у меня часто именно из-за его отсутствия и не работало

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

2. "Не получается завести VLAN на FreeBSD"  
Сообщение от Romik (??) on 02-Сен-06, 14:52 
еще фишка: иногда просит mtu=1496
Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

3. "Не получается завести VLAN на FreeBSD"  
Сообщение от FiN (??) on 03-Сен-06, 08:54 
>Настроил на двух машинах с FreeBSD VLAN интерфейсы и подлключил к коммутатору
>в тэгированные порты. Пинг от сервера к серверу не идет, почему?
>Вот мои настройки:
>
настройки правльные, соедени пачкордом, без коммутатора, возможно проблема в его настройках...


Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

4. "Не получается завести VLAN на FreeBSD"  
Сообщение от Deus email(??) on 03-Сен-06, 18:32 
>Настроил на двух машинах с FreeBSD VLAN интерфейсы и подлключил к коммутатору
>в тэгированные порты. Пинг от сервера к серверу не идет, почему?
>Вот мои настройки:
>
>FreeBSD сервер 1:
>bge0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
>        options=1a<TXCSUM,VLAN_MTU,VLAN_HWTAGGING>
>        ether 00:02:a5:e7:56:45
>        media: Ethernet autoselect (100baseTX <full-duplex>)
>        status: active
>vlan0: flags=9843<UP,BROADCAST,RUNNING,SIMPLEX,LINK0,MULTICAST> mtu 1500
>        inet 10.3.0.1 netmask 0xffff0000
>broadcast 10.3.255.255
>        ether 00:02:a5:e7:56:45
>        media: Ethernet autoselect (100baseTX <full-duplex>)
>        status: active
>        vlan: 3 parent interface:
>bge0
>
>FreeBSD сервер 2:
>bge0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
>        options=1a<TXCSUM,VLAN_MTU,VLAN_HWTAGGING>
>        ether 00:02:a5:e7:56:9f
>        media: Ethernet autoselect (100baseTX <full-duplex>)
>        status: active
>vlan0: flags=9843<UP,BROADCAST,RUNNING,SIMPLEX,LINK0,MULTICAST> mtu 1500
>        inet 10.3.0.2 netmask 0xffff0000
>broadcast 10.3.255.255
>        ether 00:02:a5:e7:56:9f
>        media: Ethernet autoselect (100baseTX <full-duplex>)
>        status: active
>        vlan: 3 parent interface:
>bge0
>
>Пунг с сервера 1:
>PING 10.3.0.2 (10.3.0.2): 56 data bytes
>ping: sendto: Host is down
>ping: sendto: Host is down
>
>В чем же проблема?

1) На обоих серверах ifconfig vlan0 up
2) Настроики коммутатора точно правильные?

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

5. "Не получается завести VLAN на FreeBSD"  
Сообщение от Monty email(ok) on 04-Сен-06, 21:39 
>1) На обоих серверах ifconfig vlan0 up
Делал - не помогает.

>2) Настроики коммутатора точно правильные?
А собственно какие там настройки-то особенный должны быть? Оба порта магистральные. В некоторых виланах указано, что они числятся магистральными.

023 Up   Auto   MDI  0100 Full-Duplex 00001 00001 None     Forwarding
024 Up   Auto   MDI  0100 Full-Duplex 00001 00001 None     Forwarding

Написано, что они принадлежат первому влану? Может нужно в первом влане их сделать транковыми еще?

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

6. "Не получается завести VLAN на FreeBSD"  
Сообщение от Piligrim (??) on 05-Сен-06, 00:34 
Недавно тоже на FreeBSD 6.1 vlan поднимал до винды 2003. При этом использовал сетевухи интелёвые. Кста в ман vlan написано какие сетевые поддерживаются нативно, какие нет и т.д.

Ну так вот 2 дня я мучался, нашёл маны в инете, всё ок, а не работает. В итоге реальныому интерфейсу просто айпишник прописал и всё заработало.

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

7. "Не получается завести VLAN на FreeBSD"  
Сообщение от Maxim (??) on 05-Сен-06, 15:29 
>Недавно тоже на FreeBSD 6.1 vlan поднимал до винды 2003. При этом
>использовал сетевухи интелёвые. Кста в ман vlan написано какие сетевые поддерживаются
>нативно, какие нет и т.д.
>
>Ну так вот 2 дня я мучался, нашёл маны в инете, всё
>ок, а не работает. В итоге реальныому интерфейсу просто айпишник прописал
>и всё заработало.

по-моему ip вовсе необязательно, достаточно в rc.conf прописать  ifconfig_имя_реального_инт="up"

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру