The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"cisco port redirect"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы OpenNET: Виртуальная конференция (Public)
Изначальное сообщение [Проследить за развитием треда]

"cisco port redirect"  
Сообщение от redmoon email(??) on 07-Июн-07, 19:23 
вопрос достаточно прост но тем не менее.
имеем cisco 2801.
одним фейсом в локаль, другим в мир.
поднят нат. все успешно ходят в интернет через циско.
в локали за адресом  192.168.0.254 стоит сервачог. на него нужно редиректнуть несколько портов. как это зделать? в цисках секу но не столько.

а то заколебался попадать сначала на циску а потом оттуда телнетом на сервер.
вот конфиг циско:

interface FastEthernet0/0
ip address мой_реальник  маска_реальника
ip nat outside
no ip mroute-cache
duplex auto
speed auto
no cdp enable
!

......................
.....................
..................

interface FastEthernet0/1
ip address 192.168.0.123 255.255.255.0      локалка
ip nat inside
no ip mroute-cache
duplex auto
speed auto
no cdp enable
!

ip route 0.0.0.0 0.0.0.0 шлюз_по_дефолту_для_реальника_циски
!
............
..............
ip nat pool FUCKING-POOL мой_реальник   мой_реальник netmask маска_реальника
ip nat inside source route-map SHIT-MAP pool FUCKING-POOL overload
!
access-list 1 permit 192.168.0.0 0.0.0.255

!
.............
..........
route-map SHIT-MAP permit 10                         роутинг ната на нужный мап.
match ip address 1
match interface FastEthernet0/0


вот нужно просто тупо с реальника на ип адрес внутрееней сети кинуть несколько портов - как это зделать. С радостью почитал бы = но некогда очень. для гуру написать "мурзилку" для меня, я думаю, не было бы проблем. заранее спасибо.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


1. "cisco port redirect"  
Сообщение от andy email(??) on 08-Июн-07, 04:48 
ip nat inside source static tcp 192.168.0.254 22 12.34.45.67 1111 extendable
ip nat inside source static tcp 192.168.0.254 25 12.34.45.67 1112 extendable
?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "cisco port redirect"  
Сообщение от redmoon email(??) on 08-Июн-07, 11:21 
>ip nat inside source static tcp 192.168.0.254 22 12.34.45.67 1111 extendable
>ip nat inside source static tcp 192.168.0.254 25 12.34.45.67 1112 extendable
>?


спос. разобрался . помогло.
а теперь далее не могли бы вы помочь.
у меня циска натит. как ее заставить  отдавать в биллинг стату по нет флоу при нате. читаю - понимаю что как то люди поворачивают на лупбэк этот трафик - но я не очень понимаю зачем.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "cisco port redirect"  
Сообщение от YuryD (??) on 08-Июн-07, 11:48 
>>ip nat inside source static tcp 192.168.0.254 22 12.34.45.67 1111 extendable
>>ip nat inside source static tcp 192.168.0.254 25 12.34.45.67 1112 extendable
>>?
>
>
>у меня циска натит. как ее заставить  отдавать в биллинг стату
>по нет флоу при нате. читаю - понимаю что как то


http://www.netup.ru/articles.php?n=10

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "cisco port redirect"  
Сообщение от redmoon email(??) on 08-Июн-07, 12:20 
>>>ip nat inside source static tcp 192.168.0.254 22 12.34.45.67 1111 extendable
>>>ip nat inside source static tcp 192.168.0.254 25 12.34.45.67 1112 extendable
>>>?
>>
>>
>>у меня циска натит. как ее заставить  отдавать в биллинг стату
>>по нет флоу при нате. читаю - понимаю что как то
>
>
>http://www.netup.ru/articles.php?n=10


если бы все было так просто  :)))
зделано в точности как там написано но, тем не менее:
вот лупбэк:
!
interface Loopback0
ip address 10.0.0.1 255.255.255.255
ip route-cache policy
ip route-cache flow
!
interface FastEthernet0/0
ip address мой_ип_адресс_интернета моя_маска
ip nat outside
ip route-cache policy
ip route-cache flow
ip policy route-map ACC
no ip mroute-cache
duplex auto
speed auto
no cdp enable
!
interface FastEthernet0/1
ip address 192.168.0.250 255.255.255.0
ip nat inside
ip route-cache policy
ip route-cache flow
no ip mroute-cache
duplex auto
speed auto
no cdp enable
!
ip route 0.0.0.0 0.0.0.0 шлюз_моего_провайдера.
ip flow-export version 5
ip flow-export destination 192.168.0.254 9996
!
ip nat inside source list 1 interface FastEthernet0/0 overload
!
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 108 permit ip any 192.168.0.0 0.0.0.255
route-map ACC permit 10
match ip address 108
set interface Loopback0 FastEthernet0/1

вот при такой конфигурации я блин вижу - то что вошло в циску на вшнешний интерфейс из мира, и то что вышло от юзеров в интернет.
то есть вижу cisco-in и users-out а куда делись cisco-out и users-in ?
ПАМАГИТЕ %)
вот при такой конфе вот что show ip cache flow дает:
SrcIf         SrcIPaddress    DstIf         DstIPaddress    Pr SrcP DstP  Pkts
Fa0/0         85.249.159.130  Local         213.87.44.229   06 0D0B 0017    45
Fa0/0         213.87.44.129   Local         213.87.44.229   11 0035 F817   423
Fa0/1         192.168.0.115   Fa0/0         64.12.28.68     06 E369 1446     1
Fa0/1         169.254.230.133 Null          255.255.255.255 11 0044 0043     1
Fa0/1         192.168.0.75    Null          81.192.53.20    06 0EE6 0035     2
Fa0/1         192.168.0.75    Null          81.192.53.20    06 0EE8 0035     2
Fa0/1         192.168.0.75    Null          81.192.53.20    06 0EEC 0035     2
Fa0/0         64.12.28.68     Fa0/1         213.87.44.229   06 1446 E369     1
Fa0/1         192.168.0.76    Null          192.168.0.255   11 0089 0089   815
Fa0/1         192.168.0.55    Null          192.168.0.255   11 008A 008A     1
Fa0/1         192.168.0.55    Null          192.168.0.255   11 0089 0089     1

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру