The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"не ставится perl 5.8"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы OpenNET: Виртуальная конференция (Public)
Изначальное сообщение [Проследить за развитием треда]

"не ставится perl 5.8"  
Сообщение от Palich email(ok) on 29-Июн-07, 01:01 
Дело в следующем, никак не могу поставить perl. Сгоряча я ему сделал deinstall и теперь не могу поставить обратно. Выдаёт след. ошибку:
===>  Vulnerability check disabled, database not found

You may use the following build options:

        WITH_DEBUGGING=yes        Build perl with debugging support.
        WITH_GDBM=yes             Build GDBM_File extension.
        WITHOUT_PERL_MALLOC=yes   Use FreeBSD system malloc
                                  (uses less memory, but slower).
        WITHOUT_PERL_64BITINT=yes Disable 64 bit integers
                                  (affects only 32-bit platforms).
        WITH_THREADS=yes          Build threaded perl.
        ENABLE_SUIDPERL=yes       Also build set-user-id suidperl binary.

===>  Extracting for perl-5.8.7
=> Checksum OK for perl-5.8.7.tar.bz2.
=> Checksum OK for BSDPAN-5.8.7.tar.bz2.
=> Checksum OK for defined-or-5.8.7.bz2.
/usr/bin/tar: not found
*** Error code 1

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


1. "не ставится perl 5.8"  
Сообщение от crash (ok) on 29-Июн-07, 02:12 
так пишет же что нет /usr/bin/tar. Куда дели tar?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "не ставится perl 5.8"  
Сообщение от Белоиванов Денис email on 29-Июн-07, 12:58 
>так пишет же что нет /usr/bin/tar. Куда дели tar?


ОН лежит там же но называется bsdtar  кинь линк  и  будет  щастя.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "не ставится perl 5.8"  
Сообщение от Palich email(ok) on 10-Июл-07, 21:59 
>>так пишет же что нет /usr/bin/tar. Куда дели tar?
>
>
>ОН лежит там же но называется bsdtar  кинь линк  и
> будет  щастя.
ну тепер он выдаёт другую ошибку:

===>  Building for perl-5.8.7
`sh  cflags "optimize='-O2 -fno-strict-aliasing -pipe'" miniperlmain.o` -DPIC -fPIC miniperlmain.c
          CCCMD =  cc -DPERL_CORE -c -DAPPLLIB_EXP="/usr/local/lib/perl5/5.8.7/BSDPAN" -DHAS_FPSETMASK -DHAS_FLOATINGPOINT_H -fno-strict-aliasing -pipe -I/usr/local/include -O2 -fno-strict-aliasing -pipe  -Wall
In file included from perl.h:37,
                 from miniperlmain.c:36:
config.h:3107:3: invalid preprocessing directive #NEED_VA_COPY
config.h:3764:3: invalid preprocessing directive #I_STDARG
config.h:3765:3: invalid preprocessing directive #I_VARARGS
In file included from miniperlmain.c:36:
perl.h:937:19: errno.h: No such file or directory
perl.h:2234:33: floatingpoint.h: No such file or directory
*** Error code 1

Stop in /usr/ports/lang/perl5.8/work/perl-5.8.7.
*** Error code 1

Stop in /usr/ports/lang/perl5.8.


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "не ставится perl 5.8"  
Сообщение от переставь винду около 1 часа или жди ответахрен его знает сколько email on 29-Июн-07, 20:56 
>Дело в следующем, никак не могу поставить perl. Сгоряча я ему сделал
>deinstall и теперь не могу поставить обратно. Выдаёт след. ошибку:
>===>  Vulnerability check disabled, database not found
>
>You may use the following build options:
>
>        WITH_DEBUGGING=yes    
>    Build perl with debugging support.
>        WITH_GDBM=yes    
>         Build GDBM_File
>extension.
>        WITHOUT_PERL_MALLOC=yes   Use
>FreeBSD system malloc
>            
>          
>          
>(uses less memory, but slower).
>        WITHOUT_PERL_64BITINT=yes Disable 64 bit
>integers
>            
>          
>          
>(affects only 32-bit platforms).
>        WITH_THREADS=yes    
>      Build threaded perl.
>        ENABLE_SUIDPERL=yes    
>   Also build set-user-id suidperl binary.
>
>===>  Extracting for perl-5.8.7
>=> Checksum OK for perl-5.8.7.tar.bz2.
>=> Checksum OK for BSDPAN-5.8.7.tar.bz2.
>=> Checksum OK for defined-or-5.8.7.bz2.
>/usr/bin/tar: not found
>*** Error code 1


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру