The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Apach22 + MySQL, проблема с либой для MySQL_PHP"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы OpenNET: Виртуальная конференция (Public)
Изначальное сообщение [ Отслеживать ]

"Apach22 + MySQL, проблема с либой для MySQL_PHP"  +/
Сообщение от mancubus email(ok) on 09-Июл-09, 13:58 
Странное сообщение появляется при старте Apache22:
<code>
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20060613/mysql.so' - Shared object "libmysqlclient.so.15" not found, required by "mysql.so" in Unknown on line 0
[Thu Jul 09 13:52:21 2009] [notice] Digest: generating secret for digest authentication ...
[Thu Jul 09 13:52:21 2009] [notice] Digest: done
[Thu Jul 09 13:52:22 2009] [notice] Apache/2.2.11 (FreeBSD) mod_ssl/2.2.11 OpenSSL/0.9.8e DAV/2 PHP/5.2.10 configured -- resu
</code>
При этом все библиотеки есть:
$ ls -la /usr/local/lib/mysql/ | grep .so
lrwxr-xr-x   1 root  wheel        20 Jul  6 22:47 libmysqlclient.so -> libmysqlclient.so.16
-rwxr-xr-x   1 root  wheel    531255 Jul  6 22:47 libmysqlclient.so.16
lrwxr-xr-x   1 root  wheel        22 Jul  6 22:47 libmysqlclient_r.so -> libmysqlclient_r.so.16
-rwxr-xr-x   1 root  wheel    541480 Jul  6 22:47 libmysqlclient_r.so.16

Система:
$ uname -rs
FreeBSD 7.1-RELEASE

MySQL 6.0 client+server

Куда ещё посмотреть?

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Apach22 + MySQL, проблема с либой для MySQL_PHP"  +/
Сообщение от ALex_hha (ok) on 09-Июл-09, 14:05 
>[оверквотинг удален]
>-rwxr-xr-x   1 root  wheel    541480 Jul
> 6 22:47 libmysqlclient_r.so.16
>
>Система:
>$ uname -rs
>FreeBSD 7.1-RELEASE
>
>MySQL 6.0 client+server
>
> Куда ещё посмотреть?

php был собран с другой версией MySQL

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Apach22 + MySQL, проблема с либой для MySQL_PHP"  +/
Сообщение от mancubus email(ok) on 09-Июл-09, 14:09 
>[оверквотинг удален]
>>
>>Система:
>>$ uname -rs
>>FreeBSD 7.1-RELEASE
>>
>>MySQL 6.0 client+server
>>
>> Куда ещё посмотреть?
>
>php был собран с другой версией MySQL

pkg_info | grep sql
mysql-client-6.0.11 Multithreaded SQL database (client)
mysql-server-6.0.11 Multithreaded SQL database (server)
php5-mssql-5.2.10   The mssql shared extension for php
php5-mysql-5.2.10   The mysql shared extension for php
php5-mysqli-5.2.10  The mysqli shared extension for php


Да, судя по всему проблема именно тут .... Спасибо

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Apach22 + MySQL, проблема с либой для MySQL_PHP"  +/
Сообщение от Michael (??) on 09-Июл-09, 14:06 
>[оверквотинг удален]
>Shared object "libmysqlclient.so.15" not found, required by "mysql.so" in Unknown on
>line 0
>При этом все библиотеки есть:
>$ ls -la /usr/local/lib/mysql/ | grep .so
>lrwxr-xr-x   1 root  wheel        20 Jul  6 22:47 libmysqlclient.so -> libmysqlclient.so.16
>-rwxr-xr-x   1 root  wheel    531255 Jul
> 6 22:47 libmysqlclient.so.16
>lrwxr-xr-x   1 root  wheel        22 Jul  6 22:47 libmysqlclient_r.so -> libmysqlclient_r.so.16
>-rwxr-xr-x   1 root  wheel    541480 Jul
> 6 22:47 libmysqlclient_r.so.16

говорите есть? действительно есть, но вот только версия не та

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Apach22 + MySQL, проблема с либой для MySQL_PHP"  +/
Сообщение от mancubus email(ok) on 09-Июл-09, 14:08 
>говорите есть? действительно есть, но вот только версия не та

libmysqlclient.so.15 vs libmysqlclient_r.so.16 ? Тут корень зла? Что проще пересобрать PHP или MySql? И что нужно пересобирать?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Apach22 + MySQL, проблема с либой для MySQL_PHP"  +/
Сообщение от ALex_hha (ok) on 09-Июл-09, 14:21 
>>говорите есть? действительно есть, но вот только версия не та
>
>libmysqlclient.so.15 vs libmysqlclient_r.so.16 ? Тут корень зла? Что проще пересобрать PHP или
>MySql? И что нужно пересобирать?

Надо пересобрать php. А зачем тебе 6ка mysql?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "Apach22 + MySQL, проблема с либой для MySQL_PHP"  +/
Сообщение от mancubus email(ok) on 09-Июл-09, 14:24 
>Надо пересобрать php. А зачем тебе 6ка mysql?

Могу грохнуть, пока там записей не так много. А какую версию ставить?


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "Apach22 + MySQL, проблема с либой для MySQL_PHP"  +/
Сообщение от mancubus email(ok) on 09-Июл-09, 14:23 
Мужики, засада... не выходит каменный цветок: Вот что есть у меня в системе(порты обновлены)

Port:   mysql-server-5.1.35
Path:   /usr/ports/databases/mysql51-server
Info:   Multithreaded SQL database (server)
Maint:  ale@FreeBSD.org
B-deps: gettext-0.17_1 gmake-3.81_3 libiconv-1.13 libtool-1.5.26 mysql-client-5.1.35
R-deps: mysql-client-5.1.35
WWW:    http://www.mysql.com/

Port:   mysql-server-6.0.11
Path:   /usr/ports/databases/mysql60-server
Info:   Multithreaded SQL database (server)
Maint:  ale@FreeBSD.org
B-deps: gettext-0.17_1 gmake-3.81_3 libiconv-1.13 libtool-1.5.26 mysql-client-6.0.11
R-deps: mysql-client-6.0.11
WWW:    http://www.mysql.com/

и что есть про php-mysql

Port:   php5-mysql-5.2.10
Path:   /usr/ports/databases/php5-mysql
Info:   The mysql shared extension for php
Maint:  ale@FreeBSD.org
B-deps: autoconf-2.62 autoconf-wrapper-20071109 libiconv-1.13 libxml2-2.7.3 m4-1.4.13,1 mysql-client-5.0.83 perl-5.8.9_3 php5-5.2.10 pkg-config-0.23_1
R-deps: libiconv-1.13 libxml2-2.7.3 mysql-client-5.0.83 php5-5.2.10 pkg-config-0.23_1
WWW:    http://www.php.net/


Судя по всему вообще не сходится. Может стащить с сайте нужную версию php5-mysql, если конечно она есть. Как считает сообщество?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "Apach22 + MySQL, проблема с либой для MySQL_PHP"  +/
Сообщение от mancubus email(ok) on 09-Июл-09, 14:27 
Блин, вот туплю... Спрошу по правильному, какую версию SQL нужно поставить, чтобы она работала с php5-mysql?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "Apach22 + MySQL, проблема с либой для MySQL_PHP"  +1 +/
Сообщение от ALex_hha (ok) on 09-Июл-09, 14:55 
>Блин, вот туплю... Спрошу по правильному, какую версию SQL нужно поставить, чтобы
>она работала с php5-mysql?

Мда, как все запущенно. Оставляй MySQL-5.x и пересобирай php. MySQL-6.0 удаляй.

Насчет выбора версии MySQL. На их сайте есть инфа

MySQL Community Server
Current Release (Recommended)
MySQL 5.1—Generally Available (GA) release for production use

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "Apach22 + MySQL, проблема с либой для MySQL_PHP"  +/
Сообщение от Александр (??) on 09-Июл-09, 16:31 
я тут ради пробы поставил апач + 6-ой мускул + пхп5, все работает
правда, я сделал это на 8-ке

единственная проблема была с постфиксадмином,
синтаксис в 6-ке чуть другой, шла ругань при создании таблиц
внес поправки, запустился

/root > [=2Spkg_info | grep sql                                                
[=Smysql-client-6.0.11 Multithreaded SQL database (client)                    
mysql-server-6.0.11 Multithreaded SQL database (server)                        
p5-DBD-mysql60-4.010 MySQL 6.0 driver for the Perl5 Database Interface (DBI)    
php5-mysql-5.2.10   The mysql shared extension for php                          
php5-mysqli-5.2.10  The mysqli shared extension for php                        
php5-pdo_sqlite-5.2.10 The pdo_sqlite shared extension for php                  
php5-pgsql-5.2.10   The pgsql shared extension for php                          
php5-sqlite-5.2.10  The sqlite shared extension for php                        
postgresql-client-8.3.7 PostgreSQL database (client)                            
postgresql-server-8.3.7 The most advanced open-source database available anywher
e                                                                              

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "Apach22 + MySQL, проблема с либой для MySQL_PHP"  +/
Сообщение от mancubus email(ok) on 09-Июл-09, 18:54 
Всем спасибо Комрады!
Даунгрейдился и всё нормально.
mysql-server-5.1.35 Multithreaded SQL database (server)
php5-mysql-5.2.10   The mysql shared extension for php
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру