The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Проблема с пересборкой мира"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы OpenNET: Виртуальная конференция (Public)
Изначальное сообщение [ Отслеживать ]

"Проблема с пересборкой мира"  +/
Сообщение от Oleg__ on 14-Окт-09, 17:46 
В общем после внесения в /etc/make.conf в переменную USE нескольких переменных решил пересобрать мир.
в частности вот как выглядит данная переменная: USE="qt mp3 alsa gtk gnome X mmx mmx2 midi mpeg acpi usb automount"

Вот что получается:


localhost ~ # emerge --update --deep --newuse world

* IMPORTANT: 5 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

Calculating dependencies... done!
[ebuild U ] sys-libs/timezone-data-2009m [2009j]
[ebuild U ] dev-libs/gmp-4.3.1 [4.2.4]
[ebuild U ] app-arch/unzip-6.0-r1 [5.52-r2] USE="bzip2%* unicode%*"
[ebuild U ] app-arch/zip-3.0 [2.32-r1] USE="bzip2%* unicode%*"
[ebuild N ] sys-power/acpid-1.0.10_p3
[ebuild R ] x11-libs/qt-core-4.5.2 USE="-qt3support*"
[ebuild R ] x11-libs/qt-sql-4.5.2 USE="-qt3support*"
[ebuild N ] x11-base/xorg-drivers-1.6 INPUT_DEVICES="keyboard mouse -acecad -aiptek -citron -elographics -evdev -fpit -hyperpen -joystick -mutouch -penmount -synaptics -tslib -virtualbox -vmmouse -void -wacom" VIDEO_CARDS="nvidia -apm -ark -ast -chips -cirrus -dummy -epson -fbdev -fglrx -geode -glint -i128 -i740 (-impact) -imstt -intel -mach64 -mga -neomagic (-newport) -nv -r128 -radeon -radeonhd -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l -vermilion -vesa -via -virtualbox -vmware (-voodoo) -xgi"
[ebuild NS ] sys-libs/db-4.7.25_p4 [4.6.21_p4] USE="-doc -java -nocxx -tcl -test"
[ebuild U ] x11-misc/util-macros-1.3.0 [1.2.1]
[ebuild R ] media-sound/lame-3.98.2-r1 USE="mmx*"
[ebuild R ] media-libs/libtheora-1.0 USE="-encode*"
[ebuild R ] media-video/dirac-1.0.2 USE="mmx*"
[ebuild U ] x11-proto/xproto-7.0.15 [7.0.14]
[ebuild U ] x11-proto/inputproto-1.5.1 [1.5.0]
[ebuild U ] x11-proto/randrproto-1.3.0 [1.2.2]
[ebuild U ] x11-proto/fontsproto-2.1.0 [2.0.2]
[ebuild U ] x11-proto/damageproto-1.2.0 [1.1.0]
[ebuild U ] x11-libs/pixman-0.16.0 [0.14.0-r1] USE="mmx*"
[ebuild U ] x11-libs/libdrm-2.4.13 [2.4.5]
[ebuild U ] x11-proto/dri2proto-2.1 [1.99.3]
[ebuild U ] x11-proto/videoproto-2.3.0 [2.2.2]
[ebuild U ] x11-libs/libpciaccess-0.10.6 [0.10.5]
[ebuild U ] x11-proto/resourceproto-1.1.0 [1.0.2]
[ebuild U ] x11-libs/libICE-1.0.5 [1.0.4]
[ebuild U ] x11-libs/libXau-1.0.5 [1.0.4]
[ebuild U ] x11-proto/xextproto-7.0.5 [7.0.4]
[ebuild U ] x11-libs/libSM-1.1.1 [1.1.0] USE="uuid%*"
[ebuild U ] sys-apps/coreutils-7.5 [7.4]
[ebuild U ] net-misc/wget-1.12 [1.11.4] USE="-idn% -ntlm%"
[ebuild U ] app-editors/nano-2.1.10 [2.1.9]
[ebuild U ] app-misc/ca-certificates-20090709 [20080809]
[ebuild U ] app-admin/eselect-opengl-1.0.8-r1 [1.0.6-r1]
[ebuild N ] x11-proto/xcb-proto-1.5
[ebuild U ] dev-python/pyrex-0.9.8.5-r1 [0.9.8.5]
[ebuild U ] dev-python/pysqlite-2.5.5-r1 [2.5.5]
[ebuild U ] dev-python/gdata-2.0.2 [2.0.0]
[ebuild N ] x11-libs/libxcb-1.4-r1 USE="-debug -doc (-selinux)"
[ebuild U ] x11-proto/glproto-1.4.10 [1.4.9]
[ebuild U ] dev-python/numpy-1.3.0-r1 [1.3.0]
[ebuild U ] x11-libs/libX11-1.2.2 [1.1.5] USE="xcb*"
[ebuild N ] x11-libs/xcb-util-0.3.6 USE="-debug -test"
[ebuild U ] x11-libs/libXext-1.0.5 [1.0.4]
[ebuild U ] x11-libs/libXt-1.0.6 [1.0.5]
[ebuild N ] x11-apps/xwud-1.0.1 USE="-debug"
[ebuild N ] x11-apps/xcmsdb-1.0.1 USE="-debug"
[ebuild N ] x11-apps/xev-1.0.3 USE="-debug"
[ebuild N ] x11-apps/xrefresh-1.0.2 USE="-debug"
[ebuild U ] media-libs/netpbm-10.46.00-r1 [10.46.00]
[ebuild U ] x11-libs/libXrandr-1.3.0 [1.2.3]
[ebuild U ] x11-libs/libXfont-1.4.0 [1.3.4]
[ebuild U ] x11-apps/xkbcomp-1.1.0 [1.0.5]
[ebuild U ] x11-libs/startup-notification-0.10 [0.9]
[ebuild U ] x11-apps/setxkbmap-1.1.0 [1.0.4]
[ebuild N ] x11-apps/xkbevd-1.0.2 USE="-debug"
[ebuild N ] x11-apps/ttmkfdir-3.0.9-r3
[ebuild R ] media-video/ffmpeg-0.5_p19928 USE="mp3*"
[ebuild U ] x11-libs/libXaw-1.0.6 [1.0.5]
[ebuild N ] x11-apps/xcursorgen-1.0.2
[ebuild U ] x11-misc/xkeyboard-config-1.6 [1.5]
[ebuild N ] x11-apps/smproxy-1.0.2 USE="-debug"
[ebuild N ] x11-apps/xinput-1.4.2 USE="-debug"
[ebuild N ] x11-apps/xgamma-1.0.2 USE="-debug"
[ebuild N ] x11-apps/xpr-1.0.2 USE="-debug"
[ebuild U ] x11-apps/xrandr-1.3.2 [1.2.3]
[ebuild N ] x11-apps/xsetmode-1.0.0 USE="-debug"
[ebuild N ] x11-apps/xvinfo-1.0.2 USE="-debug"
[ebuild N ] x11-apps/xsetroot-1.0.2 USE="-debug"
[ebuild N ] x11-apps/xbacklight-1.1 USE="-debug"
[ebuild N ] x11-apps/xkill-1.0.1 USE="-debug"
[ebuild N ] x11-apps/xlsclients-1.0.1 USE="-debug"
[ebuild N ] x11-apps/xlsatoms-1.0.1 USE="-debug"
[ebuild N ] x11-apps/xwd-1.0.2 USE="-debug"
[ebuild N ] x11-apps/xf86dga-1.0.2 USE="-debug"
[ebuild N ] media-libs/libmpeg2-0.5.1 USE="X -sdl"
[ebuild N ] x11-themes/xcursor-themes-1.0.1
[ebuild N ] x11-apps/bitmap-1.0.3-r1 USE="-debug"
[ebuild N ] x11-apps/xkbutils-1.0.1-r1 USE="-debug"
[ebuild N ] media-plugins/gst-plugins-mpeg2dec-0.10.11
[ebuild U ] dev-python/dbus-python-0.83.0-r1 [0.82.4] USE="-doc% -examples%"
[ebuild R ] media-plugins/gst-plugins-meta-0.10-r2 USE="mpeg*"
[ebuild U ] sys-apps/man-pages-3.22 [3.21]
[ebuild U ] net-misc/openssh-5.2_p1-r3 [5.2_p1-r1]
[ebuild N ] media-fonts/font-xfree86-type1-1.0.1 USE="X"
[ebuild N ] media-fonts/font-adobe-utopia-100dpi-1.0.1 USE="X nls"
[ebuild N ] media-fonts/font-ibm-type1-1.0.0 USE="X nls"
[ebuild N ] media-fonts/font-daewoo-misc-1.0.0 USE="X nls"
[ebuild N ] media-fonts/font-micro-misc-1.0.0 USE="X nls"
[ebuild N ] media-fonts/font-bh-ttf-1.0.0 USE="X"
[ebuild N ] media-fonts/font-misc-ethiopic-1.0.0-r1 USE="X"
[ebuild N ] media-fonts/font-sony-misc-1.0.0 USE="X nls"
[ebuild N ] media-fonts/font-adobe-utopia-75dpi-1.0.1 USE="X nls"
[ebuild N ] media-fonts/font-bitstream-speedo-1.0.0 USE="X"
[ebuild N ] media-fonts/font-screen-cyrillic-1.0.1 USE="X nls"
[ebuild N ] media-fonts/font-jis-misc-1.0.0 USE="X nls"
[ebuild N ] media-fonts/font-misc-misc-1.0.0 USE="X nls"
[ebuild N ] media-fonts/font-cursor-misc-1.0.0 USE="X nls"
[ebuild N ] media-fonts/font-misc-meltho-1.0.0 USE="X"
[ebuild N ] media-fonts/font-misc-cyrillic-1.0.0 USE="X nls"
[ebuild N ] media-fonts/font-bitstream-75dpi-1.0.0 USE="X nls"
[ebuild N ] media-fonts/font-arabic-misc-1.0.0 USE="X nls"
[ebuild N ] media-fonts/font-bitstream-100dpi-1.0.0 USE="X nls"
[ebuild N ] media-fonts/font-isas-misc-1.0.0 USE="X nls"
[ebuild N ] media-fonts/font-bh-75dpi-1.0.0 USE="X nls"
[ebuild N ] media-fonts/font-cronyx-cyrillic-1.0.0 USE="X nls"
[ebuild N ] media-fonts/font-mutt-misc-1.0.0 USE="X nls"
[ebuild N ] media-fonts/font-sun-misc-1.0.0 USE="X nls"
[ebuild N ] media-fonts/font-schumacher-misc-1.0.0 USE="X nls"
[ebuild N ] media-fonts/font-bitstream-type1-1.0.0 USE="X"
[ebuild N ] media-fonts/font-bh-lucidatypewriter-100dpi-1.0.0 USE="X nls"
[ebuild N ] media-fonts/font-winitzki-cyrillic-1.0.0 USE="X nls"
[ebuild N ] media-fonts/font-dec-misc-1.0.0 USE="X nls"
[ebuild N ] media-fonts/font-bh-100dpi-1.0.0 USE="X nls"
[ebuild N ] media-fonts/font-bh-lucidatypewriter-75dpi-1.0.0 USE="X nls"
[ebuild N ] x11-apps/x11perf-1.5 USE="-debug"
[ebuild U ] x11-terms/xterm-243 [242]
[ebuild U ] x11-apps/xinit-1.0.8-r10 [1.0.8-r8]
[ebuild U ] media-libs/mesa-7.5.1 [7.3-r1] VIDEO_CARDS="-radeonhd%"
[ebuild N ] media-libs/glew-1.5.1
[ebuild U ] x11-base/xorg-server-1.6.3.901-r2 [1.5.3-r6]
[ebuild N ] x11-apps/xdriinfo-1.0.2 USE="-debug"
[ebuild U ] x11-base/xorg-x11-7.4-r1 [7.2]
[ebuild R ] x11-libs/qt-gui-4.5.2-r2 USE="-qt3support*"
[ebuild R ] net-irc/xchat-2.8.6-r1 USE="mmx*"
[ebuild U ] gnome-base/gvfs-1.0.3-r13 [1.0.3-r2]
[ebuild R ] gnome-base/gnome-applets-2.24.3.1 USE="acpi*"
[ebuild U ] sys-apps/hal-0.5.12_rc1-r8 [0.5.11-r9] USE="acpi* -consolekit% -policykit%"
[ebuild R ] gnome-base/gnome-volume-manager-2.24.1 USE="automount*"
[ebuild R ] x11-drivers/nvidia-drivers-180.60 USE="acpi*"
[ebuild R ] media-plugins/audacious-plugins-2.1-r1 USE="-flac* -wma*"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/qt-sql:4

('ebuild', '/', 'x11-libs/qt-sql-4.5.2', 'merge') pulled in by
x11-libs/qt-sql required by world
~x11-libs/qt-sql-4.5.2 required by ('installed', '/', 'x11-libs/qt-4.5.2', 'nomerge')
~x11-libs/qt-sql-4.5.2[sqlite,-debug] required by ('installed', '/', 'x11-libs/qt-assistant-4.5.2', 'nomerge')

('installed', '/', 'x11-libs/qt-sql-4.5.2', 'nomerge') pulled in by
~x11-libs/qt-sql-4.5.2[qt3support,-debug] required by ('installed', '/', 'x11-libs/qt-qt3support-4.5.2', 'nomerge')
(and 3 more)

Explanation:

New USE for 'x11-libs/qt-sql:4' are incorrectly set. In order to solve
this, adjust USE to satisfy '~x11-libs/qt-
sql-4.5.2[qt3support,-debug]'.

x11-libs/qt-core:4

('ebuild', '/', 'x11-libs/qt-core-4.5.2', 'merge') pulled in by
~x11-libs/qt-core-4.5.2[glib,-debug,-qt3support] required by ('ebuild', '/', 'x11-libs/qt-gui-4.5.2-r2', 'merge')
~x11-libs/qt-core-4.5.2[-debug,-qt3support] required by ('ebuild', '/', 'x11-libs/qt-sql-4.5.2', 'merge')
(and 9 more)

('installed', '/', 'x11-libs/qt-core-4.5.2', 'nomerge') pulled in by
~x11-libs/qt-core-4.5.2[glib,qt3support,-debug] required by ('installed', '/', 'x11-libs/qt-gui-4.5.2-r2', 'nomerge')
~x11-libs/qt-core-4.5.2[qt3support,-debug] required by ('installed', '/', 'x11-libs/qt-qt3support-4.5.2', 'nomerge')
~x11-libs/qt-core-4.5.2[qt3support,-debug] required by ('installed', '/', 'x11-libs/qt-sql-4.5.2', 'nomerge')
(and 9 more)

x11-libs/qt-gui:4

('ebuild', '/', 'x11-libs/qt-gui-4.5.2-r2', 'merge') pulled in by
~x11-libs/qt-gui-4.5.2[-debug] required by ('installed', '/', 'x11-libs/qt-svg-4.5.2', 'nomerge')
x11-libs/qt-gui required by world
x11-libs/qt-gui required by ('installed', '/', 'www-client/opera-10.00', 'nomerge')
(and 3 more)

('installed', '/', 'x11-libs/qt-gui-4.5.2-r2', 'nomerge') pulled in by
>=x11-libs/qt-gui-4.4:4[qt3support] required by ('installed', '/', 'net-im/psi-0.12.1', 'nomerge')

~x11-libs/qt-gui-4.5.2[glib,qt3support,-debug] required by ('installed', '/', 'x11-libs/qt-phonon-4.5.2', 'nomerge')
~x11-libs/qt-gui-4.5.2[qt3support,accessibility,-debug] required by ('installed', '/', 'x11-libs/qt-qt3support-4.5.2', 'nomerge')
(and 7 more)

Explanation:

New USE for 'x11-libs/qt-gui:4' are incorrectly set. In order to solve
this, adjust USE to satisfy '~x11-libs/qt-
gui-4.5.2[qt3support,accessibility,-debug]', '~x11-libs/qt-
gui-4.5.2[glib,qt3support,-debug]', '>=x11-libs/qt-
gui-4.4:4[qt3support]', and '~x11-libs/qt-gui-4.5.2[qt3support]'.

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.

* IMPORTANT: 5 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

Пытался пересобирать пакеты x11-libs/qt-gui с флагами qt3support,accessibility,-debug ;
x11-libs/qt-core с флагами glib,qt3support,-debug
x11-libs/qt-sql с флагами t3support,-debug
Безрезультатно.
Кто знает отпишитесь пожалуйста. Заранее спасибо.
PS: OS:
a@localhost ~ $ uname -a
Linux localhost 2.6.30-gentoo-r6 #1 SMP Thu Oct 8 03:50:01 EEST 2009 i686 Intel(R) Celeron(R) D CPU 3.06GHz GenuineIntel GNU/Linux
      

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Проблема с пересборкой мира"  +/
Сообщение от daevy on 15-Окт-09, 12:29 
напишите сюда, http://www.gentoo.ru/forum/4
тут вам врядли помогут по такому вопросу((
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2023 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру