The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"проблема с обновлением php5"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Открытые системы на сервере (BSD привязка / FreeBSD)
Изначальное сообщение [ Отслеживать ]

"проблема с обновлением php5"  +/
Сообщение от Birder email on 08-Июн-10, 12:51 
Привет всем!
Возникла необходимость обновить php (ОС FreeBSD7.2). Обновил порты через portsnap, захожу в
/usr/ports/lang/php5, там делаю make получаю ошибку о конфликте


===>  php5-5.3.2_1 conflicts with installed package(s):
      php5-spl-5.2.6_2
They install files into the same place.
      Please remove them first with pkg_delete(1)


Пытаюсь дальше удалить php5-spl-5.2.6_2 b дальше очередная ошибка

pkg_delete: package 'php5-spl-5.2.6_2' is required by these other packages
and may not be deinstalled:
php5-dom-5.2.6_2
php5-extensions-1.3
php5-sqlite-5.2.6_2
php5-xmlreader-5.2.6_2
roundcube-0.2.2,1

Не хочеться удалять ниже зависящие, возможно не так делаю
Посоветуйте как правильно поступить в этом случае.
Спасибо!

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "проблема с обновлением php5"  +/
Сообщение от Deac (ok) on 08-Июн-10, 12:58 
>[оверквотинг удален]
>
>/usr/ports/lang/php5, там делаю make получаю ошибку о конфликте
>
>
>===>  php5-5.3.2_1 conflicts with installed package(s):
>      php5-spl-5.2.6_2
> They install files into the same place.
>      Please remove them first with pkg_delete(1)
>
>

make deinstall

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "проблема с обновлением php5"  +/
Сообщение от mef (ok) on 08-Июн-10, 13:07 
>
>make deinstall

make deinstall clean
make config
make
make install clean
rehash

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "проблема с обновлением php5"  +/
Сообщение от Аноним (??) on 08-Июн-10, 17:49 
1. все пхп-шные модули обновлять все равно нужно, если обновляете пхп.
2. portupgrade, portmaster вам в помощь
3. roundcube - это одна большая дыра, я бы первым делом сделал pkg_delete roundcube-0.2.2,1 и забыл как страшный сон.
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру