The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]



"В GNOME 45 будет нарушена совместимость со старыми дополнениями"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"В GNOME 45 будет нарушена совместимость со старыми дополнениями"  +/
Сообщение от opennews (??), 04-Сен-23, 09:41 
В пользовательском окружении GNOME 45, релиз которого намечен на 25 сентября, изменена организация загрузки модулей в дополнениях к GNOME Shell, что  приведёт к нарушению обратной совместимости и потребует внесения изменений в дополнения. Дополнения, разработанные для прошлых версий GNOME, не смогут работать в выпуске GNOME 45, а дополнения адаптированные для работы в GNOME 45, не смогут устанавливаться в прошлых версиях GNOME. Для сохранения совместимости с разными выпусками GNOME разработчикам дополнений необходимо загрузить в каталог  extensions.gnome.org два варианта дополнения: один для GNOME 45 и следующих за ним выпусков, а другой для старых выпусков GNOME...

Подробнее: https://www.opennet.ru/opennews/art.shtml?num=59711

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения [Сортировка по времени | RSS]


1. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +66 +/
Сообщение от Аноним (1), 04-Сен-23, 09:41 
Никогда такого не было и вот опять.
Ответить | Правка | Наверх | Cообщить модератору

6. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  –12 +/
Сообщение от Аноним (6), 04-Сен-23, 09:50 
гномэ становится лучше от выпуска к выпуску, а ломание API в мажорных (!) релизах обычное дело у ВСЕХ
Ответить | Правка | Наверх | Cообщить модератору

39. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +14 +/
Сообщение от Аноним (39), 04-Сен-23, 10:40 
Самовнушение работает?
Ответить | Правка | Наверх | Cообщить модератору

82. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  –8 +/
Сообщение от Аноним (82), 04-Сен-23, 13:10 
Тебе не стыдно ныть каждый раз на форумах? Написание патча для любого расширения займет ровно 1 минуту.
Ответить | Правка | Наверх | Cообщить модератору

124. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +6 +/
Сообщение от Аноним (124), 04-Сен-23, 15:20 
Тебе по-русски сказали. Автор забросил плаг, а плаг нужен потому что без него гном неюзабелен. И даже если автор опомнится через полгода плаг мне нужен сразу после обновления или ухожу на КДЕ (спойлер уже ушел на КДЕ)
Ответить | Правка | Наверх | Cообщить модератору

139. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +3 +/
Сообщение от Аноним (139), 04-Сен-23, 16:34 
> Тебе по-русски сказали. Автор забросил плаг, а плаг нужен потому что без
> него гном неюзабелен. И даже если автор опомнится через полгода плаг
> мне нужен сразу после обновления или ухожу на КДЕ (спойлер уже
> ушел на КДЕ)

Хоть я и не пользователь KDE, но обобряю, KDE как раз почти закоксовалась, разрабы перестали её ломать, похоже что можно даже пользоваться и не охреневать от завоза новых фич с новыми багами. Вся надежда теперь на дистростроев, что они допилят её, т.к. по традиции кедоразрабы забьют болт на полировку стабильной версии и дропнут её как есть, побежав разрабатывать следующий мажорный релиз (сполер уже начали разрабатывать KDE6) xD

Но при всех косяках KDE, это всяко лучше, чем ужиматься на вечно кастрируемой среде для недоайпэдов.

Ответить | Правка | Наверх | Cообщить модератору

151. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (151), 04-Сен-23, 17:04 
погоди, скоро пойдёт веселье при переходе на 6ую плазму)
Ответить | Правка | Наверх | Cообщить модератору

186. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Ефрщ (?), 04-Сен-23, 19:43 
> KDE закоксовалась

Ты понимаешь значение этого слова?

Ответить | Правка | К родителю #139 | Наверх | Cообщить модератору

201. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (201), 04-Сен-23, 22:03 
Ответы Mail.ru: Личинка замка закоксовалась.Силуминовая … 🙂
Ответить | Правка | Наверх | Cообщить модератору

159. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  –2 +/
Сообщение от Аноним (151), 04-Сен-23, 17:37 
> или ухожу на КДЕ (спойлер уже ушел на КДЕ)

сорян чувак, твои хомячковые истории мало кому интересны, куда ты там и что

Ответить | Правка | К родителю #124 | Наверх | Cообщить модератору

161. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +1 +/
Сообщение от Аноним (151), 04-Сен-23, 17:39 
> или ухожу на КДЕ (спойлер уже ушел на КДЕ)

по моим наблюдениям, пользователи KDE чуть ли не самые токсичные люди, вечно прутся не в свои треды, что бы рассказать как они там перешли на кедики — вот кому нафиг эти очешуительные истории сдались? таким же кедешникам) они их и лайкуют собственно

Ответить | Правка | К родителю #124 | Наверх | Cообщить модератору

205. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +1 +/
Сообщение от Аноним (205), 04-Сен-23, 22:17 
Гном вполне юзабелен без плагинов, неюзабелен он только для тех кто пытается переделать Гном во что-то другое, но если тебе изначально не нравится гном зачем пытаться его переделывать или альтернативные ДЕ настолько плохи что приходится из гнома что то лепить?
Ответить | Правка | К родителю #124 | Наверх | Cообщить модератору

221. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (221), 05-Сен-23, 00:59 
Это из наутилуса выпилили запуск терминала из конекстного меню? И если я хочу вернуть эту фичу, я гном превращаю во что-то другое? Дожили.
Ответить | Правка | Наверх | Cообщить модератору

311. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от beb (??), 06-Сен-23, 22:10 
Они в это контекстное меню захардкодили свои Gnome Console и Gnome Terminal, и если ни одного из них в системе нет, то и пункта в контекстном меню тоже соответственно нет.
Ответить | Правка | Наверх | Cообщить модератору

225. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (225), 05-Сен-23, 01:22 
Качаешь сорцы плага, патчишь сам, собираешь, ставишь в гном ручками. Профит. Беспомощный какой.
Ответить | Правка | К родителю #124 | Наверх | Cообщить модератору

250. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от thhh (?), 05-Сен-23, 07:29 
Ничего качать не нужно. Код и так присуствует, в ../share/gnome-shell/extensions/. Просто правишь пару строк
Ответить | Правка | Наверх | Cообщить модератору

258. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (201), 05-Сен-23, 09:30 
🙂
Ответить | Правка | Наверх | Cообщить модератору

74. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +5 +/
Сообщение от Аноним (74), 04-Сен-23, 12:19 
в мажорных¹ релизах (!)

1. Каждые полгода

Ответить | Правка | К родителю #6 | Наверх | Cообщить модератору

97. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (205), 04-Сен-23, 13:50 
Пруфы на каждые пол года?
Ответить | Правка | Наверх | Cообщить модератору

122. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (122), 04-Сен-23, 15:16 
Fedora. В очередной версии - новый гном уже кучу лет, выходит раз примерно в полгода.
Ответить | Правка | Наверх | Cообщить модератору

209. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (205), 04-Сен-23, 23:52 
Пруфы про поломанные api каждые пол года.
Ответить | Правка | Наверх | Cообщить модератору

137. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (74), 04-Сен-23, 16:25 
Ну не знаю... История релизов? Все версии, начиная с 40, выходят в сентябре и марте. Каждая версия — большой мажорный релиз, можно всё ломать нафиг.
Ответить | Правка | К родителю #97 | Наверх | Cообщить модератору

156. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (151), 04-Сен-23, 17:31 
Ну выходят, и чё? То ноете про "устаревающие технологии", то нос воротите от апдейтов. Уж определитесь там.
Ответить | Правка | Наверх | Cообщить модератору

198. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (74), 04-Сен-23, 21:08 
"То крестик носите, то содомией занимаетесь. Уж определитесь там."

Потрясающий, конечно, способ выставить оппонента шизом, когда самому сказать нечего.

Ответить | Правка | Наверх | Cообщить модератору

251. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от thhh (?), 05-Сен-23, 07:32 
Согласен, если сказать нечего, можно приплести не к месту крестик с содомией
Ответить | Правка | Наверх | Cообщить модератору

210. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (205), 04-Сен-23, 23:53 
Понятно что выходят, пруфы нужны на поломанные api при каждых мажорных релизах.
Ответить | Правка | К родителю #137 | Наверх | Cообщить модератору

75. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +4 +/
Сообщение от Аноним (75), 04-Сен-23, 12:23 
Так теперь каждый выпуск мажорный.
Ответить | Правка | К родителю #6 | Наверх | Cообщить модератору

117. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от КО (?), 04-Сен-23, 14:56 
Давай хотя бы один пример в этом же поле, ну-ка, ну-ка
Ответить | Правка | К родителю #6 | Наверх | Cообщить модератору

136. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  –1 +/
Сообщение от Аноним (-), 04-Сен-23, 16:20 
> гномэ становится лучше от выпуска к выпуску, а ломание API в мажорных (!)
> релизах обычное дело у ВСЕХ

Мне тоже нравится. Раньше они только клепателей тем имели, а теперь еще и авторам скриптоты прилетело. Скоро они попробуют поиметь всю планету. С понятным результатом - "мир оказался сильней".

Ответить | Правка | К родителю #6 | Наверх | Cообщить модератору

190. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (190), 04-Сен-23, 20:03 
> Скоро они попробуют поиметь всю планету. С понятным результатом - "мир оказался сильней".

А вдруг это и есть тот самый виндекапец, и планету они таки поимеют?

Ответить | Правка | Наверх | Cообщить модератору

265. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (265), 05-Сен-23, 11:51 
>> Скоро они попробуют поиметь всю планету. С понятным результатом - "мир оказался сильней".
> А вдруг это и есть тот самый виндекапец, и планету они таки поимеют?

На мой вкус это "крайне маловероятно". Я вообще не понимаю кто и зачем будет гномом пользоваться. Хомячкам окей и в предустановленной винде, гикам он убогий слишком, даже не дает выбрать как ноут в спячку уложить, елки, и светит фичами исключительно для тех кто проносит ложку мимо рта. Закос под мобильный интерфейс? Ну, ок, только девайсов на нем - ноль. А на десктопе три кнопки такого размера что там не то что кулаком а двуручным мечом в экран фигачить, видимо, предполагается. Площадь экрана расходуется неэффективно и man-machine interface показывает лишь как слить дорогой и фичастый хардвар до уровня мобилки. Я для этого штукарь баксов на большой крутой монитор тратил чтоли?! Чтобы получить эффективность стобаксовой мобилки? Да ладно?!

Вот и объясните мне - кто и зачем будет таким DE пользоваться. Пока вижу - хайпующие ламонубы, мнящие себя крутыми, но реально - нулевое глупое нубье. При том только та узкая прослоечка которой почему-то виндочка не подошла.

Ответить | Правка | Наверх | Cообщить модератору

302. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (302), 06-Сен-23, 08:27 
Пользовался GNOME 3 из-за того что там большие пиктогркммы, переключалка окон по Alt+Tab с большыми пиктограмамми и много чего ещё большое что легко разглядеть и легко попасть мышкой. А ещё ткм есть некоторые приктльные расшырения, а ещё KDE уж слишком похож на Windows, а ещё GNOME 3 выглядит красивенько. Но я перешёл на Windows потому что хочу изучить .NET и зкрабатывать программированием под Windows. И в Linux нету игор. Ещё меня достала эта фигня фактическим зависанием системы когд оперативка заполнена или почти заполнена.
Ответить | Правка | Наверх | Cообщить модератору

304. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (-), 06-Сен-23, 09:00 
> Пользовался GNOME 3 из-за того что там большие пиктогркммы, переключалка окон по
> Alt+Tab с большыми пиктограмамми и много чего ещё большое что легко
> разглядеть и легко попасть мышкой.

По-моему размер пиктограмм настраивается практически везде. Только вот если чей-то интерфейс с машиной сводится к постоянному возяканию мышой - много они наработают... разве что дизайнером каким, или типа того.

> А ещё ткм есть некоторые приктльные расшырения,

Спеллчекер явно не входил в этот список...

> а ещё KDE уж слишком похож на Windows, а ещё GNOME 3 выглядит красивенько.

Да вроде обычно. Не так блевотно как раньше но блеклые значки цвета упаковочного картона - меня лично таки вымораживают по сей день.

> Но я перешёл на Windows потому что хочу изучить .NET и зкрабатывать программированием
> под Windows. И в Linux нету игор. Ещё меня достала эта фигня фактическим зависанием
> системы когд оперативка заполнена или почти заполнена.

Как говорится, творческих узбеков и все такое. Я кажется был прав насчет гнома. Ну и вот зачем нам такие экспонаты в линухе, спрашивается?

...но насчет игр - в стиме под линух более 1000 игр есть, включая самые распоследние топовые бренды. Валв вообще Steam Deck нынче делает на линухе.

Ответить | Правка | Наверх | Cообщить модератору

312. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (312), 08-Сен-23, 07:52 
Понятно. Продолжайте держать нас в курсе.
Ответить | Правка | К родителю #302 | Наверх | Cообщить модератору

141. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Вот тебе бабушка и новые гномофичи (?), 04-Сен-23, 16:39 
> гномэ становится лучше от выпуска к выпуску, а ломание API в мажорных
> (!) релизах обычное дело у ВСЕХ

Вот тока частота этих самых ломающих релизов в других DE позволяет не гореть дупой от отваливающихся экстеншонов снова и снова, а таки позволяет в промежутках между релизами спокойно попользоваться системой с экстеншонами и ещё можно послоупочить, пока основные экстеншоны портируют к следующему релизу. А на гномоте только вроде всё улеглось, а вот хрен ты угадал, начинай снова бетатестить новую версию, с пылу, с жару, из под коня! Такой вот он суровый гномоэкмпириенс! Xd

Ответить | Правка | К родителю #6 | Наверх | Cообщить модератору

212. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (205), 05-Сен-23, 00:11 
У Гнома, если даже ломаются расширения, что происходит не так часто как местные тут пытаются преподнести, они успевают пофиксится до момента включения свежего Гнома в состав большинства дистрибутивов.
Ответить | Правка | Наверх | Cообщить модератору

255. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +1 +/
Сообщение от anonymous (??), 05-Сен-23, 09:04 
Там теперь каждый релиз - мажорный.
Ответить | Правка | К родителю #6 | Наверх | Cообщить модератору

10. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +4 +/
Сообщение от soarin (ok), 04-Сен-23, 09:57 
Я лично удивлён, что это обрабатывают.
А не «сломалось, так и надо, и вообще не приоритет по второму принципу». Вроде как раз так всегда было.
Ответить | Правка | К родителю #1 | Наверх | Cообщить модератору

2. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +1 +/
Сообщение от beduin747 (ok), 04-Сен-23, 09:44 
Это, безусловно, добавит популярности и гному и линухам. =( Наворотили своего, потом решили стандартное пользовать...
Ответить | Правка | Наверх | Cообщить модератору

5. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  –1 +/
Сообщение от анонас (?), 04-Сен-23, 09:48 
first time? гном 3 вон каждый релиз все ломал и ничего.
Ответить | Правка | Наверх | Cообщить модератору

142. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +3 +/
Сообщение от DP (?), 04-Сен-23, 16:41 
> first time? гном 3 вон каждый релиз все ломал и ничего.

"Ничего" это было для современных гномоюзеров, олды охреневали от такой волны смузиразработок, и посваливали кто куда.

Ответить | Правка | Наверх | Cообщить модератору

303. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от анонас (?), 06-Сен-23, 08:29 
массовая миграция юзеров была в основном из-за фичеката и навязывания апплоандроидоюи, а не сломанных расширений или левых тем. кирпичи по поводу обратной совместимоси откладывали не зашкваренные в гноме разрабы или дезигнеры.
Ответить | Правка | Наверх | Cообщить модератору

16. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  –5 +/
Сообщение от Аноним (16), 04-Сен-23, 10:02 
Непременно. Плазма не выключается, Гноме не обновляется, остальное из рук Левшы вышло. Здравствуй Windows
Ответить | Правка | К родителю #2 | Наверх | Cообщить модератору

23. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  –3 +/
Сообщение от Аноним (6), 04-Сен-23, 10:10 
Аве Microsoft! Аве Apple! (:
Ответить | Правка | Наверх | Cообщить модератору

26. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (26), 04-Сен-23, 10:14 
>  Apple

Это когда под каждую минорную версию, получаемую с обновлениями, нужно приложение пересобирать? С загрузкой и обновлением XCode, кстати.

Ответить | Правка | Наверх | Cообщить модератору

37. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от ryoken (ok), 04-Сен-23, 10:38 
...и потом говорят "gentoo - сложнааа"...
Ответить | Правка | Наверх | Cообщить модератору

53. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +1 +/
Сообщение от Пользователь (?), 04-Сен-23, 11:04 
Где-то в интернете прочитал бредовый комментарий/статью, и теперь несёшь эту мысль повсюду?
Ответить | Правка | К родителю #26 | Наверх | Cообщить модератору

88. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (26), 04-Сен-23, 13:33 
Не имею привычки. Только личный опыт.
Ответить | Правка | Наверх | Cообщить модератору

143. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Шъыъш (?), 04-Сен-23, 16:45 
>>  Apple
> Это когда под каждую минорную версию, получаемую с обновлениями, нужно приложение пересобирать?
> С загрузкой и обновлением XCode, кстати.

Нет, это когда под запланированное строгое число версий ОС, ваше устройство Apple через заданное количество времени считает тыквой, а не потому что оно объективно не может вывозить новую версию ОС! При том, что через тот же legacy patcher техника продолжает без проблем нормально работать, но у вас уже какинтош на официальной технике от Apple, вы уже неугодный для них.

Ответить | Правка | К родителю #26 | Наверх | Cообщить модератору

52. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +1 +/
Сообщение от beduin747 (ok), 04-Сен-23, 11:04 
> Аве Microsoft! Аве Apple! (:

Не, спасибо. Меня ubuntu c XFCE вполне устраивает.


Ответить | Правка | К родителю #23 | Наверх | Cообщить модератору

144. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +1 +/
Сообщение от DP (?), 04-Сен-23, 16:46 
>> Аве Microsoft! Аве Apple! (:
> Не, спасибо. Меня ubuntu c XFCE вполне устраивает.

Это называется зубунту, можно же короче написать! ;)

Ответить | Правка | Наверх | Cообщить модератору

154. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +1 +/
Сообщение от beduin747 (ok), 04-Сен-23, 17:12 
>>> Аве Microsoft! Аве Apple! (:
>> Не, спасибо. Меня ubuntu c XFCE вполне устраивает.
> Это называется зубунту, можно же короче написать! ;)

Не совсем. Вы про готовый дистр. А у меня своя болгенос. =) Взят mini.iso от убунты, поставлена минимальная система (netinstall c --no-install-recommends), потом сверху xfce (только самое необходимое), затем уже софт, который меня устраивает. Ну и заколхозить это все под себя. =)
Так и живу начиная с 18.04. То нужность какую прикрутить, то гадость какую-нибудь, типа snapd, оторвать... Ну и на рабочем ноуте такая же стоит (на флешке на 16 Гиг).


Ответить | Правка | Наверх | Cообщить модератору

293. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от DP (?), 05-Сен-23, 18:15 
>>>> Аве Microsoft! Аве Apple! (:
>>> Не, спасибо. Меня ubuntu c XFCE вполне устраивает.
>> Это называется зубунту, можно же короче написать! ;)
> Не совсем. Вы про готовый дистр. А у меня своя болгенос. =)
> Взят mini.iso от убунты, поставлена минимальная система (netinstall c --no-install-recommends),
> потом сверху xfce (только самое необходимое), затем уже софт, который меня
> устраивает. Ну и заколхозить это все под себя. =)
> Так и живу начиная с 18.04. То нужность какую прикрутить, то гадость
> какую-нибудь, типа snapd, оторвать... Ну и на рабочем ноуте такая же
> стоит (на флешке на 16 Гиг).

Хоть сам такой фигнёй не занимался, а брал зубунту, но за колхозинг увожаю! ;)

Ответить | Правка | Наверх | Cообщить модератору

41. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +4 +/
Сообщение от Аноним (39), 04-Сен-23, 10:42 
Trinity TDE и MATE вполне юзабельно.
Ответить | Правка | К родителю #16 | Наверх | Cообщить модератору

153. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от dannyD (?), 04-Сен-23, 17:06 
>>MATE вполне юзабельно.

канешна на любителя,

как по-мне - вполне )))

Ответить | Правка | Наверх | Cообщить модератору

199. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (199), 04-Сен-23, 21:30 
на любителя это Гном
Ответить | Правка | Наверх | Cообщить модератору

200. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от dannyD (?), 04-Сен-23, 21:44 
не знаю...

если вы о "GNOME 45", то это для меня где-то там же где и w11, дальше Луны.

Ответить | Правка | Наверх | Cообщить модератору

202. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (201), 04-Сен-23, 22:07 
Слишком экспишно (ツ)
Ответить | Правка | К родителю #41 | Наверх | Cообщить модератору

203. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  –1 +/
Сообщение от Аноним (201), 04-Сен-23, 22:08 
ЗЫ TDE.
Ответить | Правка | Наверх | Cообщить модератору

33. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +1 +/
Сообщение от Аноним (33), 04-Сен-23, 10:21 
Когда они делали свое, "стандартное" отсутствовало, либо было ещё хуже.

И да, официально темы и расширения не поддерживаются. Используйте это на свой страх риск. В общем-то как и весь остальной Open Source.

Ответить | Правка | К родителю #2 | Наверх | Cообщить модератору

40. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +4 +/
Сообщение от Аноним (39), 04-Сен-23, 10:41 
Ну не хотят авторы Гнома чтобы работали какие-то дополнения. Они хотят чтобы все страдали на дефолте.
Ответить | Правка | К родителю #2 | Наверх | Cообщить модератору

145. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Как же такто (?), 04-Сен-23, 16:49 
> Ну не хотят авторы Гнома чтобы работали какие-то дополнения. Они хотят чтобы
> все страдали на дефолте.

А мыши плакают, колятся, но продолжают трясущимися лапками прилаживать дополнения к новой гордой и независимой дефолтной версии GNOME... Снова.

Более преданных фанатов, мнение которых вертелось разрабами где только можно, мало где можно найти. Но они даже этого не ценять по ходу.

Ответить | Правка | Наверх | Cообщить модератору

256. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (39), 05-Сен-23, 09:11 
Вообще нет. Всё можно допилить дополнениями это аргумент адептов гнома, на замечание что их гном не юзабелен. Я юзать гном не буду ни в каком виде.
Ответить | Правка | Наверх | Cообщить модератору

204. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (201), 04-Сен-23, 22:16 
Может, просто шесть рук?😎
Ответить | Правка | К родителю #40 | Наверх | Cообщить модератору

119. Скрыто модератором  –2 +/
Сообщение от penetrator (?), 04-Сен-23, 15:01 
Ответить | Правка | К родителю #2 | Наверх | Cообщить модератору

130. Скрыто модератором  –1 +/
Сообщение от нейм (?), 04-Сен-23, 15:47 
Ответить | Правка | Наверх | Cообщить модератору

196. Скрыто модератором  –1 +/
Сообщение от penetrator (?), 04-Сен-23, 20:37 
Ответить | Правка | Наверх | Cообщить модератору

126. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (124), 04-Сен-23, 15:21 
Все уйдут на ХромОС не переживай.
Ответить | Правка | К родителю #2 | Наверх | Cообщить модератору

3. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +1 +/
Сообщение от Аноним (3), 04-Сен-23, 09:46 
Октябрь, количество форков старый расширений увеличивается.
Ответить | Правка | Наверх | Cообщить модератору

132. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от нейм (?), 04-Сен-23, 15:48 
Зато годовая статистика стора (или как та репа называется) пойдет ввысь

Динамично развивается, количество проджектов растет, инвесторы рады

Ответить | Правка | Наверх | Cообщить модератору

4. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +4 +/
Сообщение от Аноним (4), 04-Сен-23, 09:48 
Они хоть бы составили список уже портированных дополнений, а то на https://extensions.gnome.org/ даже дата обновления дополнения не показывается и без ковыряния самого дополнения не понять, запустится оно в GNOME 45 или нет.
Ответить | Правка | Наверх | Cообщить модератору

8. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +8 +/
Сообщение от Аноним (8), 04-Сен-23, 09:54 
И это логично!
Ты что хотел как на маке или винде?
Чтобы все работало после одного щелчка мышкой?

Пользователи линуксов любят попердолиться с конфигами, пообщаться на форумах, пересобрать свой вариант мира.
Это традиция!
Нельзя лишать их такого удовольствия.

Ответить | Правка | Наверх | Cообщить модератору

45. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +1 +/
Сообщение от another_one (ok), 04-Сен-23, 10:51 
И много то на маке/винде сторонних дополнений, влияющих на UI/UX? Новость как раз об обратном, что пострадают в основном "не такие как все".
Ответить | Правка | Наверх | Cообщить модератору

66. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от _kpemail (ok), 04-Сен-23, 11:32 
И там и там подобные дополнения существуют, что то есть у меня в коллекции, но мягко говоря, они не популярны, причем настолько, что так мягко я не выговорю.
Ну, разве что ClassicShell/OpenShell не увидеть на Windows надо очень постараться.
А остальное лесом.


Добавил.
Хмм. А почему для Гнома нет порта OpenShell? Ему он бы очень пригодился вместо тормозных расширений. ;)

Ответить | Правка | Наверх | Cообщить модератору

73. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  –2 +/
Сообщение от AleksK (ok), 04-Сен-23, 12:10 
Твой openshell уже забросили. Где он для win 11? А в гноме и так все гораздо удобнее чем в каличной винде.
Ответить | Правка | Наверх | Cообщить модератору

99. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +1 +/
Сообщение от Аноним Максим (?), 04-Сен-23, 13:51 
ClassicShell забросили, а OPenShell пока ещё жив, и на Windows11 работает.

>>А в гноме и так все гораздо удобнее

Удобно, где можно настроить под себя, или из коробки настроено.
И если к Гному в целом особо претензий и нет, и настроенному тем более, то к способ его настройки ещё та антиэргономика.

Ответить | Правка | Наверх | Cообщить модератору

72. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Анонимусс (?), 04-Сен-23, 12:06 
Есть, но не так уж и много. Просто потому что они не сильно там и нужны (кроме пуска на винде, разве что)
А гнумье из коробки неюзабельно прям вообще и без обмазывания дополнениями просто никак.
Ответить | Правка | К родителю #45 | Наверх | Cообщить модератору

318. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от grn (ok), 20-Сен-23, 08:39 
На винде вроде после двух щелчков мышкой
Ответить | Правка | К родителю #8 | Наверх | Cообщить модератору

61. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +3 +/
Сообщение от nE0sIghT (ok), 04-Сен-23, 11:24 
Я сейчас работаю над реимплементацией сайта. В версии для разработки информация о дате обновления расширений есть. Прогресс можно посмотреть по ссылке https://gitlab.gnome.org/Infrastructure/extensions-web/-/iss...
Ответить | Правка | К родителю #4 | Наверх | Cообщить модератору

253. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от thhh (?), 05-Сен-23, 07:43 
> без ковыряния самого дополнения не понять, запустится оно в GNOME 45 или нет.

Все проще, просто посмотри в списке 'version', если есть 45, то запустится:

https://extensions.gnome.org/extension/602/window-list/

Ответить | Правка | К родителю #4 | Наверх | Cообщить модератору

9. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  –1 +/
Сообщение от Аноним (9), 04-Сен-23, 09:57 
Ну, это уже стало доброй традицией.. Каждый минорный релиз Gnome это повод начать всё с чистого листа...
Ответить | Правка | Наверх | Cообщить модератору

11. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +2 +/
Сообщение от soarin (ok), 04-Сен-23, 09:58 
Они перевернули 🗓
Ответить | Правка | Наверх | Cообщить модератору

21. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  –2 +/
Сообщение от Аноним (6), 04-Сен-23, 10:06 
это МАЖОРНЫЙ релиз
хотя то что эксперты опеннет их путают я не удивлен
Ответить | Правка | К родителю #9 | Наверх | Cообщить модератору

69. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +1 +/
Сообщение от Аноним (69), 04-Сен-23, 11:42 
У гномога каждые полгода МАЖОРНЫЙ релиз. То, что они каждые полгода могут ломать совместимость с дополнениями, точно норма? А нужно ли тогда такое api вообще? Почему бы его совсем не закрыть? Тогда и вопросов меньше будет
Ответить | Правка | Наверх | Cообщить модератору

100. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (205), 04-Сен-23, 13:54 
Нужно судить за то что делают, а не за то что МОГУТ делать. Каждые пол года не ломается.
Ответить | Правка | Наверх | Cообщить модератору

113. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +1 +/
Сообщение от Аноним (69), 04-Сен-23, 14:39 
> Нужно судить

Ненужно

> Каждые пол года не ломается

Гарантируешь, что еще через полгода не сломается? А потом еще через полгода? А раз в какое количество времени ломать обратную совместимость норма? А как при обновлении узнать, что у тебя половина твоих наворотов отвалится, не читая новости?

Ответить | Правка | Наверх | Cообщить модератору

213. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (205), 05-Сен-23, 00:16 
А ты докажи что каждые пол года ломаются api, с чего такое умозаключение?
Ответить | Правка | Наверх | Cообщить модератору

224. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (69), 05-Сен-23, 01:17 
а ты докажи, что б-га нет! ©

еще раз - где гарантия, что они через полгода снова не сломают api? договоренности какие-нибудь?

вот тут по ссылке (https://gjs.guide/extensions/overview/updates-and-breakage.h...) прямо сказано, что расширения работают даже не через api, а что это просто "патчи" на гномощель, то есть буквально абсолютно любое изменение в гномощели, даже минорное, может сломать какое-нибудь расширение

Ответить | Правка | Наверх | Cообщить модератору

259. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (205), 05-Сен-23, 10:40 
У Гнома есть история версий и список изменений, твои аналогии неуместны, ты просто доказать этот выброс не можешь вот и юлишь.
Ответить | Правка | Наверх | Cообщить модератору

268. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (69), 05-Сен-23, 12:31 
какие аналогии? я должен доказывать, что гноморазрабы действительно ничего не сломают в следующей версии? точно не гноморазрабы это должны делать? или точно не те, кто утверждает, что они не могут ничего ломать, потому что есть же история изменений? что значит "ты просто юлишь"? я что, неясно задаю вопросы? Может быть вопрос "это точно норма, что они могут ломать совместимость каждые полгода" какой-то нетакой? неправильно или неверно поставленный? ты с чем сейчас вообще споришь? если что я не говорил, что они ломают, я сказал, что они могут ломать, и они могут ломать его даже в минорных версиях, а тред вообще начался с того, что "они делают ломающие изменения, потому что релиз МАЖОРНЫЙ", на что я ответил, что у гномога каждые полгода релиз мажорный, и как следствие, возник следующий вопрос

еще раз - где гарантии того, что через полгода снова ничего не сломается?

Ответить | Правка | Наверх | Cообщить модератору

138. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (138), 04-Сен-23, 16:28 
Действительно, когда в прошлый раз пользовался, ломалось каждые 2 месяца. Это в 3 раза чаще, они молодцы!
Ответить | Правка | К родителю #100 | Наверх | Cообщить модератору

214. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (205), 05-Сен-23, 00:17 
Ложь, утрирование и демагогия, типично для местных комментаторов.
Ответить | Правка | Наверх | Cообщить модератору

218. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (138), 05-Сен-23, 00:32 
Ничего не знаю, даже если такой график на совести мейнтейнеров и авторы ломали только раз в 3 месяца, регулярный результат был именно такой.
Ответить | Правка | Наверх | Cообщить модератору

70. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Sw00p aka Jerom (?), 04-Сен-23, 11:51 
>это МАЖОРНЫЙ релиз

то есть, должно все ломаться?

Ответить | Правка | К родителю #21 | Наверх | Cообщить модератору

78. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от ИмяХ (?), 04-Сен-23, 13:01 
Да, должно. Если бы не сломалось, то это была бы версия 44.1
Ответить | Правка | Наверх | Cообщить модератору

90. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +1 +/
Сообщение от Аноним (69), 04-Сен-23, 13:36 
интересная трактовка "семантического версионирования"

добавляешь глобальные фичи, но не ломаешь существующий порядок - минорный релиз

не добавляешь глобальные фичи, но ломаешь порядок - мажорный

Ответить | Правка | Наверх | Cообщить модератору

94. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (94), 04-Сен-23, 13:47 
> не добавляешь глобальные фичи, но ломаешь порядок - мажорный

Добавили глобальную фичу - заменили систему импорта на повсеместный стандарт. Что не так?

Ответить | Правка | Наверх | Cообщить модератору

114. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (69), 04-Сен-23, 14:41 
Ну например то, что руководствуясь комментом, на который я отвечал, для мажорного релиза глобальные фичи не нужны, а нужен слом совместимости, и тогда это будет мажорный релиз.
Ответить | Правка | Наверх | Cообщить модератору

173. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (173), 04-Сен-23, 18:56 
>>>это МАЖОРНЫЙ релиз
>>то есть, должно все ломаться?
>Да, должно. Если бы не сломалось, то это была бы версия 44.1

Такой "хокей" не нужен.

Есть социальный договор: не доставлять друг другу.

А когда что-либо ломают, это нарушение уговора. Т.к. бумаг не подписано, то просто уходят тратить время на более надёжных партнёров-товарищей.

Поэтому: может, но не должно.

Ответить | Правка | К родителю #78 | Наверх | Cообщить модератору

92. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (94), 04-Сен-23, 13:45 
Если бы в мажорном релизе не ломалась совместимость, это был бы не мажорный релиз. Загуглили бы хоть сначала.
Ответить | Правка | К родителю #70 | Наверх | Cообщить модератору

115. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +2 +/
Сообщение от Аноним (69), 04-Сен-23, 14:50 
погуглил и узнал, что у ядра Linux не было мажорных релизов с 13 декабря 2003 года, а еще я погуглил и не нашел того сайта, который бы мне запрещал делать глобальный релиз по моим собственным правилам, а еще я не нашел в гугле запрет анонам на опеннете возмущаться тем, что в гномоге нет закрепленного api, а есть огрызок, работоспособности которого никто не гарантирует
Ответить | Правка | Наверх | Cообщить модератору

150. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Sw00p aka Jerom (?), 04-Сен-23, 17:01 
> что у ядра Linux

Линуса на них не хватает

пс: ломать не строить!


Ответить | Правка | Наверх | Cообщить модератору

164. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (164), 04-Сен-23, 18:15 
> у ядра Linux не было мажорных релизов с 13 декабря 2003 года

Плохо гуглили. Если в версионировании Линукса не меняется первая цифорка это не значит что релиз не мажорный.

> не нашел того сайта, который бы мне запрещал делать глобальный релиз по моим собственным правилам

И не найдете, делайте как хотите. Есть только сайты с рекомендациями.

Ответить | Правка | К родителю #115 | Наверх | Cообщить модератору

195. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (69), 04-Сен-23, 20:37 
> Плохо гуглили.

Гораздо лучше тебя. Ведь суть - не сломана обратная совместимость, значит не мажорный релиз (ну так утверждал комментатор выше). Те, кто развивают Linux, говорят, что api пространства в минорных релизах не ломают, то есть с ядра 2.6, которое вышло в декабре 2003 года, а значит мажорных релизов не выходило вот уже почти 20 лет

> И не найдете, делайте как хотите. Есть только сайты с рекомендациями.

Дак как хотите или есть правила, которые мне надо нагуглить, как сказал комментатор выше?

Ты, влезая в тред комментов, что сказать то хотел?

Ответить | Правка | Наверх | Cообщить модератору

101. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Kuromi (ok), 04-Сен-23, 14:01 
Только на днях из любопытсва сомтрел, а что там будет в Гнум 45. В описаловах огромными буквами, мол, чудовищной важности релиз, прям огромный шаг вперед, при этом на самом деле, заменили EOG на другое такое же лишенное функциональности, пару приложенй перевели на ГТК4. Скука.

То как развивается Гном имхо очень хорошо видно на примере их хваленого Gnome Web - проблемы (тормозит, падает, глючит) и баги все теже самые, ничего не меняется, зато они гуй причесывают.

Ответить | Правка | К родителю #21 | Наверх | Cообщить модератору

106. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (106), 04-Сен-23, 14:07 
> То как развивается Гном имхо очень хорошо видно на примере их хваленого
> Gnome Web - проблемы (тормозит, падает, глючит) и баги все теже
> самые, ничего не меняется, зато они гуй причесывают.

Ну, в этом случае врядли команда гномеров виновата - движок-то не их (webkit от эппл).
Хотя с падениями непонятно, не должно падать.

Ответить | Правка | Наверх | Cообщить модератору

12. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +7 +/
Сообщение от Герострат (?), 04-Сен-23, 09:58 
> В Гноме отвалятся расширения

А в чём новость?

Ответить | Правка | Наверх | Cообщить модератору

27. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (26), 04-Сен-23, 10:17 
Действительно, список бы, что расширяться теперь не будет, а что расширится.
Ответить | Правка | Наверх | Cообщить модератору

15. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +3 +/
Сообщение от troizet (ok), 04-Сен-23, 10:00 
А в чем проблема поддерживать оба механизма импорта?
Ответить | Правка | Наверх | Cообщить модератору

20. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +2 +/
Сообщение от Омноном (?), 04-Сен-23, 10:04 
Ну наверное в том, что интерпретатор один на весь шелл, из которого предыдущий механизм был выпилен, нет?
Ответить | Правка | Наверх | Cообщить модератору

46. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +6 +/
Сообщение от Аноним (46), 04-Сен-23, 10:54 
ну так вопрос в том, зачем из этого интерпретатора выпиливать старый механизм? Г-споди, да даже nodejs поддерживает и старый require(), и стандартный import.
Ответить | Правка | Наверх | Cообщить модератору

51. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Омноном (?), 04-Сен-23, 11:01 
Там костыль (в gjs) и говнаипалок а не `require` был, его и выпилили заменив на обычные модули.
Ответить | Правка | Наверх | Cообщить модератору

62. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +2 +/
Сообщение от ОШИБКА Отсутствуют данные в поле Name (?), 04-Сен-23, 11:27 
Стоит заметить, что "обычные" ES6 модули - состряпанный на коленке какими-то студентам отстой, запиханный в глотку сообщества силой корпорации добра, что довольно легко гуглится.
Ответить | Правка | Наверх | Cообщить модератору

131. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +1 +/
Сообщение от хрю (?), 04-Сен-23, 15:47 
Ну это ж надо было подумать или (о боже!) позаботиться о пользователях. Таким путём пользователь Гном может начать и другое [s]требовать[/s] просить, а уж этого допустить никак нельзя. +)
Если серьзно, то сложилось мнение, что усё что выходит из под пера красношляпки следует идеологии -"мы открыли код, и вы должны быть безумно счастливы, а нас больше ничего не колышет".
Ответить | Правка | К родителю #15 | Наверх | Cообщить модератору

18. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +6 +/
Сообщение от Анонимов Аноним Анонимович (?), 04-Сен-23, 10:04 
Весь мир: нам нужна обратная совместимость, единый фрэймворк и UI
Gnome разрабы: пупсики, мы тут кое чё изменили

Имхо, все эти шаги разрабов не более чем прихоть маркетологов, чтобы проект был на слуху и было больше «красивых» циферок в отчетах. Вона скока комитов и пул реквестов за год! Усердно стараются ребятушки-девчатушки.

Я хз кем надо быть, чтобы юзать гном, это литерали самое нон юзер френдли DE ever I have seen. Мерзкий кде и то более адекватен в своём развитии, чем эти… впрочем, возможно, chaos by design это фишка гнома?

Ответить | Правка | Наверх | Cообщить модератору

28. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +2 +/
Сообщение от Аноним (6), 04-Сен-23, 10:17 
> это литерали самое нон юзер френдли

переведите, пожалуйста

Ответить | Правка | Наверх | Cообщить модератору

231. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +1 +/
Сообщение от Skullnetemail (ok), 05-Сен-23, 03:16 
Перевожу: ты, user - ничтожное существо и должен юзать GNOME так как этого хотят разработчики. Недостаточно фич - делай сам, это open-source (C), и может быть мы смержим твои изменения, но скорее всего нет. Не нравятся то как сделано - значит ты неправильный пользователь и хейтер, а возможно ещё и расист. Выкинули фичи? Мы просто упрощаем интерфейс (С). Если мы что-то сломали в GTK, то виноваты разработчики приложений, которые должны фиксить всё это. А ещё наше DE самое самое и в каждом популярном дистрибутиве линукса, поэтому в любых проблемах GNOME виноват ТЫ.
Ответить | Правка | Наверх | Cообщить модератору

35. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +3 +/
Сообщение от name (??), 04-Сен-23, 10:34 
> ever I have seen

I have ever seen

Ответить | Правка | К родителю #18 | Наверх | Cообщить модератору

54. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  –1 +/
Сообщение от Аноним (54), 04-Сен-23, 11:05 
> гном, это литерали самое нон юзер френдли DE [...] Мерзкий кде

а вы чем пользуетесь?

Ответить | Правка | К родителю #18 | Наверх | Cообщить модератору

108. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  –5 +/
Сообщение от Аноним (205), 04-Сен-23, 14:16 
Знаем мы ваши юзер френдли DE, проходили, меня Гном в дефолтном виде устраивает, более того он именно так и задумывался разрабами, он вполне удобный по дефолту если понять задумку разработчиков, а не пытаться переделать его под что-то более привычное нарушая логику работы окружения.
Ответить | Правка | К родителю #18 | Наверх | Cообщить модератору

133. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +1 +/
Сообщение от нейм (?), 04-Сен-23, 15:52 
То есть ты выбираешь софт не для того чтобы он работал на тебя и для тебя, а чтобы самому подкладываться под него?
Ответить | Правка | Наверх | Cообщить модератору

215. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (205), 05-Сен-23, 00:20 
Нет я выбираю максимально удобный для меня софт который не требует допиливания и траты времени на него.
Ответить | Правка | Наверх | Cообщить модератору

146. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним Максим (?), 04-Сен-23, 16:52 
>>вполне удобный по дефолту если понять задумку разработчиков

Ну да, как аналогия, наняли работников сделать ремонт. Они сделали, но по своему. Хорошо сделали, но совсем не то что требовалось.
И тут также, как ни проникайся пониманием к видению DE разработчиками, рациональности в котором есть, это не отменяет потребности в инструменте для работы, нужном и удобном для себя лично.

Ответить | Правка | К родителю #108 | Наверх | Cообщить модератору

216. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (205), 05-Сен-23, 00:24 
Это не аналогия, аналогия когда тебе предложили несколько дизайн проектов, и ты выбрал тот который тебе больше подходит и нравится, а хейтеры гнома зачем-то выбирают дизайн проект который их не устраивает и пытаются переделать его в совершенно другой и жалуются на это окружающим.
Ответить | Правка | Наверх | Cообщить модератору

175. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (173), 04-Сен-23, 18:59 
Скорее всего они хотят успеть в вагон поезда в вебню.

Вероятно, придуман способ использования.

Ответить | Правка | К родителю #18 | Наверх | Cообщить модератору

25. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (25), 04-Сен-23, 10:13 
Никто не думал выкинуть gjs и заменить его на guile js?
Ответить | Правка | Наверх | Cообщить модератору

29. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +1 +/
Сообщение от Хухрымухры (ok), 04-Сен-23, 10:17 
Ни кто не думал выкинуть js?
Ответить | Правка | Наверх | Cообщить модератору

89. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  –1 +/
Сообщение от Аноним (8), 04-Сен-23, 13:35 
и заменить... чем?

так любой студент троечник мог сделать на коленке "очень нужное дополнение"
а что-то более сложное они не осилят

Ответить | Правка | Наверх | Cообщить модератору

102. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +1 +/
Сообщение от Аноним (102), 04-Сен-23, 14:01 
А зачем нам дополнения троечников? А хочу дополнения от отличников!
Ответить | Правка | Наверх | Cообщить модератору

112. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Анонимусс (?), 04-Сен-23, 14:37 
Тогда у тебя будет два дополнения... ну может три.
Ответить | Правка | Наверх | Cообщить модератору

234. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Хухрымухры (ok), 05-Сен-23, 06:06 
> и заменить... чем?

Растом же.

А если серьёзно, то можно завести wasm. По идее он должен уже сейчас запускаться, но бесполезен без API к UI.

> так любой студент троечник мог сделать на коленке "очень нужное дополнение"

а что-то более сложное они не осилят

Их проблемы.

Ответить | Правка | К родителю #89 | Наверх | Cообщить модератору

169. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  –1 +/
Сообщение от Аноньимъ (ok), 04-Сен-23, 18:41 
Просто на guile.
И никаких проблем.

На гуль недостаточно радужный и прогрессивный.
В нем слишком много скобочек и нет baNaNa нов!

Ответить | Правка | К родителю #25 | Наверх | Cообщить модератору

34. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +1 +/
Сообщение от Аноним (34), 04-Сен-23, 10:31 
Там что, дополнения на JS? o_O
Вот почему он тормоз то такой оказывается. Я думал там C, ну или хотя бы Vala.
Ответить | Правка | Наверх | Cообщить модератору

38. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от fumanchez (ok), 04-Сен-23, 10:38 
Ну тогда и vim c emacs тормоза, потому что скриптов крутят еще больше.
Ответить | Правка | Наверх | Cообщить модератору

58. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +1 +/
Сообщение от Аноним (138), 04-Сен-23, 11:13 
Конечно тормоза, адовые причём. Даже на современном железе.
Ответить | Правка | Наверх | Cообщить модератору

68. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от fumanchez (ok), 04-Сен-23, 11:40 
I/O bound, что тут еще сказать.
Ответить | Правка | Наверх | Cообщить модератору

64. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (64), 04-Сен-23, 11:31 
У меня обычный vi, ничего не тормозит
Ответить | Правка | К родителю #38 | Наверх | Cообщить модератору

269. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Анонимус228 (?), 05-Сен-23, 13:09 
Прямо vi, за авторством Билла Джоя? Где вы такой отрыли и зачем?

Подозреваю, что на самом деле речь про какой-нибудь vim-minimal в голой конфигурации, ещё бы он тормозил.

Ответить | Правка | Наверх | Cообщить модератору

91. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (8), 04-Сен-23, 13:38 
а прикинь там был бы С ?
"виджет вышел за границы массива, и подарил рут"
не, спасибо, пусть лучше буде жабаскрипт))
Ответить | Правка | К родителю #34 | Наверх | Cообщить модератору

95. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (106), 04-Сен-23, 13:48 
> а прикинь там был бы С ?
> "виджет вышел за границы массива, и подарил рут"
> не, спасибо, пусть лучше буде жабаскрипт))

Звучит так как-будто ты не радуешься подаркам.

Ответить | Правка | Наверх | Cообщить модератору

107. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (102), 04-Сен-23, 14:08 
А прикинь, что все популярные JS-движки на C/C++ написаны. То есть не только тормозят, но ещё и за границы выходят.
Ответить | Правка | К родителю #91 | Наверх | Cообщить модератору

111. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Анонимусс (?), 04-Сен-23, 14:36 
А движки написаны тоже кем попало?
Не, ну в том же v8 тоже факапы случаются, но это не сравнить с писателями дополнений.
Ответить | Правка | Наверх | Cообщить модератору

305. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (-), 06-Сен-23, 10:40 
> а прикинь там был бы С ?
> "виджет вышел за границы массива, и подарил рут"
> не, спасибо, пусть лучше буде жабаскрипт))

...а зачем оно там вообще под рутом работало - мы подумаем потом. Хипстеры такие предсказуемые :)


Ответить | Правка | К родителю #91 | Наверх | Cообщить модератору

176. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (173), 04-Сен-23, 19:01 
> Там что, дополнения на JS? o_O

Там ещё и панели задач на JS же глючат у дистрибутива, называемого некоторыми топчиком чего-то.

Ответить | Правка | К родителю #34 | Наверх | Cообщить модератору

306. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (-), 06-Сен-23, 10:41 
>> Там что, дополнения на JS? o_O
> Там ещё и панели задач на JS же глючат у дистрибутива, называемого
> некоторыми топчиком чего-то.

Ну так топчиком можно быть в разных вещах. Даже вот в глюках. Не всем же хорошими парнями быть, фантомас тоже тема нужная.

Ответить | Правка | Наверх | Cообщить модератору

36. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +2 +/
Сообщение от fumanchez (ok), 04-Сен-23, 10:36 
Заменили свой велосипед на общепринятый способ, т.е. нормально сделали - в open source велосипедам не место.
Ответить | Правка | Наверх | Cообщить модератору

43. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +3 +/
Сообщение от Аноним (39), 04-Сен-23, 10:45 
А где кавайгерл и остальные адепты РендХата и Гнома которые рассказывали что все можно допилить с помощью дополнений?
Ответить | Правка | Наверх | Cообщить модератору

167. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +3 +/
Сообщение от пох. (?), 04-Сен-23, 18:36 
Заняты. Перепиливают. "всё".


Ответить | Правка | Наверх | Cообщить модератору

217. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +1 +/
Сообщение от Аноним (205), 05-Сен-23, 00:27 
Так дополнения не запретили, уже имеющиеся дополнения переделать под новые реалии 5 минутное дело, понабежали хейтеры и раздувают проблему.
Ответить | Правка | К родителю #43 | Наверх | Cообщить модератору

307. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (-), 06-Сен-23, 12:40 
> Так дополнения не запретили, уже имеющиеся дополнения переделать под новые реалии 5
> минутное дело, понабежали хейтеры и раздувают проблему.

Если тратить 5 минут на каждую мелкую какаху, можно случайно обнаружить что каках на глобусе много - а жизнь у человека не резиновая, если ваша фамилия не МакЛауд.

Ответить | Правка | Наверх | Cообщить модератору

47. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (47), 04-Сен-23, 10:56 
А альтернативы есть Gnome (GTK) и KDE (Qt)?
Просто что первый что второй мучение сплошное...
Ответить | Правка | Наверх | Cообщить модератору

57. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  –2 +/
Сообщение от Аноним (39), 04-Сен-23, 11:12 
Да вообще что угодно. Полно их.
Ответить | Правка | Наверх | Cообщить модератору

65. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +1 +/
Сообщение от Аноним (64), 04-Сен-23, 11:32 
EFL, FLTK, Motif, wxWidgets
Ответить | Правка | К родителю #47 | Наверх | Cообщить модератору

85. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +3 +/
Сообщение от 12yoexpert (ok), 04-Сен-23, 13:27 
xfce и dwm, больше ничего адекватного нет: либо васянские DE, либо такие DE, которые не работают без васянского говнокода с гитхаба (привет awesome)
Ответить | Правка | К родителю #47 | Наверх | Cообщить модератору

98. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  –2 +/
Сообщение от Аноним (98), 04-Сен-23, 13:51 
Если человек пишет, что dwm - это адекватное...
Ну, это его определенным образом характеризует))))
Ответить | Правка | Наверх | Cообщить модератору

170. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноньимъ (ok), 04-Сен-23, 18:43 
А что там с awesome?

Я его как-то очень успешно юзал под Фрей одно время, прям хорошо хорошо было.

Но потом они сломали что-то? И мой конфиг перестал работать от слова совсем.
Заново настроить я его почему-то не смог.

Ответить | Правка | К родителю #85 | Наверх | Cообщить модератору

257. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (257), 05-Сен-23, 09:21 
> А что там с awesome?
> И мой конфиг перестал работать от слова совсем.

Заново настроить я его почему-то не смог.

не благодари

Ответить | Правка | Наверх | Cообщить модератору

235. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  –1 +/
Сообщение от Хухрымухры (ok), 05-Сен-23, 06:08 
i3wm норм
Ответить | Правка | К родителю #85 | Наверх | Cообщить модератору

50. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от FF (?), 04-Сен-23, 11:01 
Ну вот ю, гноме превратится в тыкву при очередном обновлении, но это норма для любителей.
Ответить | Правка | Наверх | Cообщить модератору

71. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +2 +/
Сообщение от Аноним (82), 04-Сен-23, 12:04 
Практически для каждого расширения нужно править как минимум shell-version, большая проблема "const GLib = imports.gi.GLib;" на "import GLib from 'gi://GLib';"?
Ответить | Правка | Наверх | Cообщить модератору

56. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  –2 +/
Сообщение от Евгений Ивановemail (?), 04-Сен-23, 11:10 
Нормальная для Гном ситуевина, уже никто не обижается ;)

Мне Гном на ноуте удобнее, а на ПК удобнее КДЕ. Обо шикарны и молодцы разрабы, что не закинули проекты!

Ответить | Правка | Наверх | Cообщить модератору

177. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (173), 04-Сен-23, 19:05 
Т.е., видимо, неважно вообще плохое ли оно и там и там.

Дело, видимо, в каком-то шике. Который другим не нужен и мало используется (и вообще и по делу).

Ответить | Правка | Наверх | Cообщить модератору

76. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +2 +/
Сообщение от Аноним (106), 04-Сен-23, 12:34 
GNOME ещё кто-то использует? В чём смысл когда есть MATE?
Ответить | Правка | Наверх | Cообщить модератору

77. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (77), 04-Сен-23, 12:55 
MATE выглядит слишком старинно
Ответить | Правка | Наверх | Cообщить модератору

273. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (39), 05-Сен-23, 13:43 
В данном случае это огромный такой плюс.
Ответить | Правка | Наверх | Cообщить модератору

80. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  –2 +/
Сообщение от Аноним (82), 04-Сен-23, 13:06 
MATE задумывался как продолжение поддержки Gnome2 на Gtk2. Потом они поняли, что gtk2 это тупик и начали портировать на gtk3. Т.е. они всегда будут в роли догонаяющего Gnome, да еще и с ретроградным интерфейсом.
MATE ещё кто-то использует? В чём смысл, когда есть GNOME? У GNOME по удобству пользования и допиленности конкурентов на linux нет.
Ответить | Правка | К родителю #76 | Наверх | Cообщить модератору

87. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +3 +/
Сообщение от Аноним (8), 04-Сен-23, 13:33 
Кавайка, ты забыла залогиниться.
Ответить | Правка | Наверх | Cообщить модератору

163. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от svvord (ok), 04-Сен-23, 18:12 
https://lookolovka.blogspot.com/2022/02/pereklyuchenie-raskl...

Ну да, допиленность выпирает из всех щелей

Ответить | Правка | К родителю #80 | Наверх | Cообщить модератору

185. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  –1 +/
Сообщение от Ефрщ (?), 04-Сен-23, 19:36 
не включай дурака, хот-кей переключения раскладки win+space.
Ответить | Правка | Наверх | Cообщить модератору

193. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Skullnetemail (ok), 04-Сен-23, 20:17 
От портирования на GTK3 все DE только огребли проблем и просадки по производительности. Ради справедливости, в GTK 3 были какие-то новые фичи, но можно было тупо остаться на GTK2 и допилить напильником. GTK3 - по сути последняя адекватная версия GTK. Дальше только форкать GTK2/3.
Ответить | Правка | К родителю #80 | Наверх | Cообщить модератору

285. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +1 +/
Сообщение от prokoudineemail (ok), 05-Сен-23, 15:33 
> GTK3 - по сути последняя адекватная версия GTK.

Сначала gtk1 был последней адекватной версией, потому что диалог открытия/сохранения поменяли.

Потом gtk2 был последней адекватной версией ещё почему-то.

Теперь вона чё — gtk3 уже был последней адекватной версией.

Можно только позавидовать такому отточенному навыку переобувания на лету.

Ответить | Правка | Наверх | Cообщить модератору

288. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Skullnetemail (ok), 05-Сен-23, 17:19 
> Можно только позавидовать такому отточенному навыку переобувания на лету.

Так ты сам подтвердил что GTK деградировал от версии к версии. А GTK3->GTK4 деграднул настолько, что GTK пора форкать. Другого нормального варианта нет (ну кроме переписывания на Qt).

Ответить | Правка | Наверх | Cообщить модератору

109. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  –1 +/
Сообщение от Аноним (205), 04-Сен-23, 14:33 
На опеннете постоянно выдают желаемое за действительное, по статистике два главных рабочих окружения это Gnome и KDE, а все остальные, даже если собрать их вместе и посчитать имеют гораздо меньшую долю пользователей.
Ответить | Правка | К родителю #76 | Наверх | Cообщить модератору

191. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Skullnetemail (ok), 04-Сен-23, 20:06 
> На опеннете постоянно выдают желаемое за действительное, по статистике два главных рабочих окружения это Gnome и KDE

Вы устарели лет на 12. GNOME уже давно не главный, а третьесортный помойный DE, который стараются пиарить и пропихнуть как главный. Десктопом рулят KDE, Xfce, Mate и Cinammon.

Ответить | Правка | Наверх | Cообщить модератору

219. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (205), 05-Сен-23, 00:44 
Да ладно, а все статистики говорят о об обратном. Гном если что дефолт ДЕ в большинстве дистрибутивов.
Ответить | Правка | Наверх | Cообщить модератору

281. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Skullnetemail (ok), 05-Сен-23, 14:49 
А за "Единую Россию" голосуют большинство граждан РФ.
Ответить | Правка | Наверх | Cообщить модератору

140. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Error_Sans (?), 04-Сен-23, 16:35 
В чём смысл MATE, когда это - очередной раскол в сообществе, не приемлющем настройку DE? Пользуйтесь KDE, благо, он существует и процветает.
Ответить | Правка | К родителю #76 | Наверх | Cообщить модератору

149. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +1 +/
Сообщение от Аноним (106), 04-Сен-23, 16:56 
> В чём смысл MATE, когда это - очередной раскол в сообществе, не
> приемлющем настройку DE? Пользуйтесь KDE, благо, он существует и процветает.

MATE более легковесная, никаких JS скриптов. При этом там есть всё что нужно от DE.

Ответить | Правка | Наверх | Cообщить модератору

171. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноньимъ (ok), 04-Сен-23, 18:46 
Все кто сидит на Убунте, тоесть всё корпоративное ойти юзающее Линукс на компах своих рабов.
Ответить | Правка | К родителю #76 | Наверх | Cообщить модератору

179. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (173), 04-Сен-23, 19:11 
> GNOME ещё кто-то использует? В чём смысл когда есть MATE?

OpenBox/XFCE сессия и панелька LX Panel. Что-либо ломается или исчезает - ооочень редко. Условно в любом дистрибутиве можно поставить и настроить как на всех своих компах.

В Гноме, да и в КДЕ, не припомню нужных функций, чтоб не было в остальных DE.

Ответить | Правка | К родителю #76 | Наверх | Cообщить модератору

84. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от 12yoexpert (ok), 04-Сен-23, 13:26 
им бы с новыми совместимость обеспечить, но к гному у меня нет претензий давно и никаких, в xfce за много лет только один фейл был - сломали декорацию окон
Ответить | Правка | Наверх | Cообщить модератору

227. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Skullnetemail (ok), 05-Сен-23, 02:57 
> в xfce за много лет только один фейл был - сломали декорацию окон

Это же фейл разрабов GNOME/GTK, которые стали пихать CSD во все приложения на GTK.

Ответить | Правка | Наверх | Cообщить модератору

93. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +2 +/
Сообщение от th3m3 (ok), 04-Сен-23, 13:46 
>В GNOME 45 будет нарушена совместимость со старыми дополнениями

А в чём новость то? Всегда так в GNOME было. Вышла новая версия - часть расширений отвалилась. И причина не важна, постоянно всё ломают. Давно уже все привыкли или ушли на другие DE ;)

Ответить | Правка | Наверх | Cообщить модератору

118. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (82), 04-Сен-23, 15:00 
> А в чём новость то?

Прочитал бы новость прежде чем комент строчить. Ключевой посыл в новости не про то, что "GNOME 45 будет нарушена совместимость", а про то, что "в GNOME 45 перевели GNOME Shell с собственной системы импорта модулей на стандартный механизм ECMAScript 6" и преведено руководство по портированию, которое сводится к правке пары строк кода и всего делов то.

Ответить | Правка | Наверх | Cообщить модератору

121. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (205), 04-Сен-23, 15:09 
Привыкли до того что все расширения получают обновления к тому моменту как сам гном попадает в дистрибутивы.
Ответить | Правка | К родителю #93 | Наверх | Cообщить модератору

116. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (116), 04-Сен-23, 14:52 
Опять с Dropbox заниматься сомнительными вещами
Ответить | Правка | Наверх | Cообщить модератору

128. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (128), 04-Сен-23, 15:36 
Вот поэтому и надо уходить на macOS, кто этого ещё не сделал.
Ответить | Правка | Наверх | Cообщить модератору

134. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  –2 +/
Сообщение от нейм (?), 04-Сен-23, 15:54 
Так тот же гном, только обрубленный настолько что вообще никаких обнов нет (и прогресса)

Смысл?

Ответить | Правка | Наверх | Cообщить модератору

194. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +1 +/
Сообщение от пох. (?), 04-Сен-23, 20:21 
> что вообще никаких обнов нет
> (и прогресса)

Г-ди, счастье -то какое! (было бы... но, к сожалению, нет)

Ответить | Правка | Наверх | Cообщить модератору

228. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Skullnetemail (ok), 05-Сен-23, 02:57 
Достаточно уйти на адекватное DE, а не менять шило на мыло.
Ответить | Правка | К родителю #128 | Наверх | Cообщить модератору

129. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +2 +/
Сообщение от pofigist (?), 04-Сен-23, 15:39 
Шо? Опять?!
Ответить | Правка | Наверх | Cообщить модератору

135. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  –3 +/
Сообщение от Аноним (135), 04-Сен-23, 16:09 
Это уже было известно более трех недель назад. я об этом писал тут в комментах, и только сейчас тут начался всеобщий понос и унижение. По качеству и целостности экосистемы альтернатив GNOME нет, все остальное кустарщина не заслуживающая внимания.
Ответить | Правка | Наверх | Cообщить модератору

148. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +1 +/
Сообщение от кокосистема (?), 04-Сен-23, 16:55 
Экосистема из заблюренного меню с громадными иконками, когда там по диагонали уже будут рабочие столы?
Ответить | Правка | Наверх | Cообщить модератору

158. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +1 +/
Сообщение от Ржомба (?), 04-Сен-23, 17:36 
Что такое "экосистема GNOME"? Убогонький шелл и с 2 десятка приложений с возможностями подчас меньшими, чем у мобильных аналогов?
Ответить | Правка | К родителю #135 | Наверх | Cообщить модератору

155. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (155), 04-Сен-23, 17:22 
XFCE примерно на порядок удобнее и понятнее.

В чём фишка Gnome? Мне интересно.

Пользователи Gnome напоминают анекдот о мышах и кактусе.

Ответить | Правка | Наверх | Cообщить модератору

160. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Skullnetemail (ok), 04-Сен-23, 17:37 
> В чём фишка Gnome? Мне интересно.

Поклонение SJW карго-культу.

> XFCE примерно на порядок удобнее и понятнее.

По количеству фич Xfce опережает GNOME на целое поколение.

Ответить | Правка | Наверх | Cообщить модератору

174. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от eugener (ok), 04-Сен-23, 18:58 
> XFCE примерно на порядок удобнее и понятнее.

GNOME + расширения DashToDock и Unite - и получаешь удобную среду подобную Unity. Слева панель приложений, сверху панель с которой сливается заголовок открытого окна. К сожалению, в XFCE так нормально не сделать, все панели приложений какие-то недоделаные, а плагин к панели который объединяет её с заголовком и кнопками окна - давно заброшен и не работает со свежими версиями XFCE.
Вот и получается что альтернатив нет. Да и по дизайну GNOME лучше всех, тот же XFCE уже просто топорного вида по сравнению с GNOME.

Ответить | Правка | К родителю #155 | Наверх | Cообщить модератору

181. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (151), 04-Сен-23, 19:13 
> Да и по дизайну GNOME лучше всех

нам с тобой лучше уж не упоминать, что под гном туева хуча классных тем, которые ставятся на раз-два, в отличии от кед, где что бы их ставить нужно танцевать с бубном) помолчим, что бы не расстраивать тех вопящих ребят в кедах)

Ответить | Правка | Наверх | Cообщить модератору

183. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от eugener (ok), 04-Сен-23, 19:23 
> нам с тобой лучше уж не упоминать, что под гном туева хуча
> классных тем, которые ставятся на раз-два

Честно говоря с этим GTK 4 и libadwaita с темами для приложений теперь хреново. Ubuntu хоть сделали чтобы цветовую тему можно было менять, но то такое...

Темы под сам шелл - другое дело, но я их и не ставлю.)

Ответить | Правка | Наверх | Cообщить модератору

188. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Skullnetemail (ok), 04-Сен-23, 19:52 
> нам с тобой лучше уж не упоминать, что под гном туева хуча классных тем, которые ставятся на раз-два

И лучше не упоминать, что в GTK любят ломать эти темы каждый минорный релиз. К тому же у тебя clusterfuck из GTK2, GTK3, GTK4 тем, которые выглядят по разному. Плюс ещё CSD и libadwaita, которая выкидывает привычные темы. И ещё не понятно как заставить Qt приложения на этом всём зоопарке выглядеть нативно. Туева хуча, воистину!

Ответить | Правка | К родителю #181 | Наверх | Cообщить модератору

220. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (205), 05-Сен-23, 00:55 
Почему gtk2-3-4 должны выглядеть одинаково? Мечта ретрограда?
Ответить | Правка | Наверх | Cообщить модератору

222. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Skullnetemail (ok), 05-Сен-23, 01:06 
> Почему gtk2-3-4 должны выглядеть одинаково? Мечта ретрограда?

Потому что это один и тот же фреймворк.

Ответить | Правка | Наверх | Cообщить модератору

260. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  –1 +/
Сообщение от Аноним (205), 05-Сен-23, 10:48 
Давайте ещё в ядро изменения не будем вносить, ведь это одно и то же ядро, сам то понял что написал?
Ответить | Правка | Наверх | Cообщить модератору

187. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Skullnetemail (ok), 04-Сен-23, 19:47 
> GNOME + расширения DashToDock и Unite - и получаешь удобную среду подобную Unity.

Шо то %s, шо эта %s.

> все панели приложений какие-то недоделаные

Офигел, в Xfce у тебя в 5 раз больше фич чем в гноме.

> а плагин к панели который объединяет её с заголовком и кнопками окна - давно заброшен и не работает со свежими версиями XFCE

Форкни и портируй на свежую если тебе он так нужен.

> Да и по дизайну GNOME лучше всех, тот же XFCE уже просто топорного вида по сравнению с GNOME.

Достаточно было погуглить "Xfce unixporn" чтобы найти рулез графон. И фичи не вырезаны в отличии от сабжа.

https://www.reddit.com/r/unixporn/comments/kdh3s1/xfce_simpl.../
https://repository-images.githubusercontent.com/377729738/eb...
https://www.facebook.com/XfceNation/photos/a.114170623595406...

Ответить | Правка | К родителю #174 | Наверх | Cообщить модератору

261. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  –2 +/
Сообщение от Аноним (205), 05-Сен-23, 10:49 
Не вижу дизайна.
Ответить | Правка | Наверх | Cообщить модератору

309. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  –1 +/
Сообщение от Аноним (309), 06-Сен-23, 14:30 
> Достаточно было погуглить "Xfce unixporn" чтобы найти рулез графон. И фичи не вырезаны в отличии от сабжа.

Предложенные примеры выглядят по дизайну ещё хуже libadwaita.

Ответить | Правка | К родителю #187 | Наверх | Cообщить модератору

180. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (173), 04-Сен-23, 19:13 
> Пользователи Gnome напоминают анекдот о мышах и кактусе.

Просто многим не сказали, что дефолтное можно заменить в одну-две команды пакетного менеджера, типа apt install xfce4-desktop и ребунуться (если лень Display Manager рестартануть).

Ответить | Правка | К родителю #155 | Наверх | Cообщить модератору

184. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (173), 04-Сен-23, 19:27 
Или - apt install task-xfce-desktop
Ответить | Правка | Наверх | Cообщить модератору

317. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (317), 18-Сен-23, 15:38 
Зачем об этом гьоворить? Зачем в одну-две команды менять стильный и удобный ДЕ на ретроградный обрубок?
Ответить | Правка | К родителю #180 | Наверх | Cообщить модератору

165. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +1 +/
Сообщение от пох. (?), 04-Сен-23, 18:34 
Че?! У него была какая-то совместимость дополнений?

Ответить | Правка | Наверх | Cообщить модератору

178. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (151), 04-Сен-23, 19:08 
я тебе больше скажу, она остаётся
Ответить | Правка | Наверх | Cообщить модератору

230. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +1 +/
Сообщение от Skullnetemail (ok), 05-Сен-23, 03:00 
В прошлом...
Ответить | Правка | Наверх | Cообщить модератору

182. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (173), 04-Сен-23, 19:20 
Мда. Помню хлопчика, за свои купившего 30-ти дюймовый монитор на работу и поставившего Гном третий на рабочую станцию лет десять назад.

По Гному третьему было понятно: пользователей кинули, пишут что-то совсем другое.

Но, вебня пришла, все дружно покупкой айфонов и ведроидов проплатили и подтвердили развитие. Теперь вот... еште DE на JS.

Ответить | Правка | Наверх | Cообщить модератору

197. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +1 +/
Сообщение от Аноним (197), 04-Сен-23, 20:45 
Если разрабы GNOME что-то радикально меняют, значит, так лучше. Опробовал несколько наиболее популярных DE — лучше GNOME пока что ничего не придумали. Стабильный, быстрый, умеренно красивый, современный. Wayland, наконец.

Работаю на Fedora с 25-й версии.

Ответить | Правка | Наверх | Cообщить модератору

208. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (135), 04-Сен-23, 22:21 
Согласен, поставил уже попробовать тестовую сборку Fedora 39, все четко и продумано, новый установщик, а главное - даже вполне стабильно.
Ответить | Правка | Наверх | Cообщить модератору

226. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +1 +/
Сообщение от Skullnetemail (ok), 05-Сен-23, 02:52 
> Если разрабы GNOME что-то радикально меняют, значит, так лучше.

Стокгольмский синдром во все поля.

> Опробовал несколько наиболее популярных DE — лучше GNOME пока что ничего не придумали. Стабильный, быстрый, умеренно красивый, современный. Wayland, наконец.

Толсто.

Ответить | Правка | К родителю #197 | Наверх | Cообщить модератору

248. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (248), 05-Сен-23, 07:22 
Обоснуй, или балабол. Тебе чел рассказал личный опыт, а ты заплакал.
Ответить | Правка | Наверх | Cообщить модератору

271. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +1 +/
Сообщение от Аноним (39), 05-Сен-23, 13:39 
Обосновывать личный опыт? Ты что вообще сказал, хоть понял?
Ответить | Правка | Наверх | Cообщить модератору

211. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Вы забыли заполнить поле Name (?), 05-Сен-23, 00:05 
Лучше стандартный способ, чем костыль. По идее авторам расширений должно быть просто все поменять. Помнится у гнома еще свои средства для объявления классов вместо стандартных были.
Ответить | Правка | Наверх | Cообщить модератору

229. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  –3 +/
Сообщение от Skullnetemail (ok), 05-Сен-23, 02:59 
Кому интересно, почитайте эту же новость на главном SJW сабреддите линукса. Там каждый релиз сие поделия облизывют армия обсосов, и заминусованные комменты тоже почитайте, чтобы понять КАКАЯ у GNOME аудитория.

https://www.reddit.com/r/linux/comments/169r5o8/the_upcoming.../

Никому GNOME не нужен кроме культа фанатиков.

Ответить | Правка | Наверх | Cообщить модератору

245. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  –1 +/
Сообщение от Аноним (245), 05-Сен-23, 06:58 
успокойся уже, 🤡
Ответить | Правка | Наверх | Cообщить модератору

249. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (248), 05-Сен-23, 07:26 
> понять КАКАЯ у GNOME аудитория

Наибольшая? )

https://linux-hardware.org/?view=os_de

Ответить | Правка | К родителю #229 | Наверх | Cообщить модератору

277. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Skullnetemail (ok), 05-Сен-23, 14:43 
Нарисовали как всегда.
Ответить | Правка | Наверх | Cообщить модератору

263. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  –1 +/
Сообщение от Аноним (205), 05-Сен-23, 11:10 
Слабо накидываешь. Столько ненависти, тебя там обидели что-ли, или ты ненавидишь всех у кого мировоззрение или мнение не совпадает с твоим? Все кругом плохие и неправильные, а ты один правильный, что-то мне это напоминает. Под этой новостью куча твоих хейтерских комментариев, ну не нравится тебе гном не используй, или ты думаешь что твой хейт убедит пользователь этой ДЕ не использовать ее, ты явно переоцениваешь свои возможности и талант оратора.
Ответить | Правка | К родителю #229 | Наверх | Cообщить модератору

272. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +1 +/
Сообщение от Аноним (39), 05-Сен-23, 13:42 
>Там каждый релиз сие поделия облизывют армия обсосов, и заминусованные комменты тоже почитайте, чтобы понять КАКАЯ у GNOME аудитория.

Фабрика троллей и примкнувшие ним полезные идиоты. Это всё заговор рептилоидов с планеты Нибиру, чтобы Вендокапец никогда не наступил.  

Ответить | Правка | К родителю #229 | Наверх | Cообщить модератору

280. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Skullnetemail (ok), 05-Сен-23, 14:45 
Без шуток, Майкрософт донатит в GNOME Foundation, то есть оплачивает весь этот цирк.
Ответить | Правка | Наверх | Cообщить модератору

284. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +1 +/
Сообщение от Аноним (39), 05-Сен-23, 15:18 
Ну вот все понятно. Специально донатят, чтобы гном был неюзабелен и вызвал страх и отторжение у любого.
Ответить | Правка | Наверх | Cообщить модератору

315. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от AlexYeCu_not_logged (?), 11-Сен-23, 00:41 
Не, ты что. Они донатят, потому что хотят проспонсировать развитие качественного окружения рабочего стола под конкурирующую платформу. Корпорация Microsoft добрая, а благо пользователей всегда было для неё приоритетом.
Ответить | Правка | Наверх | Cообщить модератору

254. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Андрей04091977 (ok), 05-Сен-23, 07:46 
Вернули бы некоторый самый необходимый функционал чтоб расширения(плагины) вовсе не понадобились бы, а то с кастрацией слишком увлеклись.
Ответить | Правка | Наверх | Cообщить модератору

266. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +1 +/
Сообщение от Аноним (266), 05-Сен-23, 12:25 
Самое паршивое DE, которое я когда либо использовал. Даже не полноценная LXDE куда более юзабельна, чем этот гиппопотам, жрущий ресурсы не лучше венды, а функций - как кот наплакал. Перешёл на KDE Plasma и не жалуюсь. Считаю, что именно оно должно стать стандартным DE, которое нормально придерживается стандартов FreeDesktop, а не GNOME
Ответить | Правка | Наверх | Cообщить модератору

267. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Аноним (135), 05-Сен-23, 12:31 
Никогда такого не будет, только не это ... KDE.
Ответить | Правка | Наверх | Cообщить модератору

313. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Анонимусос (?), 09-Сен-23, 19:22 
Да сиди на своём Gnome если нравится бытт бетатестером
Ответить | Правка | Наверх | Cообщить модератору

276. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +1 +/
Сообщение от Бульдох (?), 05-Сен-23, 14:37 
Похрен на все эти DE, Openbox выполняет свои задачи на 100% и жрать не просит.
Ответить | Правка | Наверх | Cообщить модератору

283. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Skullnetemail (ok), 05-Сен-23, 15:04 
Как и jwm.
Ответить | Правка | Наверх | Cообщить модератору

300. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +/
Сообщение от Бульдох (?), 05-Сен-23, 23:58 
Точно.
Ответить | Правка | Наверх | Cообщить модератору

296. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +2 +/
Сообщение от Аноним (296), 05-Сен-23, 19:46 
С ностальгией посмотрел на WinAPI16, который до сих пор на % 95 совместим.
Ответить | Правка | Наверх | Cообщить модератору

299. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  –1 +/
Сообщение от Аноним (299), 05-Сен-23, 23:18 
Так и винда 11-я недалеко от NT ушла.
Ответить | Правка | Наверх | Cообщить модератору

298. "В GNOME 45 будет нарушена совместимость со старыми дополнени..."  +1 +/
Сообщение от Аноним (299), 05-Сен-23, 23:15 
Делов то import поменять. Думаю разработчики extensions уже новые версии в форках тестируют, никаких проблем не вижу с этим.
Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Партнёры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2024 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру