The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Раздел полезных советов: Установка AMD Catalyst 11.5 на Debi..."
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Раздел полезных советов: Установка AMD Catalyst 11.5 на Debi..."  +/
Сообщение от auto_tips (ok) on 21-Май-11, 10:12 
Для начала должны быть установлены пакеты:

   sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf \
      libstdc++6 dkms libqtgui4 execstack libelfg0 ia32-libs

Затем, нужен драйвер Catalyst и патчи к новому ядру:

   mkdir atifix
   cd atifix
   wget http://wwx2.ati.com/drivers/linux/ati-driver-installer-11-5-...
   wget http://www.mindwerks.net/wp-content/uploads/2011/03/2.6.39_b...
   wget http://www.mindwerks.net/wp-content/uploads/2011/03/no_bkl.p...

Распаковываем драйвер и применяем патчи:

   chmod +x ati-driver-installer-11-5-x86.x86_64.run
   ./ati-driver-installer-11-5-x86.x86_64.run --extract driver
   mv *.patch ./driver/
   cd ./driver/
   patch -p1 -i 2.6.39_bkl.patch && patch -p1 -i no_bkl.patch

После патчей устанавливаем драйвер:

   ./ati-installer.sh 8.85 --install

Если во время установки не всплыло никаких зависимостей, то выполняем

   aticonfig --initial -f

Перегружаем компьютер или X-Server и проводим на всякий случай диагностику:

   cat /var/log/Xorg.0.log | grep EE

После рестарта можно диагностировать с помощью

   fglrxinfo и fgl_glxgears


URL: http://www.planet3dnow.de/vbulletin/showthread.php?t=393400&...
Обсуждается: https://www.opennet.ru/tips/info/2577.shtml

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по ответам | RSS]

1. "Установка AMD Catalyst 11.5 на Debian-подобную систему с Lin..."  +/
Сообщение от Wormik (ok) on 21-Май-11, 10:12 
Кажется, это был не первый совет? Вот так гораздо лучше.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Установка AMD Catalyst 11.5 на Debian-подобную систему с Lin..."  +/
Сообщение от Анон on 21-Май-11, 13:30 
А сгенерить пакет не катит? Обязательно надо в системе насрать.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

3. "Установка AMD Catalyst 11.5 на Debian-подобную систему с Lin..."  +/
Сообщение от Карбофос (ok) on 21-Май-11, 21:24 
ну почему же, по пунктам
./ati-installer.sh 8.85 --listpkg
и потом для волнующего массы дистрибутива из доступных из списка
./ati-installer.sh 8.85 --buildpkg DistrName
Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Установка AMD Catalyst 11.5 на Debian-подобную систему с Lin..."  +/
Сообщение от stranger (??) on 21-Май-11, 21:52 
Вот и надо было это написать, а не install.
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "Установка AMD Catalyst 11.5 на Debian-подобную систему с Lin..."  +/
Сообщение от Аноним (??) on 22-Май-11, 12:28 
-    for (i = 0; i < __KE_MAX_SPINLOCKS; i++)
-        dev->spinlock[i] = SPIN_LOCK_UNLOCKED;
-

я хренею с таких патчей..
а заменить на spinlock_init() видимо не судьба.. или очередная религия не позволяет.

А потом будут наезды на ATI что дескать дрова кривые.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

6. "Установка AMD Catalyst 11.5 на Debian-подобную систему с Lin..."  +/
Сообщение от Аноним (??) on 22-Май-11, 12:30 
вопрос "просто убрать bkl" тоже вызывает сомнения - мало ли чего им снхронизировалось..

Вот уж криворукие которые такие патчи делают.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

7. "Установка AMD Catalyst 11.5 на Debian-подобную систему с Lin..."  +/
Сообщение от a (??) on 23-Май-11, 12:31 
а судьи - кто?
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

8. "Установка AMD Catalyst 11.5 на Debian-подобную систему с Lin..."  +/
Сообщение от bang (??) on 23-Май-11, 19:07 
так это ж linux style! не?
Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

9. "Установка AMD Catalyst 11.5 на Debian-подобную систему с Lin..."  +/
Сообщение от Аноним (??) on 23-Май-11, 19:47 
> А потом будут наезды на ATI что дескать дрова кривые.

Они кривые хотя-бы потому что вообще требуют всей этой возни.

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

10. "Установка AMD Catalyst 11.5 на Debian-подобную систему с Lin..."  +/
Сообщение от Аноним email(??) on 24-Май-11, 10:56 
Заплакал от радости, когда увидел этот совет - ибо эти дрова от рождения кривые и поставить их по-простому никак нельзя. Интересно, для 2.6.38 этот бубен подойдет?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

11. "Установка AMD Catalyst 11.5 на Debian-подобную систему с Lin..."  +/
Сообщение от Аноним email(??) on 24-Май-11, 11:51 
Где бы найти такие патчи для 38-го ядра?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

12. "Установка AMD Catalyst 11.5 на Debian-подобную систему с Lin..."  +/
Сообщение от Карбофос (ok) on 24-Май-11, 12:51 
а что с 38 не так?
Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

13. "Установка AMD Catalyst 11.5 на Debian-подобную систему с Lin..."  +/
Сообщение от Карбофос (ok) on 24-Май-11, 13:25 
ну сообщите о кривости патча автору  http://www.mindwerks.net
Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

14. "Установка AMD Catalyst 11.5 на Debian-подобную систему с Lin..."  +/
Сообщение от Карбофос (ok) on 24-Май-11, 13:26 
дополнил
Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

15. "Установка AMD Catalyst 11.5 на Debian-подобную систему с Lin..."  +/
Сообщение от Аноним email(??) on 24-Май-11, 15:08 
стоит 38-е ядро из бэкпортов (Debian 6.0.1) - так вот, на него не встает fglrx из репов, и с сайта поставить не выходит...
Во время установки получаю вот такую ошибку:
[Error] Kernel Module : Failed to build fglrx-8.85 with DKMS
[Error] Kernel Module : Removing fglrx-8.85 from DKMS
Вот и что с этим делать?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

17. "Установка AMD Catalyst 11.5 на Debian-подобную систему с Lin..."  +/
Сообщение от lmerZb0t on 27-Май-11, 14:18 
А для 2.6.32-5 пойдёт?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору


Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру