The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Конфигурация почтовых серверов при BGP с двумя разными ISP"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"Конфигурация почтовых серверов при BGP с двумя разными ISP"  
Сообщение от weris email(ok) on 15-Дек-08, 10:03 
Имеется такая схема подключения:
http://sibaudio.ru/two_isp.jpg

краткое описание-
1 провайдер. анлимный канал. от него по бгп получаем только дефолт роут.
от них имеем сетку /28 в использовании.

2 провайдер. быстрый канал. трафик внутри городских сетей бесплатно, вне города - помегабайтно дорого. по бгп получаем дефолт (для резерва)+городские сети.
имеем подсеть /29 в использовании.

Собственной АС пока не имеем, используем приватную.

Есть 2 почтовых сервера выступающих front-end (антиспам,антивирь) - и релей на локальный Exchange.

Каждый из них статик натом прописан в инет, по одному на каждого провайдера.

Cisco 2821,
2800 Software (C2800NM-ADVIPSERVICESK9-M), Version 12.4(22)T, RELEASE SOFTWARE (fc1)

C таким конфигом:
!
interface GigabitEthernet0/1.16
description *** DMZ-gate for internet ***
encapsulation dot1Q 16
ip address 10.82.16.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
ip policy route-map mail
!
interface GigabitEthernet0/1.207
description *** SibTelecom ***
encapsulation dot1Q 207
ip address 217.XX.XX.165 255.255.255.248
ip access-group 107 in
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly
no cdp enable
!
interface GigabitEthernet0/1.254
description *** RosTelecom ***
encapsulation dot1Q 254
ip address 94.XX.XX.90 255.255.255.252
ip access-group 154 in
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly
no cdp enable
!

!
router bgp 65527
bgp router-id 217.XX.XX.165
bgp log-neighbor-changes
neighbor 94.XX.XX.89 remote-as 12389
neighbor 94.XX.XX.89 update-source GigabitEthernet0/1.254
neighbor 217.XX.XX.161 remote-as 15759
neighbor 217.XX.XX.161 update-source GigabitEthernet0/1.207
!
address-family ipv4
  neighbor 94.XX.XX.89 activate
  neighbor 94.XX.XX.89 weight 100
  neighbor 94.XX.XX.89 prefix-list RTK_in in
  neighbor 217.XX.XX.161 activate
  no auto-summary
  no synchronization
exit-address-family
!
!
ip nat inside source static 10.82.16.5 94.XX.XX.195
ip nat inside source static 10.82.16.4 217.XX.XX.163
!
ip prefix-list RTK_in seq 5 permit 0.0.0.0/0
!
!
access-list 116 remark *** mail1 only to STK ***
access-list 116 deny   ip host 10.82.16.4 10.82.0.0 0.0.127.255
access-list 116 permit ip host 10.82.16.4 any
!
access-list 117 remark *** mail2 only to RTK ***
access-list 117 deny   ip host 10.82.16.5 10.82.0.0 0.0.127.255
access-list 117 permit ip host 10.82.16.5 any
!
!
!
route-map mail permit 10
match ip address 116
set ip next-hop 217.XX.XX.161
!
route-map mail permit 20
match ip address 117
set ip next-hop 94.XX.XX.89
!

#sh ip bgp
................
   Network          Next Hop            Metric LocPrf Weight Path
*  0.0.0.0          217.XX.XX.161                         0 15759 i
*>                  94.XX.XX.89             0           100 12389 i
*> 62.68.128.0/19   217.XX.XX.161                         0 15759 34145 i
*> 77.106.64.0/18   217.XX.XX.161                         0 15759 34145 i
итд все городские сети.

теперь вопросы.
1 проблема - при падении канала 1го провайдера - почтовый сервер mail2 не может отправить почту, т.к. его адрес провайдер2 не маршрутизирует.
2 - исходя из проблемы 1 - он не может отправить почту на городские сети провайдера 2 - не имеющие выхода во внешку - он это собственно не наша особо проблема ...
3 - соответственно при падении исп2 - почтовый сервер с этим ИП - не отправит почту никуда через исп1.

теперь для решения данных проблем регистрируем собственную AS и свой диапазон IP адресов.
уже почти готово ...

так вот сейчас надо разобраться на будущее как решить ряд вопросов.
1. во внегородские сети почту слать через ISP1 (дефолт роут)
2. в город - через ISP2 (список сетей получаем от ISP2)

теперь главное -
3. как сделать так, чтобы при поднятом ISP1 - не принимать на себя входящий трафик из "внешки" через ISP2? чтобы весь трафик вне города ходил через ИСП1.
а ИСП2 только внутри города + резерв для внешки.

каким способом можно отрегулировать входящий трафик, используя параметры настроек BGP ?
с исходящим проблем нет собственно.

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Конфигурация почтовых серверов при BGP с двумя разными ISP"  
Сообщение от lumenous (ok) on 15-Дек-08, 10:22 
Скорее всего с помощью препендов.
Роутер выбирая маршрут к вам будет основываться на правиле что чем короче до вас путь, тем лучше маршрут. Расстояние в кол-ве AS. Следовательно, Вы можете анонсировать свои сети с исскуственным увеличением пути за счет добавления своих AS несколько раз.

Что то вроде

address-family ipv4
  neighbor 94.XX.XX.89 activate
  neighbor 94.XX.XX.89 weight 100
  neighbor 94.XX.XX.89 prefix-list RTK_in in
  neighbor 94.XX.XX.89 route-map ISP1-OUT out
  neighbor 217.XX.XX.161 activate
  neighbor 217.XX.XX.161 route-map ISP2-OUT out

route-map ISP1-OUT permit 10
match 100 (это номер акцесс листа, если вам надо по разному анонсировать подсети. Если их у вас несколько)
!
route-map ISP2-OUT permit 10
match 100
set as-path prepend AS AS AS AS (тут номер вашей AS. ставите столько сколько потребуется для уменьшения трафика)

Ну это минимум того что точно необходимо
Соответственно, как то только бжп падает с первым линком, входящий трафик идет по второму.
Думаю, должно быть понятно :)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Конфигурация почтовых серверов при BGP с двумя разными ISP"  
Сообщение от weris email(ok) on 15-Дек-08, 10:25 
>[оверквотинг удален]
>!
>route-map ISP2-OUT permit 10
> match 100
> set as-path prepend AS AS AS AS (тут номер вашей AS.
>ставите столько сколько потребуется для уменьшения трафика)
>
>Ну это минимум того что точно необходимо
>Соответственно, как то только бжп падает с первым линком, входящий трафик идет
>по второму.
>Думаю, должно быть понятно :)

спасибо.
вроде понятно :) будем пробовать на деле.
пока предварительно тонкости БГП почитаем ...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2023 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру