The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"BGP & Routing"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"BGP & Routing"  
Сообщение от colix (ok) on 09-Апр-09, 10:32 
Поднял BGP с провайдером. Для теста получаю от него только пока его сети. Как все наладим отдаст и дефаулт еще. Оборудование у меня стоит Cisco 3560. С самой циски сети провайдера пингуются, а вот с моих сетей почему-то нет.

Конфиг таков:
Код:

!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
!
hostname ***
!
enable secret 5 ***********
!
no aaa new-model
clock timezone UTC 4
system mtu routing 1500
ip subnet-zero
ip routing
no ip domain-lookup
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
interface Loopback0
no ip address
!
interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 333
switchport mode trunk
!
interface FastEthernet0/3
switchport access vlan 333
!
interface FastEthernet0/6
no switchport
ip address 195.88.*.1 255.255.255.0
!
interface Vlan1
no ip address
!
interface Vlan333
ip address 10.10.20.5 255.255.255.252
!
router bgp *
no synchronization
bgp log-neighbor-changes
network 195.88.*.0
network 195.88.*.0
neighbor 91.144.*.* remote-as *
neighbor 91.144.*.* ebgp-multihop 255
no auto-summary
!
ip classless
ip route 91.144.*.* 255.255.255.255 10.10.20.6
no ip http server
!
route-map PREPEND permit 10
set as-path prepend 48986 48986
!
end

К интерфейсу fa0/6 подключен комп с адресом 195.88.*.2, как шлюз указан 195.88.*.1. Вот с него у меня ничего неполучается пропинговать.

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

  • BGP & Routing, _RAW_, 10:37 , 09-Апр-09, (1)  
    • BGP & Routing, colix, 10:43 , 09-Апр-09, (2)  
  • BGP & Routing, lumenous, 11:13 , 09-Апр-09, (3)  
    • BGP & Routing, colix, 11:17 , 09-Апр-09, (4)  
      • BGP & Routing, GolDi, 11:28 , 09-Апр-09, (5)  
        • BGP & Routing, colix, 11:45 , 09-Апр-09, (6)  
          • BGP & Routing, colix, 11:49 , 09-Апр-09, (7)  
          • BGP & Routing, lumenous, 11:49 , 09-Апр-09, (8)  
            • BGP & Routing, colix, 12:01 , 09-Апр-09, (9)  
              • BGP & Routing, colix, 13:22 , 09-Апр-09, (10)  
              • BGP & Routing, lumenous, 13:36 , 09-Апр-09, (11)  
  • BGP & Routing, BJ, 11:19 , 10-Апр-09, (12)  
  • BGP & Routing, Alex, 02:49 , 12-Апр-09, (13)  

Сообщения по теме [Сортировка по времени | RSS]


1. "BGP & Routing"  
Сообщение от _RAW_ (ok) on 09-Апр-09, 10:37 
>interface FastEthernet0/6
> no switchport
> ip address 195.88.*.1 255.255.255.0

а вот тут не надо ли случайн switchport mode access ?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "BGP & Routing"  
Сообщение от colix (ok) on 09-Апр-09, 10:43 
>>interface FastEthernet0/6
>> no switchport
>> ip address 195.88.*.1 255.255.255.0
>
>а вот тут не надо ли случайн switchport mode access ?

хммм. Для чего?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "BGP & Routing"  
Сообщение от lumenous (ok) on 09-Апр-09, 11:13 
>[оверквотинг удален]
>!
>route-map PREPEND permit 10
> set as-path prepend 48986 48986
>!
>end
>
>
>
>К интерфейсу fa0/6 подключен комп с адресом 195.88.*.2, как шлюз указан 195.88.*.1.
>Вот с него у меня ничего неполучается пропинговать.

А провайдер знает о ваших сетях? Вы ему анонсы шлете?
Наберите sh ip bgp neighbor 91.144.*.* advertised-routes
Или если у вашего прова есть looking glass, то сделайте трейс до ваших сетей оттуда.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "BGP & Routing"  
Сообщение от colix (ok) on 09-Апр-09, 11:17 
>А провайдер знает о ваших сетях? Вы ему анонсы шлете?
>Наберите sh ip bgp neighbor 91.144.*.* advertised-routes
>Или если у вашего прова есть looking glass, то сделайте трейс до
>ваших сетей оттуда.

Я свои сети ему аннонсирую, он их видит. looking glass у него нету.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "BGP & Routing"  
Сообщение от GolDi (??) on 09-Апр-09, 11:28 
>>А провайдер знает о ваших сетях? Вы ему анонсы шлете?
>>Наберите sh ip bgp neighbor 91.144.*.* advertised-routes
>>Или если у вашего прова есть looking glass, то сделайте трейс до
>>ваших сетей оттуда.
>
>Я свои сети ему аннонсирую, он их видит. looking glass у него
>нету.

покажите свою таблицу роутинга

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "BGP & Routing"  
Сообщение от colix (ok) on 09-Апр-09, 11:45 

> покажите свою таблицу роутинга

#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     84.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
B       84.201.*.0/21 [20/20] via 91.144.*.77, 18:01:30
B       84.201.*.0/21 [20/20] via 91.144.*.77, 18:01:30
B       84.201.*.0/20 [20/20] via 91.144.*.77, 18:01:30
C    195.88.*.0/24 is directly connected, FastEthernet0/6
     10.0.0.0/30 is subnetted, 1 subnets
C       10.10.2.4 is directly connected, Vlan333
     94.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B       94.180.*.0/20 [20/20] via 91.144.*.77, 18:01:30
B       94.181.*.0/19 [20/20] via 91.144.*.77, 18:01:30
     91.0.0.0/8 is variably subnetted, 5 subnets, 4 masks
S       91.144.*.77/32 [1/0] via 10.60.2.6
B       91.144.*.0/23 [20/20] via 91.144.*.77, 18:01:30
B       91.144.*.0/24 [20/19] via 91.144.*.77, 18:01:30
B       91.144.*.0/23 [20/20] via 91.144.*.77, 18:01:30
B       91.144.*.0/22 [20/20] via 91.144.*.77, 18:01:30
C    192.168.100.0/24 is directly connected, FastEthernet0/5

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "BGP & Routing"  
Сообщение от colix (ok) on 09-Апр-09, 11:49 
Помоему вся проблема в том что источником является 10.10.2.5, т.е. серый ип. Снатить я его несмогу ибо на моем Catalyst нету функции NAT.

Может можно как нибудь сроутить на линуксовую машинку все это?


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "BGP & Routing"  
Сообщение от lumenous (ok) on 09-Апр-09, 11:49 
>[оверквотинг удален]
>S       91.144.*.77/32 [1/0] via 10.60.2.6
>B       91.144.*.0/23 [20/20] via 91.144.*.77, 18:01:30
>
>B       91.144.*.0/24 [20/19] via 91.144.*.77, 18:01:30
>
>B       91.144.*.0/23 [20/20] via 91.144.*.77, 18:01:30
>
>B       91.144.*.0/22 [20/20] via 91.144.*.77, 18:01:30
>
>C    192.168.100.0/24 is directly connected, FastEthernet0/5

Правильно понял, что у вас BGP поднято через подсеть 10.10.2.4/30?
Сделайте трейс и пинг с компьютера до 10.10.2.6 и до 91.144.*.*

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "BGP & Routing"  
Сообщение от colix (ok) on 09-Апр-09, 12:01 

>Правильно понял, что у вас BGP поднято через подсеть 10.10.2.4/30?
>Сделайте трейс и пинг с компьютера до 10.10.2.6 и до 91.144.*.*

Да, правильно.

При трейсе с компьютера:

И при первом и при втором ип. Проходит 195.88.*.1 и далее Превышен интервал.....

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "BGP & Routing"  
Сообщение от colix (ok) on 09-Апр-09, 13:22 
Может все таки циска неправильно сконфигурирована?


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "BGP & Routing"  
Сообщение от lumenous (ok) on 09-Апр-09, 13:36 
>
>>Правильно понял, что у вас BGP поднято через подсеть 10.10.2.4/30?
>>Сделайте трейс и пинг с компьютера до 10.10.2.6 и до 91.144.*.*
>
>Да, правильно.
>
>При трейсе с компьютера:
>
>И при первом и при втором ип. Проходит 195.88.*.1 и далее Превышен
>интервал.....

Странно как то. Даже без бжп вы должны пинговать (если на той стороне вообще открыт пинг) 10.10.2.6 ((
Как вариант, попробуйте через Vlan подключиться. Создать влан с вашей сеткой, и в акцесс на порт ПК.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "BGP & Routing"  
Сообщение от BJ on 10-Апр-09, 11:19 
А на роутере 10.10.20.6 есть маршруты к сети 195.88.*.1 и к сетям провайдера ?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

13. "BGP & Routing"  
Сообщение от Alex (??) on 12-Апр-09, 02:49 
Для сетей что вы анонсируете надо добавить маршруты в null. роутер не анонсит сети на которые у него нет маршрутов

> network 195.88.*.0
> network 195.88.*.0
> ...
>ip route 91.144.*.* 255.255.255.255 10.10.20.6

ip route 195.88.*.0 <маска> Null0

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру