The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Nat на cisco с одним ethernet"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"Nat на cisco с одним ethernet"  +/
Сообщение от bborisbboris email on 03-Июн-09, 07:36 
Встала задача поднять на cisco 2600 нат, но проблема на ней всего один интерфейс ethernet.
почитал
http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tec...
честно говоря не очень понял. сделал по образу и подобию - не работает.
Вот мой конфиг

Current configuration : 2796 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
ip subnet-zero
ip cef
!
frame-relay switching
chat-script CALLOUT "" "atdt\T" TIMEOUT 60 CONNECT \c
modemcap entry usr:AA=s0=0:MSC=&FS0=0&C1&D2&H1&R2&B1&W
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.1.1 255.255.255.252
ip nat inside
Необходим второй интерфейс, только не понятно почему у него адрес левый
!
!
interface FastEthernet0/0
ip address 223.255.255.254 255.255.255.0 secondary # Это серый ip в котором будут хосты из внутренней сети
ip address 194.0.0.1 255.255.255.0  # это внешний ip
ip nat inside
ip policy route-map Nat-loop
duplex auto
speed auto
!

ip nat inside source list 102 interface FastEthernet0/0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 194.0.108.1

no ip http server
!
!
access-list 10 permit 0.0.0.0 255.255.255.0
access-list 102 permit ip 223.255.255.0 0.0.0.255 any
dialer-list 1 protocol ip permit
route-map Nat-loop permit 10
match ip address 102
set ip next-hop 10.0.1.2

Подскажите пожалуйста где грабли

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Nat на cisco с одним ethernet"  +/
Сообщение от sh_ email(ok) on 03-Июн-09, 09:53 
На loopback'е ip nat outside
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Nat на cisco с одним ethernet"  +/
Сообщение от Murzik email(??) on 03-Июн-09, 12:29 
>А почему бы не сделать через VLAN тогда все красиво бы получилось.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Nat на cisco с одним ethernet"  +/
Сообщение от Николай (??) on 03-Июн-09, 14:52 
попробуй тут подправь
interface Loopback0
ip address 10.0.1.1 255.255.255.255
ip nat inside

тут

route-map Nat-loop permit 10
match ip address 102
set ip next-hop 10.0.1.1

тут

interface FastEthernet0/0
ip address 223.255.255.254 255.255.255.0
ip address 194.0.0.1 255.255.255.0  # это внешний ip
ip nat OUTSIDE
ip policy route-map Nat-loop
duplex auto
speed auto

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Nat на cisco с одним ethernet"  +/
Сообщение от bborisbboris email on 10-Июн-09, 14:52 
>[оверквотинг удален]
>interface Loopback0
>ip address 10.0.1.1 255.255.255.255
>ip nat inside
>
>тут
>
>route-map Nat-loop permit 10
>match ip address 102
>set ip next-hop 10.0.1.1
>

циска ругается говорит что
% Warning: Next hop address is our address

но адрес ставит, но при этом на не работает

>тут
>
>interface FastEthernet0/0
>ip address 223.255.255.254 255.255.255.0
>ip address 194.0.0.1 255.255.255.0  # это внешний ip
>ip nat OUTSIDE
>ip policy route-map Nat-loop
>duplex auto
>speed auto

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Nat на cisco с одним ethernet"  +/
Сообщение от Lang on 11-Июн-09, 08:31 
>[оверквотинг удален]
>
>>тут
>>
>>interface FastEthernet0/0
>>ip address 223.255.255.254 255.255.255.0
>>ip address 194.0.0.1 255.255.255.0  # это внешний ip
>>ip nat OUTSIDE
>>ip policy route-map Nat-loop
>>duplex auto
>>speed auto

Вместо
set ip next-hop 10.0.1.1
надо
set interface Loopback0

после этого у меня все заработало

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "Nat на cisco с одним ethernet"  +/
Сообщение от littlevik email on 11-Июн-09, 08:50 
>[оверквотинг удален]
>!
>!
>access-list 10 permit 0.0.0.0 255.255.255.0
>access-list 102 permit ip 223.255.255.0 0.0.0.255 any
>dialer-list 1 protocol ip permit
>route-map Nat-loop permit 10
> match ip address 102
> set ip next-hop 10.0.1.2
>
>Подскажите пожалуйста где грабли

NAT через лупбек + PBR "убьют" Вашу железку на канале > 10Мбит/с.
Делайте через сабинтерфейсы, нужные ВЛАНы разведете управляемым свитчем.

!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 223.255.255.254 255.255.255.0
ip nat inside
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 194.0.0.1 255.255.255.0
ip nat outside
!
ip nat pool NAT 194.0.0.X 194.0.0.Y netmask 255.255.255.Z
ip nat inside source list 102 pool NAT overload
!

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру