Будет только один свитч, все соединено звездой. В принципе все можно обеспечить с помощью private-vlan.Но здесь уже дело принципа, хочется разобраться в чем дело.
Я создал несколько вланов, назначил интерфейсу ip и назначил каждому влану свои порты.
(все вланы тестовые)
далее
ip route 10.10.5.0 255.255.255.0 vlan 6
ip route 192.168.6.0 255.255.255.0 vlan 5
#sh ip route
Gateway of last resort is not set
C 192.169.13.0/24 is directly connected, Vlan13
C 192.169.14.0/24 is directly connected, Vlan14
172.16.0.0/24 is subnetted, 2 subnets
C 172.16.9.0 is directly connected, Vlan9
C 172.16.11.0 is directly connected, Vlan11
172.26.0.0/24 is subnetted, 2 subnets
C 172.26.12.0 is directly connected, Vlan12
C 172.26.10.0 is directly connected, Vlan10
10.0.0.0/24 is subnetted, 3 subnets
C 10.10.5.0 is directly connected, Vlan5
C 10.10.7.0 is directly connected, Vlan7
C 10.100.8.0 is directly connected, Vlan8
C 192.168.6.0/24 is directly connected, Vlan6
C 192.168.0.0/24 is directly connected, Vlan1
#sh run
Building configuration...
Current configuration : 21035 bytes
!
upgrade fpd auto
version 12.2
service timestamps debug uptime
service timestamps log datetime localtime
no service password-encryption
service counters max age 5
!
hostname cisco
!
boot system flash sup-bootdisk:
logging buffered 65536 debugging
enable secret 5 $1$7SjD$Yx7awm/fwNxMEesSWuYbF0
!
no aaa new-model
clock timezone MSK 3
clock summer-time MSK recurring 1 Sun Apr 2:00 last Sun Oct 2:00
vtp mode transparent
ip subnet-zero
!
!
no ip domain-lookup
!
no mls flow ip
no mls acl tcam share-global
mls ip multicast flow-stat-timer 9
mls cef error action freeze
!
!
!
!
!
fabric buffer-reserve queue
diagnostic cns publish cisco.cns.device.diag_results
diagnostic cns subscribe cisco.cns.device.diag_commands
!
redundancy
mode sso
main-cpu
auto-sync running-config
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
vlan access-log ratelimit 2000
!
vlan 3-4
!
vlan 5
name Test5
!
vlan 6
name Test6
!
vlan 7-14
!
!
!
interface Vlan1
ip address 192.168.0.254 255.255.255.0
!
interface Vlan5
ip address 10.10.5.1 255.255.255.0
!
interface Vlan6
ip address 192.168.6.1 255.255.255.0
!
interface Vlan7
ip address 10.10.7.1 255.255.255.0
!
interface Vlan8
ip address 10.100.8.1 255.255.255.0
!
interface Vlan9
ip address 172.16.9.1 255.255.255.0
!
interface Vlan10
ip address 172.26.10.1 255.255.255.0
!
interface Vlan11
ip address 172.16.11.1 255.255.255.0
!
interface Vlan12
ip address 172.26.12.1 255.255.255.0
!
interface Vlan13
ip address 192.169.13.1 255.255.255.0
!
interface Vlan14
ip address 192.169.14.1 255.255.255.0
!
router eigrp 25000
network 192.168.0.0
auto-summary
!
no ip classless
ip route 10.10.5.0 255.255.255.0 Vlan6
ip route 10.10.5.0 255.255.255.0 Vlan1
ip route 10.10.5.0 255.255.255.0 Vlan7
ip route 10.10.5.0 255.255.255.0 Vlan8
ip route 10.10.5.0 255.255.255.0 10.10.5.200
ip route 192.168.0.0 255.255.255.0 Vlan6
ip route 192.168.6.0 255.255.255.0 Vlan1
ip route 192.168.6.0 255.255.255.0 192.168.0.0
ip route 192.168.6.0 255.255.255.0 Vlan6
ip route 192.169.13.0 255.255.255.0 Vlan6
!
ip http server
!
logging trap debugging
logging 192.168.0.240
logging 192.168.0.59
!
!
control-plane
!
!
!
dial-peer cor custom
!
!
!
!
line con 0
password cisco
login
line vty 0 4
password cisco
login
!
exception core-file
no cns aaa enable
end
#sh ip inter
Vlan5 is up, line protocol is up
Internet address is 10.10.5.1/24
Broadcast address is 255.255.255.255
Address determined by setup command
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Local Proxy ARP is disabled
Security level is default
Split horizon is enabled
ICMP redirects are always sent
ICMP unreachables are always sent
ICMP mask replies are never sent
IP fast switching is enabled
IP fast switching on the same interface is disabled
IP Flow switching is disabled
IP CEF switching is enabled
IP Fast switching turbo vector
IP Normal CEF switching turbo vector
IP multicast fast switching is enabled
IP multicast distributed fast switching is disabled
IP route-cache flags are Fast, CEF
Router Discovery is disabled
IP output packet accounting is disabled
IP access violation accounting is disabled
TCP/IP header compression is disabled
RTP/IP header compression is disabled
Probe proxy name replies are disabled
Policy routing is disabled
Network address translation is disabled
WCCP Redirect outbound is disabled
WCCP Redirect inbound is disabled
WCCP Redirect exclude is disabled
BGP Policy Mapping is disabled
Sampled Netflow is disabled
IP multicast multilayer switching is disabled
Vlan6 is up, line protocol is up
Internet address is 192.168.6.1/24
Broadcast address is 255.255.255.255
Address determined by setup command
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Local Proxy ARP is disabled
Security level is default
Split horizon is enabled
ICMP redirects are always sent
ICMP unreachables are always sent
ICMP mask replies are never sent
IP fast switching is enabled
IP fast switching on the same interface is disabled
IP Flow switching is disabled
IP CEF switching is enabled
IP Fast switching turbo vector
IP Normal CEF switching turbo vector
IP multicast fast switching is enabled
IP multicast distributed fast switching is disabled
IP route-cache flags are Fast, CEF
Router Discovery is disabled
IP output packet accounting is disabled
IP access violation accounting is disabled
TCP/IP header compression is disabled
RTP/IP header compression is disabled
Probe proxy name replies are disabled
Policy routing is disabled
Network address translation is disabled
WCCP Redirect outbound is disabled
WCCP Redirect inbound is disabled
WCCP Redirect exclude is disabled
BGP Policy Mapping is disabled
Sampled Netflow is disabled
IP multicast multilayer switching is disabled