The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"BGP/MPLS VPN из приватной в реальную AS"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"BGP/MPLS VPN из приватной в реальную AS"  +/
Сообщение от lucifer email(??) on 10-Июл-09, 14:19 
Есть некая приватная AS1(655xxx) в которой поднят mpls/bgp, маршрутизатор R1 (7604) является роут рефлектором для множества маршуртизаторов Ra, Rb и т.д. внутри этой АС все работает отлично, выход во внешнюю сеть происходит через ASBR (7606) который принадлежит реальной AS2 (4xxxx) и к которому подключены несколько внешних провайдеров.
Недавно возникла задача подключить к VPN (VRF1)находящемуся внутри AS1 клиента находяещегося в другой внешней AS3. BGP между R1 и ASBR по лупбекам не подымается.
BGP по линковым интерфейсам подымается нормально, но дальше начинается  самое интересное,
на всех маршрутизаторах видны маршруты принадлежащие VRF1,
с R2 пингуется ASBR и R1, не пингуются Ra, Rb
с ASBR пингуется R2 и R1, не пингуются Ra, Rb
с R1 пингуется ASBR и R2, Ra, Rb.
Ra, Rb пингуется только R1.

Понимаю что проблема между R1 и ASBR, но пока не нахожу её, а время поджимает...
Буду благодарен за любую помощь.
Вот тут схемка для наглядности: http://pic.ipicture.ru/uploads/090710/UITcGJ4Wdi.jpeg
Конфиги:
#######################   ASBR   #######################  

interface Loopback0
ip address 192.168.199.1 255.255.255.255

interface GigabitEthernet1/2
mtu 9216
no ip address
ip flow ingress
media-type rj45
mpls mtu 1546
mpls ip
no cdp enable
end

interface GigabitEthernet1/2.10
encapsulation dot1Q 10
ip address 192.168.193.174 255.255.255.252
no ip redirects
ip flow ingress
mpls mtu 1546
mpls bgp forwarding
mpls ip
no cdp enable
end

router bgp 4xxxx
no bgp default ipv4-unicast
no bgp default route-target filter
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
neighbor 192.168.193.173 remote-as 655xx

address-family vpnv4
  neighbor 192.168.193.173 activate
  neighbor 192.168.193.173 send-community extended
exit-address-family

address-family ipv4 vrf VRF1
  no synchronization
  redistribute connected
  redistribute static
exit-address-family

ip route 192.168.199.40 255.255.255.255 192.168.193.173

#######################   R1: #########################

interface Loopback0
ip address 192.168.199.40 255.255.255.255

interface GigabitEthernet1/1
mtu 9216
no ip address
media-type rj45
tag-switching mtu 1546
tag-switching ip
no cdp enable
end

interface GigabitEthernet1/1.10
encapsulation dot1Q 10
ip address 192.168.193.173 255.255.255.252
ip access-group Out_Filter out
tag-switching mtu 1546
tag-switching ip
end


router bgp 655xx
no bgp default ipv4-unicast
no bgp default route-target filter
bgp log-neighbor-changes
neighbor iBGP-RR peer-group
neighbor iBGP-RR remote-as 4xxxx
neighbor iBGP-RR update-source Loopback0
neighbor 192.168.199.2 peer-group iBGP-RR
neighbor 192.168.199.3 peer-group iBGP-RR
neighbor 192.168.193.173 remote-as 4xxxx
!
address-family ipv4
redistribute connected
redistribute static
neighbor iBGP-RR activate
neighbor iBGP-RR route-reflector-client
neighbor iBGP-RR send-community both
neighbor iBGP-RR soft-reconfiguration inbound
neighbor 192.168.199.2 peer-group iBGP-RR
neighbor 192.168.199.3 peer-group iBGP-RR
no auto-summary
no synchronization
network 192.168.199.40 mask 255.255.255.255
exit-address-family
!
address-family vpnv4
neighbor iBGP-SO-RR activate
neighbor iBGP-SO-RR route-reflector-client
neighbor iBGP-SO-RR send-community extended
neighbor 192.168.199.2 peer-group iBGP-RR
neighbor 192.168.199.3 peer-group iBGP-RR
neighbor 192.168.193.173 activate
neighbor 192.168.193.173 send-community extended
exit-address-family
!
address-family ipv4 vrf VRF1
redistribute connected
redistribute static
no auto-summary
no synchronization
exit-address-family
!
ip route 192.168.199.1 255.255.255.255 192.168.193.174

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "BGP/MPLS VPN из приватной в реальную AS"  +/
Сообщение от fantom (??) on 10-Июл-09, 14:48 
Ну с лупбеками поднять - наверное ebgp-multihop надо прописать на нейбора.
из AS3 вам mpls-то отдают?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "BGP/MPLS VPN из приватной в реальную AS"  +/
Сообщение от lucifer email(??) on 10-Июл-09, 15:33 
Спасибо, все сразу заработало.
Действительно ebgp-multihop, как-то даже и мысли не было попробовать, ведь ASки ASBR и R1 в прямой видимости...
Единтвенное не пойму почему без мультихопа не работает...
Еще раз спасибо!
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "BGP/MPLS VPN из приватной в реальную AS"  +/
Сообщение от mdenisov email(ok) on 10-Июл-09, 16:26 
>Спасибо, все сразу заработало.
>Действительно ebgp-multihop, как-то даже и мысли не было попробовать, ведь ASки ASBR
>и R1 в прямой видимости...
>Единтвенное не пойму почему без мультихопа не работает...
>Еще раз спасибо!

А не работает потому что TTL.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "BGP/MPLS VPN из приватной в реальную AS"  +/
Сообщение от fantom (??) on 10-Июл-09, 17:21 
>>Спасибо, все сразу заработало.
>>Действительно ebgp-multihop, как-то даже и мысли не было попробовать, ведь ASки ASBR
>>и R1 в прямой видимости...
>>Единтвенное не пойму почему без мультихопа не работает...
>>Еще раз спасибо!
>
>А не работает потому что TTL.

И дока по BGP тоже не помешалабы :)


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "BGP/MPLS VPN из приватной в реальную AS"  +/
Сообщение от lucifer email(??) on 14-Июл-09, 09:21 
>И дока по BGP тоже не помешалабы :)

Хорошо, хорошо :) Почитаем :)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "BGP/MPLS VPN из приватной в реальную AS"  +/
Сообщение от lucifer email(??) on 14-Июл-09, 09:20 
>А не работает потому что TTL.

Ок спс, будем искать.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру