The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"STP между Alcatel Omniswich 6800 и Cisco 2950"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Cisco Catalyst коммутаторы)
Изначальное сообщение [ Отслеживать ]

"STP между Alcatel Omniswich 6800 и Cisco 2950"  +1 +/
Сообщение от tvy (ok) on 30-Янв-10, 16:24 
Как настроить STP между Alcatel Omniswich 6800 и Cisco 2950
c приоритетами для портов?
Например, две Циски и Алкатель включены треугольником.
Главный линк - от Циски 1 до Алкателя и от Алкателя до Циски 2.
Линк от Циски 1 до Циски 2 - резервный.
Читал, что надо использовать реализацию mstp,
т.е. на Цисках:
spanning-tree mode mst
На Алкателях:
bridge mode flat.

Так? Это самый лучший вариант? Или других просто нет?
Сеть маленькая - из трех устройств и двух-трех VLANов.
Между всеми коммутаторами транки dot1q.

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "STP между Alcatel Omniswich 6800 и Cisco 2950"  +/
Сообщение от dae (ok) on 01-Фев-10, 18:34 
>Как настроить STP между Alcatel Omniswich 6800 и Cisco 2950
>c приоритетами для портов?

Мне тоже интересно, что народ посоветует.
Я в такой ситуации порт Циски 1, смотрящий на Циско 2, шатдауню для устранения петли.
При необходимости включаю ручками

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "STP между Alcatel Omniswich 6800 и Cisco 2950"  +/
Сообщение от tvy (??) on 02-Фев-10, 19:13 
>Мне тоже интересно, что народ посоветует.
>Я в такой ситуации порт Циски 1, смотрящий на Циско 2, шатдауню
>для устранения петли.
>При необходимости включаю ручками

Собрал стенд.
На цисках
spanning-tree mode mst
На Алкателе:
bridge mode flat + еще ряд команд (не помню)

Алкатель назначил rootовым бриджем.
Кажется так: spantree priority 4096

Приоритеты настроил со стороны Цисок на портах, смотрящих на рутовый бридж -на Алкатель:
На интерфейсах команду:
spanning-tree cost 4

Вроде все работает (рву один линк связь восстанавливается по другому пути).
Думаю, достаточно или что-то еще надо прописывать.


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "STP между Alcatel Omniswich 6800 и Cisco 2950"  +/
Сообщение от gleb.poljakov email on 02-Фев-10, 19:45 
Господа очень интересно где вы вычитали что рекомендуют MSTP???
Его использовать следует только в больших сетях!

Вообще рекомендуется использовать RSTP, если есть, он гораздо быстрее сходится.
То есть, как минимум на цисках:
# spanning-tree mode rapid
# spanning-tree poftfast default

На портах которые смотрят на другие коммутаторы:
# spanning-tree portfast disable

По весам линков подскажу чуть позже.
По алкателю ничего сказать не могу.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "STP между Alcatel Omniswich 6800 и Cisco 2950"  +/
Сообщение от gleb.poljakov email on 02-Фев-10, 19:51 
Если Алкатель у тебя Root и скорость на всех линках одинаковая, то рваться будет именно линк между цисками.
Так пожалуй правильнее всего будет.

И незабуть проделать что в предыдущем сообщении я написал.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

5. "STP между Alcatel Omniswich 6800 и Cisco 2950"  +/
Сообщение от tvy (??) on 03-Фев-10, 21:02 
>Если Алкатель у тебя Root и скорость на всех линках одинаковая, то
>рваться будет именно линк между цисками.
>Так пожалуй правильнее всего будет.
>
>И незабуть проделать что в предыдущем сообщении я написал.

Спасибо за информацию.
Возможно одиночный rapid Stp (rstp) и будет работать, так как mstp, насколько я понял, основан на Rstp! Надо будет попробовать, если хватит время.

А про mst я вычитал в двух местах:
1. На сайте Dlinkа есть статья как связывать по mst Dlinki и Циски.
Там используется mst.
2. http://praban.wordpress.com/2009/11/04/konfigurasi-mstp/
тут такой пример:
Switch  Cisco Catalyst (IOS)
    spanning-tree mode mstp
    spanning-tree pathcost method long

    spanning-tree mst configuration
    instance 1 vlan 10
    instance 2 vlan 11
    instance 3 vlan 12
    name example
    revision 1
    exit

    Switch Alcatel-Lucent (AOS)
    bridge mode flat
    bridge path cost mode 32bit
    bridge cist protocol mstp
    bridge mst region name example
    bridge mst region revision level 1

    bridge msti 1
    bridge msti 1 vlan 10
    bridge msti 2
    bridge msti 2 vlan 11
    bridge msti 3
    bridge msti 3 vlan 12    

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

6. "STP между Alcatel Omniswich 6800 и Cisco 2950"  +/
Сообщение от gleb.poljakov email on 03-Фев-10, 22:24 
Зачем вам извращения с MST?

MSTP - Multiple STP.

Главным образом отличается от RSTP/STP, тем что виланы распределяются по инстансам и уже на уровне инстансов рубится петля.

Правильные парни MSTP настраивают только когда очень надо, т.е. оч много виланов и оч много свичей.

В вашем случае:
#spanning-tree mode rapid
#spanning-tree portfast default

и не нужно марочить себе голову.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

7. "STP между Alcatel Omniswich 6800 и Cisco 2950"  +/
Сообщение от tvy (??) on 05-Фев-10, 14:28 
>Зачем вам извращения с MST?
>
>MSTP - Multiple STP.
>В вашем случае:
>#spanning-tree mode rapid
>#spanning-tree portfast default

Попробовал сходу, не работает.
Циски не признают Alcatel корневым свичом, хотя на нем стоит приоритет.

Т.е. хорошо бы конфигурацию Alcatelя.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

8. "STP между Alcatel Omniswich 6800 и Cisco 2950"  +/
Сообщение от gleb.poljakov email on 05-Фев-10, 14:51 
Сделай на обоих каталистах:

#show spanning-tree summary
#show spanning-tree detail

И вывод покажи.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

9. "STP между Alcatel Omniswich 6800 и Cisco 2950"  +/
Сообщение от tvy (??) on 17-Фев-10, 20:49 
>Сделай на обоих каталистах:
>
> #show spanning-tree summary
> #show spanning-tree detail
>
>И вывод покажи.

Пробовал ставить rapid-pvst на Цисках, на Алкателе
bridge cist protocol rstp
bridge cist priority 8192
Пробовал и режим bridge mode 1X1

Не работает, Циска 2950 не признает Алкатель рутовым коммутатором.
Может конечно, что не так делал.

Работает в следующих конфигурациях:
1. Прекрасно работает чистый mst, если Циски 2960. Конфигурации просты.
А вот mst Цискb 2950 c Алкателем не работает. Говорят, что mstp на Циске 2950 реализован еще как pre-standart (а на Циске 2960 уже как стандартный IEEE).

2. Но на Циске 2950 работает RSTP, который лежит в основе mst, если ставить именно mst!
Устройства соединены треугольником:
Алкатель 10 порт- Циска 2950-10 порт
Алкатель 20 порт- Циска 2960-10 порт
Циска 2950-20 порт- Циска 2950-20 порт
Конфигурации такие:
! Spanning tree :
bridge mode flat
bridge path cost mode 32bit
bridge 1 protocol RSTP
bridge 1 priority 8192 (корневой коммутатор)

Циска 2950:
spanning-tree mode mst
no spanning-tree optimize bpdu transmission (специально не ставил, сама появилась)
spanning-tree extend system-id
spanning-tree pathcost method long
!
spanning-tree mst configuration
revision 1 (чтобы между Цисками не работал mst, а работал RSTP)
!
interface FastEthernet0/10
switchport trunk allowed vlan 4,5
switchport mode trunk
spanning-tree cost 16 (рутовый порт в сторону Алкателя)

На Циске 2960:
!
spanning-tree mode mst
spanning-tree extend system-id
spanning-tree pathcost method long
!
interface FastEthernet0/10
switchport trunk allowed vlan 4,5
switchport mode trunk
spanning-tree cost 16 (рутовый порт в сторону Алкателя)

Так как конфигурации mst на цисках не совпадают, то mst не работает.
А работает RSTP.
Блокируется линк между Цисками.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

10. "STP между Alcatel Omniswich 6800 и Cisco 2950"  +/
Сообщение от gleb.poljakov email on 17-Фев-10, 21:31 
как насчет всетаки настроить на коммутаторах RSTP и показать вывод следующих команд:
#sho span summary
#sho span

так хотябы поймем что у тебя с RSTP нетак...

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру