The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Связать Cisco 1841 и два Catalyst 2960 последовательно"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Cisco Catalyst коммутаторы)
Изначальное сообщение [ Отслеживать ]

"Связать Cisco 1841 и два Catalyst 2960 последовательно"  +/
Сообщение от KudriK_TF email(ok) on 04-Фев-10, 10:09 
Доброго утра добрые люди, проблема такая есть вот такая схема, подскажите кто может
>[оверквотинг удален]
>       |
>       |
>       |fa 0/1
>  catalyst 2960---юзвери
>       |gig 0/1
>       |
>       |
>       |gig 0/1
>  catalyst 2960----юзвери
>                

народ подскажите как эту схемку реализовать, я делаю так - на 1841 поднимаю dhcp и nat (от провайдера по adsl приходит) отправляю на внутренний порт fa 0/0, на первом 2960 на порту fa 0/1 поднимаю ip dhcp client route track 1, а остальные порты пусть работают просто включенными или как лучше сделать? теперь на втором 2960 на порту gig 0/1 мне как и на первом dhcp открыть или все намного сложнее:ip dhcp client route track 1. Помогите пожалуйста

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Связать Cisco 1841 и два Catalyst 2960 последовательно"  +/
Сообщение от gleb.poljakov email on 04-Фев-10, 10:51 
https://www.opennet.ru/openforum/vsluhforumID6/20443.html

поиск - наше все!

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "Связать Cisco 1841 и два Catalyst 2960 последовательно"  +/
Сообщение от KudriK_TF email(ok) on 04-Фев-10, 11:13 
>https://www.opennet.ru/openforum/vsluhforumID6/20443.html
>
>поиск - наше все!

пасибо, выручил.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "Связать Cisco 1841 и два Catalyst 2960 последовательно"  +/
Сообщение от gleb.poljakov email on 04-Фев-10, 11:43 
>>https://www.opennet.ru/openforum/vsluhforumID6/20443.html
>>
>>поиск - наше все!
>
>пасибо, выручил.

Хорошо, понял свою ошибку :)))

переводишь порты gig 0/1 в транковый режим и все.

#conf t
#int gig 0/1
# switchport mode trunk
# no shutdown
#end
# write

остальные где пользователи сидят а аксес-вилан:
#conf t
#int range fa0/1 - 24
# switchport mode access
# switchport access vlan 123
# no shutdown
#end
# write

где пользователей нет или в shutdown или в вилан немаршрутизируемый.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

5. "Связать Cisco 1841 и два Catalyst 2960 последовательно"  +/
Сообщение от KudriK_TF email(ok) on 04-Фев-10, 11:47 

>[оверквотинг удален]
>остальные где пользователи сидят а аксес-вилан:
>#conf t
>#int range fa0/1 - 24
># switchport mode access
># switchport access vlan 123
># no shutdown
>#end
># write
>
>где пользователей нет или в shutdown или в вилан немаршрутизируемый.

)))спасибо, все работает)))

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

9. "Связать Cisco 1841 и два Catalyst 2960 последовательно"  +/
Сообщение от KudriK_TF email(ok) on 04-Фев-10, 12:31 
>[оверквотинг удален]
>>#int range fa0/1 - 24
>># switchport mode access
>># switchport access vlan 123
>># no shutdown
>>#end
>># write
>>
>>где пользователей нет или в shutdown или в вилан немаршрутизируемый.
>
>)))спасибо, все работает)))

а если на первом catalyst будет vlan 1, а на втором vlan 2, все же работать то будет??

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

10. "Связать Cisco 1841 и два Catalyst 2960 последовательно"  +/
Сообщение от gleb.poljakov email on 04-Фев-10, 12:43 
>[оверквотинг удален]
>>># no shutdown
>>>#end
>>># write
>>>
>>>где пользователей нет или в shutdown или в вилан немаршрутизируемый.
>>
>>)))спасибо, все работает)))
>
>а если на первом catalyst будет vlan 1, а на втором vlan
>2, все же работать то будет??

конечно!

только для этого нужно:
1. чтобы сабинтерфейсы под эти виланы были на 1841
2. на сабах были айпи-адреса, есесно в разных подсетях (#show ip int br)
3. в транках были разрешены эти виланы. (покажи #show int trunk)


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

11. "Связать Cisco 1841 и два Catalyst 2960 последовательно"  +/
Сообщение от KudriK_TF email(ok) on 04-Фев-10, 12:57 
>[оверквотинг удален]
>>а если на первом catalyst будет vlan 1, а на втором vlan
>>2, все же работать то будет??
>
>конечно!
>
>только для этого нужно:
>1. чтобы сабинтерфейсы под эти виланы были на 1841
>2. на сабах были айпи-адреса, есесно в разных подсетях (#show ip int
>br)
>3. в транках были разрешены эти виланы. (покажи #show int trunk)

ща пропишу, спасибо

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

12. "Связать Cisco 1841 и два Catalyst 2960 последовательно"  +/
Сообщение от KudriK_TF email(ok) on 05-Фев-10, 08:45 
>только для этого нужно:
>1. чтобы сабинтерфейсы под эти виланы были на 1841
>2. на сабах были айпи-адреса, есесно в разных подсетях (#show ip int
>br)
>3. в транках были разрешены эти виланы. (покажи #show int trunk)

Привет, слушай, надобность в vlan 2 отпала, просто тут схему проектировщики переделывают находу, вот у меня есть два каталиста, соединенные по транкам, оба должны быть в vlan 1, ты мне подсказал и я прописываю так:

первый 2960:

#conf t
#int gig 0/1
# switchport mode trunk
# no shutdown
#end

#conf t
#int range fa0/1 - 24
# switchport mode access
# switchport access vlan 1
# no shutdown
#end

и чтобы задать каталисту ip я делал так:
#conf t
#int vlan 1
#ip addr 172.16.0.2 255.255.255.128
# no shutdown
#end

второй 2960:
#conf t
#int gig 0/1
# switchport mode trunk
# no shutdown
#end

#conf t
#int range fa0/1 - 24
# switchport mode access
# switchport access vlan 1
# no shutdown
#end

и чтобы задать каталисту ip я делал так:
#conf t
#int vlan 1
#ip addr 172.16.0.3 255.255.255.128
# no shutdown
#end

и теперь у меня пинг идет, инет на компах врубленных во второй каталист даже есть, вот токо пропинговать я могу только роутер и первый каталист, а второй молчит зараза, я наверное где то тупанул, вот токо где?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

13. "Связать Cisco 1841 и два Catalyst 2960 последовательно"  +/
Сообщение от gleb.poljakov email on 05-Фев-10, 10:50 
Покажи "#show int status" с обоих каталистах.
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

14. "Связать Cisco 1841 и два Catalyst 2960 последовательно"  +/
Сообщение от KudriK_TF email(ok) on 08-Фев-10, 07:21 
>Покажи "#show int status" с обоих каталистах.

извини, выходные, не мог пробиться на работу, сейчас покажу с обоих:

первый каталист:
Switch#sh int status

Port      Name               Status       Vlan       Duplex  Speed Type
Fa0/1                        connected    1          a-full  a-100 10/100BaseTX
Fa0/2                        notconnect   1            auto   auto 10/100BaseTX
Fa0/3                        notconnect   1            auto   auto 10/100BaseTX
Fa0/4                        notconnect   1            auto   auto 10/100BaseTX
Fa0/5                        notconnect   1            auto   auto 10/100BaseTX
Fa0/6                        notconnect   1            auto   auto 10/100BaseTX
Fa0/7                        notconnect   1            auto   auto 10/100BaseTX
Fa0/8                        notconnect   1            auto   auto 10/100BaseTX
Fa0/9                        notconnect   1            auto   auto 10/100BaseTX
Fa0/10                       notconnect   1            auto   auto 10/100BaseTX
Fa0/11                       notconnect   1            auto   auto 10/100BaseTX
Fa0/12                       notconnect   1            auto   auto 10/100BaseTX
Fa0/13                       notconnect   1            auto   auto 10/100BaseTX
Fa0/14                       notconnect   1            auto   auto 10/100BaseTX
Fa0/15                       notconnect   1            auto   auto 10/100BaseTX
Fa0/16                       connected    1          a-full  a-100 10/100BaseTX
Fa0/17                       notconnect   1            auto   auto 10/100BaseTX
Fa0/18                       notconnect   1            auto   auto 10/100BaseTX
Fa0/19                       notconnect   1            auto   auto 10/100BaseTX
Fa0/20                       notconnect   1            auto   auto 10/100BaseTX
Fa0/21                       notconnect   1            auto   auto 10/100BaseTX
Fa0/22                       notconnect   1            auto   auto 10/100BaseTX

Port      Name               Status       Vlan       Duplex  Speed Type
Fa0/23                       notconnect   1            auto   auto 10/100BaseTX
Fa0/24                       notconnect   1            auto   auto 10/100BaseTX
Gi0/1                        connected    trunk      a-full a-1000 10/100/1000Ba
seTX
Gi0/2                        notconnect   1            auto   auto Not Present
Switch#

второй каталист:
Switch#sh int status                    

Port      Name               Status       Vlan       Duplex  Speed Type                                                                      
Fa0/1                        notconnect   1            auto   auto 10/100BaseTX                                                                              
Fa0/2                        notconnect   1            auto   auto 10/100BaseTX                                                                              
Fa0/3                        notconnect   1            auto   auto 10/100BaseTX                                                                              
Fa0/4                        notconnect   1            auto   auto 10/100BaseTX                                                                              
Fa0/5                        notconnect   1            auto   auto 10/100BaseTX                                                                              
Fa0/6                        notconnect   1            auto   auto 10/100BaseTX
Fa0/7                        notconnect   1            auto   auto 10/100BaseTX
Fa0/8                        notconnect   1            auto   auto 10/100BaseTX
Fa0/9                        notconnect   1            auto   auto 10/100BaseTX
Fa0/10                       notconnect   1            auto   auto 10/100BaseTX
Fa0/11                       notconnect   1            auto   auto 10/100BaseTX
Fa0/12                       notconnect   1            auto   auto 10/100BaseTX
Fa0/13                       notconnect   1            auto   auto 10/100BaseTX
Fa0/14                       notconnect   1            auto   auto 10/100BaseTX
Fa0/15                       notconnect   1            auto   auto 10/100BaseTX
Fa0/16                       notconnect   1            auto   auto 10/100BaseTX
Fa0/17                       notconnect   1            auto   auto 10/100BaseTX
Fa0/18                       notconnect   1            auto   auto 10/100BaseTX
Fa0/19                       notconnect   1            auto   auto 10/100BaseTX
Fa0/20                       notconnect   1            auto   auto 10/100BaseTX
Fa0/21                       notconnect   1            auto   auto 10/100BaseTX

Port      Name               Status       Vlan       Duplex  Speed Type
Fa0/22                       notconnect   1            auto   auto 10/100BaseTX
Fa0/23                       notconnect   1            auto   auto 10/100BaseTX
Fa0/24                       notconnect   1            auto   auto 10/100BaseTX
Gi0/1                        connected    trunk      a-full a-1000 10/100/1000Ba
seTX
Gi0/2                        notconnect   1            auto   auto Not Present
Switch#

я только не очень понимаю как это поможет)

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

15. "Связать Cisco 1841 и два Catalyst 2960 последовательно"  +/
Сообщение от KudriK_TF email(ok) on 08-Фев-10, 07:25 
>>Покажи "#show int status" с обоих каталистах.

это если на первом каталисте сидит юзер, а если на воткнем юзера во второй, то у нас получится, второй каталист:

Switch#sh int status                    

Port      Name               Status       Vlan       Duplex  Speed Type                                                                      
Fa0/1                        notconnect   1            auto   auto 10/100BaseTX                                                                              
Fa0/2                        notconnect   1            auto   auto 10/100BaseTX                                                                              
Fa0/3                        notconnect   1            auto   auto 10/100BaseTX                                                                              
Fa0/4                        notconnect   1            auto   auto 10/100BaseTX                                                                              
Fa0/5                        notconnect   1            auto   auto 10/100BaseTX                                                                              
Fa0/6                        notconnect   1            auto   auto 10/100BaseTX
Fa0/7                        notconnect   1            auto   auto 10/100BaseTX
Fa0/8                        connected    1          a-full  a-100 10/100BaseTX
Fa0/9                        notconnect   1            auto   auto 10/100BaseTX
Fa0/10                       notconnect   1            auto   auto 10/100BaseTX
Fa0/11                       notconnect   1            auto   auto 10/100BaseTX
Fa0/12                       notconnect   1            auto   auto 10/100BaseTX
Fa0/13                       notconnect   1            auto   auto 10/100BaseTX
Fa0/14                       notconnect   1            auto   auto 10/100BaseTX
Fa0/15                       notconnect   1            auto   auto 10/100BaseTX
Fa0/16                       notconnect   1            auto   auto 10/100BaseTX
Fa0/17                       notconnect   1            auto   auto 10/100BaseTX
Fa0/18                       notconnect   1            auto   auto 10/100BaseTX
Fa0/19                       notconnect   1            auto   auto 10/100BaseTX
Fa0/20                       notconnect   1            auto   auto 10/100BaseTX
Fa0/21                       notconnect   1            auto   auto 10/100BaseTX

Port      Name               Status       Vlan       Duplex  Speed Type
Fa0/22                       notconnect   1            auto   auto 10/100BaseTX
Fa0/23                       notconnect   1            auto   auto 10/100BaseTX
Fa0/24                       notconnect   1            auto   auto 10/100BaseTX
Gi0/1                        connected    trunk      a-full a-1000 10/100/1000Ba
seTX
Gi0/2                        notconnect   1            auto   auto Not Present
Switch#


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

17. "Связать Cisco 1841 и два Catalyst 2960 последовательно"  +/
Сообщение от gleb.poljakov email on 08-Фев-10, 07:40 
еще сделай аналогично:

#show int trunk
#show cdp neib

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

18. "Связать Cisco 1841 и два Catalyst 2960 последовательно"  +/
Сообщение от gleb.poljakov email on 08-Фев-10, 07:42 
и еще:

#show run int vla 1

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

19. "Связать Cisco 1841 и два Catalyst 2960 последовательно"  +/
Сообщение от KudriK_TF email(ok) on 08-Фев-10, 09:00 
>и еще:
>
>#show run int vla 1

с первого:
Switch#sh int tru
Switch#sh int trunk

Port        Mode             Encapsulation  Status        Native vlan
Gi0/1       on               802.1q         trunking      1

Port        Vlans allowed on trunk
Gi0/1       1-4094

Port        Vlans allowed and active in management domain
Gi0/1       1

Port        Vlans in spanning tree forwarding state and not pruned
Gi0/1       1
Switch#sh cd

Switch#sh cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Router           Fas 0/1           170          R S I     1841      Fas 0/0
Switch           Gig 0/1           172           S I      WS-C2960- Gig 0/1
Switch#sh run int vla 1
Building configuration...

Current configuration : 81 bytes
!
interface Vlan1
ip address 172.16.0.2 255.255.255.128
no ip route-cache
end

со второго

Switch#sh run int vla 1
Building configuration...

Current configuration : 91 bytes
!
interface Vlan1
ip address 172.16.0.3 255.255.255.128
no ip route-cache
shutdown

Switch#sh int tru

Port        Mode             Encapsulation  Status        Native vlan
Gi0/1       on               802.1q         trunking      1

Port        Vlans allowed on trunk
Gi0/1       1-4094

Port        Vlans allowed and active in management domain
Gi0/1       1-2

Port        Vlans in spanning tree forwarding state and not pruned
Gi0/1       1-2
Switch#

Switch#sh cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Switch           Gig 0/1           135           S I      WS-C2960- Gig 0/1
вот, то что просил
end

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

22. "Связать Cisco 1841 и два Catalyst 2960 последовательно"  +/
Сообщение от gleb.poljakov email on 08-Фев-10, 09:10 
interface Vlan1
ip address 172.16.0.3 255.255.255.128
no ip route-cache
shutdown

у тебя интерфейс-вилан на втором коммутаторе выключен.

сделай на втором комутаторе:
#conf t
#int vlan 1
#no shutdown

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

25. "Связать Cisco 1841 и два Catalyst 2960 последовательно"  +/
Сообщение от KudriK_TF email(ok) on 08-Фев-10, 11:22 
>[оверквотинг удален]
>ip address 172.16.0.3 255.255.255.128
>no ip route-cache
>shutdown
>
>у тебя интерфейс-вилан на втором коммутаторе выключен.
>
>сделай на втором комутаторе:
>#conf t
>#int vlan 1
>#no shutdown

ой я и баклан, блин, ну конешно, спасибо огроменное, извини что отвлекаю.
еще раз спасибо

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

23. "Связать Cisco 1841 и два Catalyst 2960 последовательно"  +/
Сообщение от KudriK_TF email(ok) on 08-Фев-10, 09:11 
>еще сделай аналогично:
>
>#show int trunk
>#show cdp neib

sh cdp neib - такой нету
Switch#sh cdp ?
  entry      Information for specific neighbor entry
  interface  CDP interface status and configuration
  neighbors  CDP neighbor entries
  traffic    CDP statistics
  |          Output modifiers
  <cr>
это я туплю, или опечатка??

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

24. "Связать Cisco 1841 и два Catalyst 2960 последовательно"  +/
Сообщение от gleb.poljakov email on 08-Фев-10, 09:40 
>[оверквотинг удален]
>Switch#sh cdp ?
>  entry      Information for specific neighbor
>entry
>  interface  CDP interface status and configuration
>  neighbors  CDP neighbor entries
>  traffic    CDP statistics
>  |          
>Output modifiers
>  <cr>
>это я туплю, или опечатка??

это я ступил :) я имел ввиду neighbors

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

16. "Связать Cisco 1841 и два Catalyst 2960 последовательно"  +/
Сообщение от KudriK_TF email(ok) on 08-Фев-10, 07:40 
>Покажи "#show int status" с обоих каталистах.

слушай, я тут книжку прочитал,и по ней ввел в конфиг 1841 второй ip на порт fa 0/0:
Router(config-if)# ip address 172.16.0.3 255.255.255.128 secondary
172.16.0.3 - ip второго каталиста,
все заработало - теперь и инет есть и я его пропинговать могу и по telnet зайти, так правильно или нет??

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

20. "Связать Cisco 1841 и два Catalyst 2960 последовательно"  +/
Сообщение от KudriK_TF email(ok) on 08-Фев-10, 09:01 
>>Покажи "#show int status" с обоих каталистах.
>
>слушай, я тут книжку прочитал,и по ней ввел в конфиг 1841 второй
>ip на порт fa 0/0:
>Router(config-if)# ip address 172.16.0.3 255.255.255.128 secondary
>172.16.0.3 - ip второго каталиста,
>все заработало - теперь и инет есть и я его пропинговать могу
>и по telnet зайти, так правильно или нет??

сорри затупил, я роутер пинговал а не свичь

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

21. "Связать Cisco 1841 и два Catalyst 2960 последовательно"  +/
Сообщение от gleb.poljakov email on 08-Фев-10, 09:08 
# ip address 172.16.0.3 255.255.255.128 secondary

Зачем тут "secondary"? :)

покажи на роутере:
#sho run int fa0/0

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "Связать Cisco 1841 и два Catalyst 2960 последовательно"  +/
Сообщение от gleb.poljakov email on 04-Фев-10, 11:45 
#ip dhcp client route track 1

для чего у тебя?

DHCP без этого не будет работать???

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

6. "Связать Cisco 1841 и два Catalyst 2960 последовательно"  +/
Сообщение от KudriK_TF email(ok) on 04-Фев-10, 11:49 
>#ip dhcp client route track 1
>
>для чего у тебя?
>
>DHCP без этого не будет работать???

я тут паралельно книжку читаю по коммутаторам cisco, там это прописывалось для dhcp

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

7. "Связать Cisco 1841 и два Catalyst 2960 последовательно"  +/
Сообщение от KudriK_TF email(ok) on 04-Фев-10, 11:49 
>#ip dhcp client route track 1
>
>для чего у тебя?
>
>DHCP без этого не будет работать???

щас попробую убрать, поглядим

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

8. "Связать Cisco 1841 и два Catalyst 2960 последовательно"  +/
Сообщение от KudriK_TF email(ok) on 04-Фев-10, 11:55 
>#ip dhcp client route track 1
>
>для чего у тебя?
>
>DHCP без этого не будет работать???

да, все нормально, убрал, и без него работает прекрасно, спасибо, я еще эту строку в самом начале вбил, думал так будет прально..)))
с ней в принципе тоже работало))
спасибо за помощь!!!

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру