The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"как связать коммутаторы Cisco Catalyst 3750 в стек"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Cisco Catalyst коммутаторы)
Изначальное сообщение [ Отслеживать ]

"как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от KudriK_TF email(ok) on 01-Мрт-10, 10:03 
Привет народ, такой вопрос, никогда не связывал коммутаторы в стек, просто подключить кабелем в стековые порты или еще необходима какая то настройка на коммутаторах, определение какой из них главнее, или после соединения они сразу будут понимать что они одно устройство и нам необходимо настроить только один??
Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от blank (ok) on 01-Мрт-10, 10:09 
>Привет народ, такой вопрос, никогда не связывал коммутаторы в стек, просто подключить
>кабелем в стековые порты или еще необходима какая то настройка на
>коммутаторах, определение какой из них главнее, или после соединения они сразу
>будут понимать что они одно устройство и нам необходимо настроить только
>один??

просто соединить кабелем, иосы должны быть одинаковые.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от KudriK_TF email(ok) on 01-Мрт-10, 10:20 
>
>просто соединить кабелем, иосы должны быть одинаковые.

спасибо,а в ios задаем все идентичное, например там ip vlan 1, а порты как определять и загонять в vlan там будет идти если на каждом по 24 порта: 0/1-24, 1/1-24 или 0/1-48

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от blank (ok) on 01-Мрт-10, 10:56 
>>
>>просто соединить кабелем, иосы должны быть одинаковые.
>
>спасибо,а в ios задаем все идентичное, например там ip vlan 1, а
>порты как определять и загонять в vlan там будет идти если
>на каждом по 24 порта: 0/1-24, 1/1-24 или 0/1-48

1/0/1-24, 2/0/1-24

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

5. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от KudriK_TF email(ok) on 01-Мрт-10, 17:01 

>
> 1/0/1-24, 2/0/1-24

спасибо большое, с этим уже разобрался)

теперь проблема вот в чем, надо создать три vlan:
vlan 1 - группа общая
vlan 2 - группа студенты
vlan 3 - группа админ

как делать влан и присваивать интерфейсам я сделал, а как сделать так чтобы vlan 3 мог заходить на vlan 1 и 2, но его чтобы не видели. и еще вопрос, надо ли для этого делать транковые порты или транки только для передачи трафика о вланах другим устройствам?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от VMcS (ok) on 01-Мрт-10, 15:03 
Есть некоторые нюансы.

В существующем стеке желательно задать максимальный приоритет master'а, а в новом свитче - минимальный, чтобы избежать ситуации, когда новый свитч станет мастером и перезапишет свой пустой конфиг на прочие свитчи в стеке.
Так же следует четко задать номер свитча в стеке, иначе может смениться нумерация портов по всему стеку, со всеми вытекающими последствиями.

Теоретически новый свитч не обязательно должен иметь идентичную версию IOS c свитчами в стеке (IOS должен синхронизироваться автоматически или его можно синхронизировать вручную), но _практически_ лучше избегать таких процедур и предварительно установить вручную идентичную версию IOS до установки свитча в стек (проблемы с автоматичекой синхронизацией часто возникают если на новом свитче стоит более свежий IOS, а особенно - если различаются featur pack'и).

Ну и последнее. Замыкайте шину между свитчами в стеке в полное кольцо, например 1-2,2-3,3-4,4-1, иначе при выходе из строя свитча в середине, будут потеряны все свитчи за ним.


Читайте здесь: http://www.cisco.com/en/US/products/hw/switches/ps5023/produ...

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

6. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от KudriK_TF email(ok) on 01-Мрт-10, 17:02 
>[оверквотинг удален]
>версию IOS до установки свитча в стек (проблемы с автоматичекой синхронизацией
>часто возникают если на новом свитче стоит более свежий IOS, а
>особенно - если различаются featur pack'и).
>
>Ну и последнее. Замыкайте шину между свитчами в стеке в полное кольцо,
>например 1-2,2-3,3-4,4-1, иначе при выходе из строя свитча в середине, будут
>потеряны все свитчи за ним.
>
>
>Читайте здесь: http://www.cisco.com/en/US/products/hw/switches/ps5023/produ...

спасибо, щас почитаю, а можете подсказать на счет вланов, я выше написал.пожалуйста

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

7. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от KudriK_TF email(ok) on 01-Мрт-10, 17:33 
теперь проблема вот в чем, надо создать три vlan:
vlan 1 - группа общая
vlan 2 - группа студенты
vlan 3 - группа админ

конфиг я задавал вот такой.

int vlan 1
ip addre 192.168.1.250
no shut

int vlan 2
no shut

int vlan 3
no shut

vlan 1
name work
vlan 2
name studclass
vlan 3
name admin

int range fa 2/0/1-48
sw mode acc
sw acc vlan 1

int range fa 1/0/1-12
sw mode acc
sw acc vlan 2

int range fa 1/0/14-24
sw mode acc
sw acc vlan 3

int gig 1/0/1
sw mode trunk
sw trunk enc dot1q
sw trunk allo vlan all

int fa 1/0/13
sw mode trunk
sw trunk enc dot1q
sw trunk allo vlan all
при этой конфигурации я никак не мог пропинговать мой свичь из vlan 2 и vlan 3, но если включал комп в vlan 1, то пинги проходили. но это в принципе и понятно, ведь только там задан ip addre, но я не могу понять почему я не могу подключившись к fa 1/0/13, пропинговать любой комп из vlan 2 и vlan 3, а только vlan 1, хотя свичь уже пингуется.
люди, помогите пожалуйста, что делать?
надо было включать ip routing?
и имеет значение команда native?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

8. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от Gbyte email(ok) on 01-Мрт-10, 19:27 
>надо было включать ip routing?

Именно!
Как ты можешь что-нить пинговать из сети из которой нет выхода - нет гейта...
Нужно указать ип-адреса на виланах и включить роутинг.

>и имеет значение команда native?

Имеет. натив тот который не тегируется.

Прочти ICND1,2 - многое прояснит.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

9. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от KudriK_TF email(ok) on 01-Мрт-10, 19:34 
>[оверквотинг удален]
>Именно!
>Как ты можешь что-нить пинговать из сети из которой нет выхода -
>нет гейта...
>Нужно указать ип-адреса на виланах и включить роутинг.
>
>>и имеет значение команда native?
>
>Имеет. натив тот который не тегируется.
>
>Прочти ICND1,2 - многое прояснит.

пасибо, как раз начал ее читать, становиться по маленьку все понятней и понятней

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

11. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от KudriK_TF email(ok) on 01-Мрт-10, 20:44 
еще один вопрос можно, а то я не успею за ночь книгу прочитать), я тут конфиг написал, схема такая:

>[оверквотинг удален]
>    |
>    |gig 1/0/2
>  switch1 (stek) - vlan 2 fa 2/0/1-48
>    |          \
> gig 1/0/2   \ vlan 3 fa 2/0/1-12
>    |       \ vlan 4 fa 2/0/13-24
>    |        vlan 5
>    |
>    |
>  switch2 - vlan 5 fa 0/1-24    

стековый свичь:
switch1(config)# vlan 2
switch1(config-vlan)# name work

switch1(config)# vlan 3
switch1(config-vlan)# name stud

switch1(config)# vlan 4
switch1(config-vlan)# name admin

switch1(config)# vlan 5
switch1(config-vlan)# name buh

switch1(config)# interface range fa 2/0/1-48
switch1(config-if-range)# switchport mode access
switch1(config-if-range)# switchport access vlan 2

switch1(config)# interface range fa 2/0/1-12
switch1(config-if-range)# switchport mode access
switch1(config-if-range)# switchport access vlan 3

switch1(config)# interface range fa 2/0/13-24
switch1(config-if-range)# switchport mode access
switch1(config-if-range)# switchport access vlan 4

идет на switch 2
switch1(config)# interface gig 1/0/1
switch1(config-if)# switchport encapsulation dot1q
switch1(config-if)# switchport mode trunk
switch1(config-if)# switchport trunk native vlan 4
switch1(config-if)# switchport trunk allowed vlan 4,5

идет на router
switch1(config)#interface gig 1/0/2
switch1(config-if)# switchport encapsulation dot1q
switch1(config-if)# switchport mode trunk
switch1(config-if)# switchport trunk native vlan 4
switch1(config-if)# switchport trunk allowed vlan all

switch1(config)# ip routing

switch1(config)#interface Vlan 2
switch1(config-if)#ip address 192.168.1.248 255.255.255.0
switch1(config-if)#no shutdown

switch1(config)#interface Vlan 3
switch1(config-if)#ip address 192.168.1.249 255.255.255.0
switch1(config-if)#no shutdown

switch1(config)#interface Vlan 4
switch1(config-if)#ip address 192.168.1.250 255.255.255.0
switch1(config-if)#no shutdown

switch1(config)#interface gig 1/0/2
switch1(config-if)#no switchport
switch1(config-if)#ip address 192.168.1.2 255.255.255.0 - идет на роутер
switch1(config-if)#no shutdown

switch1(config)# ip route 0.0.0.0 0.0.0.0 192.168.1.1 - ip адрес роутера

свичь 2

switch2(config)# vlan 4
switch2(config-vlan)# name admin

switch2(config)# vlan 5
switch2(config-vlan)# name buh

switch2(config)# interface range fa 0/1-24
switch2(config-if-range)# switchport mode access
switch2(config-if-range)# switchport access vlan 5

switch2(config)# interface gig 0/1
switch2(config-if)# switchport encapsulation dot1q
switch2(config-if)# switchport mode trunk
switch2(config-if)# switchport trunk native vlan 4
switch2(config-if)# switchport trunk allowed vlan 4,5

switch2(config)# ip routing

switch2(config)#interface Vlan 5
switch2(config-if)#ip address 192.168.1.251 255.255.255.0
switch2(config-if)#no shutdown

это конфигурация будет работать, и будет ли vlan 4, видеть все остальные vlan, чтобы к нему админ мог проксю подрубить??

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

13. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от Gbyte email(ok) on 01-Мрт-10, 22:07 
убери native vlan с транка. он ведь у тебя там просто так?

Почему у тебя во всех виланах одна сеть 192.168.1.0/24???
Такого быть не может.
В кажлом вилане должна быть отдельная сеть.
Советую так:
vlan 1 - 192.168.1.0/24
vlan 2 - 192.168.2.0/24
vlan 3 - 192.168.3.0/24
и так далее.
такая нумерация будет удобней.

для линков между рутерами можно взять 192.168.0.0 и подить ее на подсети по 4 адреса (маска 255.255.255.252).

На роутере нужно написать маршруты для сетей коммутатора
например,  ip route 192.168.1.0 255.255.255.0 192.168.1.2

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

10. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от KudriK_TF email(ok) on 01-Мрт-10, 20:23 
>Имеет. натив тот который не тегируется.

не тегируется это ясно, т.е. через транк трафик с этого влана будет передаваться не тегированным и весь не тегируемый трафик будет передаваться на этот влан. а теперь глупый вопрос, если я назначу влан 3 нативом, то комп из этого влана может заходить в любой влан? сильно не бить, я правильно понял или нет?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

12. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от Gbyte email(ok) on 01-Мрт-10, 21:59 
>>Имеет. натив тот который не тегируется.
>
>не тегируется это ясно, т.е. через транк трафик с этого влана будет
>передаваться не тегированным и весь не тегируемый трафик будет передаваться на
>этот влан. а теперь глупый вопрос, если я назначу влан 3
>нативом, то комп из этого влана может заходить в любой влан?
>сильно не бить, я правильно понял или нет?

Неправильно!

Не тэгируемый значить только то что он не тегируется, т.е. те устройства которые не понимают дот1ку теги будут воспринимать только его.

Без особой необходимости натив вилан менять НЕЛЬЗЯ.

У тебя тут такой необходимости нет.

Для того чтобы комп мог ходить в другие виланы, необходимо чтобы вилан был маршрутизируемым.

Маршрутизируемый вилан, это тот вилан в котором есть маршрутизатор (коммутатор 3го уровня тоже, у него должен быть int vlan в этом вилане и должен быть назначен ип).

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

14. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от KudriK_TF email(ok) on 02-Мрт-10, 10:18 
>Маршрутизируемый вилан, это тот вилан в котором есть маршрутизатор (коммутатор 3го уровня
>тоже, у него должен быть int vlan в этом вилане и
>должен быть назначен ип).

привет, схема изменилась, теперь роутера нет в схеме вообще, а у меня последняя стадия начитанности, уже ничего не понимаю, помоги сделать этот третий vlan чтоб он ходил на все, я сделал как ты сказал, задал ip:

стековый свичь:
switch1(config)# vlan 1
switch1(config-vlan)# name work

switch1(config)# vlan 2
switch1(config-vlan)# name stud

switch1(config)# vlan 3
switch1(config-vlan)# name admin

switch1(config)# vlan 4
switch1(config-vlan)# name buh

switch1(config)# interface range fa 2/0/1-48
switch1(config-if-range)# switchport mode access
switch1(config-if-range)# switchport access vlan 1

switch1(config)# interface range fa 2/0/1-12
switch1(config-if-range)# switchport mode access
switch1(config-if-range)# switchport access vlan 2

switch1(config)# interface range fa 2/0/13-24
switch1(config-if-range)# switchport mode access
switch1(config-if-range)# switchport access vlan 3

идет на switch 2
switch1(config)# interface gig 1/0/1
switch1(config-if)# switchport encapsulation dot1q
switch1(config-if)# switchport mode trunk
switch1(config-if)# switchport trunk allowed vlan 4,5

switch1(config)# ip routing

switch1(config)#interface Vlan 1
switch1(config-if)#ip address 192.168.0.1 255.255.255.0
switch1(config-if)#no shutdown

switch1(config)#interface Vlan 2
switch1(config-if)#ip address 192.168.1.1 255.255.255.0
switch1(config-if)#no shutdown

switch1(config)#interface Vlan 3
switch1(config-if)#ip address 192.168.2.1 255.255.255.0
switch1(config-if)#no shutdown

свичь 2

switch2(config)# vlan 3
switch2(config-vlan)# name admin

switch2(config)# vlan 4
switch2(config-vlan)# name buh

switch2(config)# interface range fa 0/1-24
switch2(config-if-range)# switchport mode access
switch2(config-if-range)# switchport access vlan 5

switch2(config)# interface gig 0/1
switch2(config-if)# switchport encapsulation dot1q
switch2(config-if)# switchport mode trunk
switch2(config-if)# switchport trunk native vlan 4
switch2(config-if)# switchport trunk allowed vlan 4,5

switch2(config)# ip routing

switch2(config)#interface Vlan 5
switch2(config-if)#ip address 192.168.3.1 255.255.255.0
switch2(config-if)#no shutdown

подскажи как сделать, чтобы vlan 3 ходил в 1,2,3,4 ?? как?пожалуйста((

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

15. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от KudriK_TF email(ok) on 02-Мрт-10, 10:20 
я бы не просил, если бы не было срочно((

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

16. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от Gbyte email(ok) on 02-Мрт-10, 10:51 
>я бы не просил, если бы не было срочно((

извини, было много работы... попробуй мне на мыло написать.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

17. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от Gbyte email(ok) on 02-Мрт-10, 10:56 
Замечательно!

Схема изменилась, а что и куда тебе нужно ты так и не объяснил.
Объяни на словах что тебе нужно, максимально просто.

Кто у тебя гейт для стэка??

Что такое свич2? похоже 3750? тогда тебе вообще транк между ними нужен? - ты же всеравно ограничиваешь виланы в транке, пускаешь только 4 и 5...

С виланами вообще петрушка, коли книжки читал, видел какие там схемы? с вилнами и адресацией? - нарисуй, самому понятнее станет...

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

18. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от KudriK_TF email(ok) on 02-Мрт-10, 11:08 
>[оверквотинг удален]
>Объяни на словах что тебе нужно, максимально просто.
>
>Кто у тебя гейт для стэка??
>
>Что такое свич2? похоже 3750? тогда тебе вообще транк между ними нужен?
>- ты же всеравно ограничиваешь виланы в транке, пускаешь только 4
>и 5...
>
>С виланами вообще петрушка, коли книжки читал, видел какие там схемы? с
>вилнами и адресацией? - нарисуй, самому понятнее станет...

ситуация такая, нужно чтобы работал один каталист, с подключенными к нему пользователями, и чтобы он выполнял пока всю работу
схема:

> c a t a l y s t  ( s t e k )
> |          |              |
>vl1        vl2            vl3
>192.168.0.1  192.168.1.1  192.168.2.1

все, switch 2 и vlan 4 выкидываем чтобы не заморачиваться, мне нужно чтобы admin из vlan3, мог попасть в vlan 1 и vlan 2, а они не могли к нему пробраться....

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

19. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от KudriK_TF email(ok) on 02-Мрт-10, 11:18 
а то у меня сейчас компы с разных vlan не видят друг друга

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

20. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от KudriK_TF email(ok) on 02-Мрт-10, 11:26 
пока нет никакого роутера или прочей техники, нужно чтобы работал каталист сам по себе, со своими вланами и пользователями, т.е. внутренняя сеть, такое можно устроить? оно в принципе работает, только нужно чтобы 3й влан мог во все ходить. а 1 и 2 оставались замкнутыми

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

21. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от Gbyte email(ok) on 02-Мрт-10, 11:35 
>пока нет никакого роутера или прочей техники, нужно чтобы работал каталист сам
>по себе, со своими вланами и пользователями, т.е. внутренняя сеть, такое
>можно устроить? оно в принципе работает, только нужно чтобы 3й влан
>мог во все ходить. а 1 и 2 оставались замкнутыми

устроить можно.
ща подскажу.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

22. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от KudriK_TF email(ok) on 02-Мрт-10, 11:38 

>устроить можно.
>ща подскажу.

пасибо пасибо пасибо, я думаю что запретить можно access list, но вот как разрешить?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

24. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от Gbyte email(ok) on 02-Мрт-10, 11:45 
>
>>устроить можно.
>>ща подскажу.
>
>пасибо пасибо пасибо, я думаю что запретить можно access list, но вот
>как разрешить?

аксесс-лист он state-less - не понимает состояний сессий.
им можно только весь трафик прикрыть, а односторонней доступности им не добьешься.


Тебе кстати зачем изврат с админским виланом?
Чего боишься?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

25. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от KudriK_TF email(ok) on 02-Мрт-10, 11:51 
>Тебе кстати зачем изврат с админским виланом?
>Чего боишься?

да не боюсь я, там админ хочет очень проксю развернуть, и учет трафика сделать, мои убеждения что это на роутере можно сделать его не убеждают, даже если не весь вилан, можно пару портов, чтобы во все вланы заходил, я думал это транком сделать, но чет не пошло

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

23. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от Gbyte email(ok) on 02-Мрт-10, 11:40 
>>пока нет никакого роутера или прочей техники, нужно чтобы работал каталист сам
>>по себе, со своими вланами и пользователями, т.е. внутренняя сеть, такое
>>можно устроить? оно в принципе работает, только нужно чтобы 3й влан
>>мог во все ходить. а 1 и 2 оставались замкнутыми
>
>устроить можно.
>ща подскажу.

примерно то что тебе нужно:
http://blog.alwaysthenetwork.com/tutorials/private-vlan-tuto.../

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

26. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от KudriK_TF email(ok) on 02-Мрт-10, 12:24 

>примерно то что тебе нужно:
>http://blog.alwaysthenetwork.com/tutorials/private-vlan-tuto.../

исходя из этой ссылки, я должен сделать vlan 3 - Promiscuous ports, а vlan 1 и 2 - Isolated ports, при этом vlan 3 будет общаться со всеми, а эти гаврики общаться могу будут только с ним, но между собой не смогут, я правильно понял или нет - но они ведь тоже смогут с vlan 3 общаться, ладно, я поехал попробую сделать.... а тебе спасибо огромное!!

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

27. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от KudriK_Tt on 02-Мрт-10, 13:38 
Слушай,а я смогу к ним маршруты прописать? Ip route?


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

28. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от Gbyte email(ok) on 02-Мрт-10, 13:46 
>Слушай,а я смогу к ним маршруты прописать? Ip route?

куда? ты про что?

хочешь чтобы сети стэка были доступны из других сетей?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

29. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от KudriK_Tt on 02-Мрт-10, 13:54 

>хочешь чтобы сети стэка были доступны из других сетей?

Нет,забудь,это глупость,я внутри хотел прописать,между вланами!
При создании приоритетов он требует vtp,и с первым вланом вообще запрещает что либо делать,дома изучу внимательно

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

30. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от Gbyte email(ok) on 02-Мрт-10, 13:58 
>
>>хочешь чтобы сети стэка были доступны из других сетей?
>
>Нет,забудь,это глупость,я внутри хотел прописать,между вланами!

Да, сети в которых у рутера/коммутатора есть ип-адреса, называются connected.
Такие сети всегда присутствуют в таблице маршрутизации.
Административная дистанция у них 0 - самая высокая, т.е. они всегда лучше маршрутов в теже сети, но изученных из других источников.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

31. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от KudriK_Tt on 02-Мрт-10, 14:50 
Слушай,а еще каким либо образом,эту схему поднять нельзя? А то я добиться не могу,чтобы компы в разных вланах между собой пинги могли посылать! Дома подумаю над предложеным вариантом,только там не описано-а в влане изолированом,между собой устройства общаться могут?!


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

32. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от Gbyte email(ok) on 02-Мрт-10, 14:58 
>Слушай,а еще каким либо образом,эту схему поднять нельзя? А то я добиться
>не могу,чтобы компы в разных вланах между собой пинги могли посылать!
>Дома подумаю над предложеным вариантом,только там не описано-а в влане изолированом,между
>собой устройства общаться могут?!

вы сначала определитесь что именно вам нужно.
толи DMZ, толи чтобы в третий вилан никто попасть не мог..

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

33. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от KudriK_Tt on 02-Мрт-10, 15:15 

>вы сначала определитесь что именно вам нужно.
>толи DMZ, толи чтобы в третий вилан никто попасть не мог..

Надо чтобы вилан 3 мог инфой перекидываться с 1 и 2м,чтобы маршрутизация выполнялась,по возможности,чтобы народ со 2го и 1го туда заглянуть не могли,но главное,все таки шоб 3й видел компы в 1м и 2м...

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

34. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от Gbyte email(ok) on 02-Мрт-10, 15:39 
>
>>вы сначала определитесь что именно вам нужно.
>>толи DMZ, толи чтобы в третий вилан никто попасть не мог..
>
>Надо чтобы вилан 3 мог инфой перекидываться с 1 и 2м,чтобы маршрутизация
>выполнялась,по возможности,чтобы народ со 2го и 1го туда заглянуть не могли,но
>главное,все таки шоб 3й видел компы в 1м и 2м...

а ты говорил что-то про прокси в том вилане... или уже об этом забыли?

вообще для чего это тебе?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

35. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от KudriK_TF email(ok) on 02-Мрт-10, 16:43 
>а ты говорил что-то про прокси в том вилане... или уже об
>этом забыли?
>
>вообще для чего это тебе

давай расскажу с начала, что надо сделать, без всяких лишних вещей, мож так проще будет:

надо сделать две группы пользователей, которые между собой не должны общаться и два порта которые будут контролировать эти две группы пользователей, т.е. порты будут смотреть кто куда полез, ну и так далее...
я и запихал их и лишние порты в третий влан, только я думал что можно прописать чтобы, мол
этот влан ходил и сюда и сюда, а эти ни ни...
посоветуй, что делать? использовать ссылку, и сделать через privat или как??
и вообще, почему я пропинговать не могу компы из разных влан?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

36. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от Gbyte email(ok) on 02-Мрт-10, 16:57 

>надо сделать две группы пользователей, которые между собой не должны общаться и
>два порта которые будут контролировать эти две группы пользователей, т.е. порты
>будут смотреть кто куда полез, ну и так далее...

ну таки и используй "силу" (ссылку), Люк ;)

>я и запихал их и лишние порты в третий влан, только я
>думал что можно прописать чтобы, мол
>этот влан ходил и сюда и сюда, а эти ни ни...

тут ты опять все запутал и я опять ничего не понял :)


>и вообще, почему я пропинговать не могу компы из разных влан?

адреса компов, default gate на них соответствуют настройками int vlan на саталисте?

на компах: ipconfig
на свиче: "sho ip int br | e una" и "sho ip route"

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

37. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от KudriK_TF email(ok) on 02-Мрт-10, 17:09 
>адреса компов, default gate на них соответствуют настройками int vlan на саталисте?
>
>
>на компах: ipconfig
>на свиче: "sho ip int br | e una" и "sho ip
>route"

я как ставил:
int vlan 1
ip addre 192.168.0.1 255.255.255.0

на компе:
забивал ip - 192.168.0.111 255.255.255.0

при этом если есть еще один комп, то все лады - все идет, компы друг друга видят, а если в разных - то они ничего не видят.

извини, sh сделать не могу, cisco на работе отдыхает))

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

38. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от KudriK_TF email(ok) on 02-Мрт-10, 17:17 
можно вопрос по ссылке
- надо ли vtp чтобы сделать эту систему
- правило применяется к влану или к портам (просто плохо если у меня два компа в соседнем влане поговорить не смогут, хотя это поправимо)
- нужны ли ip у int vlan, или нет?
- ты применял эту схему сам или в инете нашел?
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

39. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от KudriK_TF email(ok) on 02-Мрт-10, 17:23 
и еще vlan то не будут ругаться что есть еще пару вланов использующие такие же ip?? ты ж сам говорил что несколько вланов в одной подсети невозможно??
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

40. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от KudriK_TF email(ok) on 02-Мрт-10, 17:33 
interface Gi0/1
switchport mode private-vlan promiscuous
switchport private-vlan mapping 50 add 51,52

слушай, у меня же нет We also have a router (Gi0/1) which will be our promiscuous port. (У нас также есть маршрутизатор (Gi0 / 1), который будет нашим Promiscuous порта.)

маршрутизатора то у меня нету
?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

41. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от KudriK_TF email(ok) on 02-Мрт-10, 17:38 
switch1(config)# vlan 3
switch1(config-vlan)# name admin

switch1(config)# vlan 4
switch1(config-vlan)# name stud

switch1(config)# vlan 5
switch1(config-vlan)# name work

switch1(config)#interface Vlan 3
switch1(config-if)#ip address 192.168.0.250 255.255.255.0
switch1(config-if)#no shutdown

vlan 3
private-vlan primary

vlan 4
private-vlan isolated
!
vlan 5
private-vlan isolated
!
vlan 3
private-vlan association 4,5

switch1(config)# interface range fa 1/0/13-24
switch1(config-if-range)# switchport mode private-vlan promiscuous
switch1(config-if-range)# switchport private-vlan mapping 3 add 4 5


switch1(config)# interface range fa 1/0/1-12
switch1(config-if-range)# switchport mode private-vlan host
switch1(config-if-range)# switchport private-vlan host-association 3 5

switch1(config)# interface range fa 2/0/1-48
switch1(config-if-range)# switchport mode private-vlan host
switch1(config-if-range)# switchport private-vlan host-association 3 4

думаешь это заработает?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

45. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от Gbyte email(ok) on 02-Мрт-10, 19:01 
>interface Gi0/1
> switchport mode private-vlan promiscuous
> switchport private-vlan mapping 50 add 51,52
>
>слушай, у меня же нет We also have a router (Gi0/1) which
>will be our promiscuous port. (У нас также есть маршрутизатор (Gi0
>/ 1), который будет нашим Promiscuous порта.)
>
>маршрутизатора то у меня нету
>?

Разве это плохо?
Тебе просто не нужно для рутера отдельно настраивать промискус, он есть поумолчанию :)

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

44. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от Gbyte email(ok) on 02-Мрт-10, 18:59 
>и еще vlan то не будут ругаться что есть еще пару вланов
>использующие такие же ip?? ты ж сам говорил что несколько вланов
>в одной подсети невозможно??

не путай темлое с зеленым.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

43. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от Gbyte email(ok) on 02-Мрт-10, 18:58 
>можно вопрос по ссылке
>- надо ли vtp чтобы сделать эту систему

непомню, читай по ссылке. если даже надо, то сделай отдельный домен и #vtp mode transparent

>- правило применяется к влану или к портам (просто плохо если у
>меня два компа в соседнем влане поговорить не смогут, хотя это
>поправимо)

опять таки в нете много инфы, гуглом тоже нужно уметь пользоваться

>- нужны ли ip у int vlan, или нет?

это фича исключительно L2 уровня.

>- ты применял эту схему сам или в инете нашел?

эта фича преподается на курсе BCMSN (она же Switch в новом CCNP).

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

47. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от KudriK_TF email(ok) on 03-Мрт-10, 05:52 

>эта фича преподается на курсе BCMSN (она же Switch в новом CCNP).
>

привет, я с конфигом вроде разобрался, по идее, щас приду на работу, сброшу настройки и сделаю и все заработает, только извини за глупый вопрос, но у меня же случайные порты будут видеть вланы не админские, но и их тоже?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

48. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от Gbyte email(ok) on 03-Мрт-10, 07:24 
>
>>эта фича преподается на курсе BCMSN (она же Switch в новом CCNP).
>>
>
>привет, я с конфигом вроде разобрался, по идее, щас приду на работу,
>сброшу настройки и сделаю и все заработает, только извини за глупый
>вопрос, но у меня же случайные порты будут видеть вланы не
>админские, но и их тоже?

Значит плохо читал ;)


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

42. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от Gbyte email(ok) on 02-Мрт-10, 18:55 
>я как ставил:
>int vlan 1
>ip addre 192.168.0.1 255.255.255.0
>
>на компе:
>забивал ip - 192.168.0.111 255.255.255.0
>
>при этом если есть еще один комп, то все лады - все
>идет, компы друг друга видят, а если в разных - то
>они ничего не видят.

Даже и не знаю что тебе сказать...
Как сделать я тебе выше писал:

адресация имеет значение не только на интерфейсах коммутатора, но и не компах.
если у тебя в вилане 2 у свича адрес например 192.168.2.1 и маска 255.255.255.0 (она же /24 в CIDR), то и у компов адреса должны быть из сети 192.168.2.0/24, иначе никто у тебя никого не увидит.

Перечитай ICND1.

кста, так как оборудование по умолчанию админится из вилана 1 его принято делать немаршрутизируемым или вообще отключать, в любом случае пользователи в вилан1 это зло.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

46. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от KudriK_TF email(ok) on 02-Мрт-10, 19:09 
угу, пасибо огромное, читаю инфу....щас попробуем что нить соорудить)
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

50. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от KudriK_TF email(ok) on 03-Мрт-10, 10:52 
Спасибо огроменное, все получилось - все заработало как часы.)

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

51. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от stal email on 03-Мрт-10, 10:55 
>Спасибо огроменное, все получилось - все заработало как часы.)

покажите пожалуйста окончательный конфиг

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

52. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от KudriK_TF email(ok) on 03-Мрт-10, 12:03 
>покажите пожалуйста окончательный конфиг

окончательная схема:

>пока роутера нет
>       switch 3750E (stek)
>    |      |       |       |
> vl100 - vl101 / vl102 / vl103
>    |______|_______|______|  |
>                             |
>                           2960
>                             |
>                           vl103

vlan 100 - должен общаться со всеми вланами, с ним тоже, но vlan между собой общаться не должна, сложность возникла с тем что 2960 не поддерживает privat-vlan, поэтому просто оставил его в дефолтовых настройках, и подключил без транка в gig 1/0/1 на 3750Е, и все работает.
vlan 100
priva-vlan primary

vlan 101
priva-vlan comm

vlan 102
priva-vlan comm

vlan 103
priva-vlan comm

vlan 100
priva-vlan asso 101,102,103

int range fa 2/0/1-48
sw
sw mode priv-vl host
sw pr-vl host asso 100 101

int range fa 1/0/1-12
sw
sw mode priv-vl host
sw pr-vl host asso 100 102

int gig 1/0/1
sw
sw mode priv-vl host
sw pr-vl host asso 100 103

int range fa 2/0/1-48
sw
sw mode priv-vl promis
sw pr-vl mapp 100 add 101,102,103

int vlan 100
ip addre 192.168.0.250 255.255.255.0

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

53. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от KudriK_Tt on 04-Мрт-10, 08:43 
Народ,слушайте,а моей схеме и конфиге что нибудь можно добавить,чтобы на свиче 2960 сделать другую под сеть? Например с ip 10.10.10.1 ?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

54. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от Gbyte email(ok) on 04-Мрт-10, 08:50 
>Народ,слушайте,а моей схеме и конфиге что нибудь можно добавить,чтобы на свиче 2960
>сделать другую под сеть? Например с ip 10.10.10.1 ?

можно.

нужно на 3750 сделать:
#conf t
(config)#int vlan {vlan в котором нужно 10.10.10.1/24}
(config-int)#no ip addr
(config-int)#ip addr 10.10.10.1 255.255.255.0
(config-int)#end
#write

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

55. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от KudriK_Tt on 04-Мрт-10, 09:10 

>#conf t
>(config)#int vlan {vlan в котором нужно 10.10.10.1/24}
>(config-int)#no ip addr
>(config-int)#ip addr 10.10.10.1 255.255.255.0
>(config-int)#end
>#write

Ага,пасибо,а на 2960 настраивать получается ничего не надо? Сейчас свет включат,попробую

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

56. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от KudriK_Tt on 04-Мрт-10, 09:12 
А то он у меня пока в дефолтовых настройках,даже порты в 103 вилан не переведены
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

57. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от KudriK_Tt on 04-Мрт-10, 10:30 
Не выходит,я прописал на 3750
int vlan 103
ip addr 10.10.10.1 255.255.255.0
Ничего не пингуется, с 100влана пинг не идет, может secondary на 100м влане (главном) исправит ситуацию?
Я еще на 2960 ввел порты в 103 влан,надо ему ip задавать из под сети 10.10.10.0?
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

58. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от Gbyte email(ok) on 04-Мрт-10, 11:00 
>Не выходит,я прописал на 3750
>int vlan 103
>ip addr 10.10.10.1 255.255.255.0
>Ничего не пингуется, с 100влана пинг не идет, может secondary на 100м
>влане (главном) исправит ситуацию?
>Я еще на 2960 ввел порты в 103 влан,надо ему ip задавать
>из под сети 10.10.10.0?

может вам нанять специалиста?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

59. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от KudriK_TF email(ok) on 05-Мрт-10, 11:20 

>может вам нанять специалиста?

да не, спасибо, все заработало, давно, времени не было на форуме отписываться, местный админ пропинговать не мог, пришлось самому подниматься и смотреть, а так все работало правильно, спасибо еще раз.

слушай, тут такой вопрос, что посоветуешь почитать по роутерам cisco?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

60. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от Gbyte email(ok) on 05-Мрт-10, 14:50 
>
>>может вам нанять специалиста?
>
>да не, спасибо, все заработало, давно, времени не было на форуме отписываться,
>местный админ пропинговать не мог, пришлось самому подниматься и смотреть, а
>так все работало правильно, спасибо еще раз.
>
>слушай, тут такой вопрос, что посоветуешь почитать по роутерам cisco?

BSCI (642-901) или Routing (642-902)

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

61. "как связать коммутаторы Cisco Catalyst 3750 в стек"  +/
Сообщение от KudriK_TF email(ok) on 06-Мрт-10, 14:38 

>BSCI (642-901) или Routing (642-902)

спасибо

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру