The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]



"Cisco AP1832i и U-Boot"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Диагностика и решение проблем)
Изначальное сообщение [ Отслеживать ]

"Cisco AP1832i и U-Boot"  +/
Сообщение от Upanic (?), 04-Ноя-22, 09:57 
Всем привет,

Такая история, по глупости в u-boot потёр разделы (предположение) командой  #nand erase.chip
Теперь при заливке прошивки и загрузки с неё логично следует ошибка:


Specified BOOT: part1
Booting from part1
Volume part1 not found!
Booting failed, try boot on part2
Volume part2 not found!

Кто работал с u-boot, подскажите как решить проблему, создать заново разделы:


(RNAQ-C7) # bootipq debug
Specified BOOT: part1
setenv corsica_bootargs setenv bootargs 'console=ttyHSL1,9600n8  activepart=${bootpart} activeboot=0 wdgtriggered=0'; setenv mtdids nand0=nand0;
setenv mtdparts mtdparts=nand0:0x10000000@0x0(fs) && ubi part fs
UBI: mtd2 is detached from ubi0
UBI: fixable bit-flip detected at PEB 695
UBI: fixable bit-flip detected at PEB 834
UBI: fixable bit-flip detected at PEB 1395

Booting from part1

ubi read 0x45000000 part1 0x400;
Volume part1 not found!

Booting failed, try boot on part2

ubi read 0x45000000 part2 0x400;
Volume part2 not found!

-------------


(RNAQ-C7) # nand info    

Device 0: nand0, sector size 128 KiB
  Page size      2048 b
  OOB size         64 b
  Erase size   131072 b
Device 1: 808464432x nand1, sector size 4 KiB
  Page size       256 b
  OOB size          0 b
  Erase size     4096 b

Прошу помочь, кто сведущ по данной теме)

Ответить | Правка | Cообщить модератору


Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема



Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру