The OpenNET Project / Index page

[ новости /+++ | форум | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"BGP+NAT"
Вариант для распечатки Архивированная нить - только для чтения! 
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"BGP+NAT" 
Сообщение от yav emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 10-Дек-04, 16:39  (MSK)
Ситуация следующая:

RouterA и RouterB соединены FA0/0 -> Fa0/0. Плюс к этому у RouterA два линка на RouterC с которым он пирится по BGP.
RouterA натит внутреннюю сетку 172.16.0.0/16 в 2.0.0.0/27

Проблема:
Если адреса на линках с BGP из сети 172.16.0.0, BGP сессия переходит в active, но если 172.32.0.0 все работает в том числе NAT
Подозреваю что NAT не работает для адресов по которым пирится BGP.

Так NAT не работает:

hostname RouterA
!
!
interface FastEthernet0/0
ip address 172.16.0.194 255.255.255.252
ip nat inside
duplex auto
speed auto
!
!
interface Serial0/0
ip address 172.16.0.165 255.255.255.252
ip nat outside
no ip route-cache
no ip mroute-cache
!
interface Serial0/1
ip address 172.16.0.161 255.255.255.252
ip nat outside
no ip route-cache
no ip mroute-cache
!
router bgp 200
no synchronization
bgp log-neighbor-changes
network 2.0.0.0 mask 255.255.255.224
neighbor 172.16.0.162 remote-as 100
neighbor 172.16.0.166 remote-as 100
no auto-summary
!
!
ip nat pool INET_PUBLIC 2.0.0.3 2.0.0.30 netmask 255.255.255.224
ip nat inside source list 10 pool INET_PUBLIC overload
!
access-list 10 permit 172.16.0.0 0.0.255.255


hostname RouterС
!
interface Serial0/0
ip address 172.32.0.162 255.255.255.252
no fair-queue
clockrate 56000
!
interface Serial0/1
ip address 172.32.0.166 255.255.255.252
clockrate 56000
!
router bgp 100
no synchronization
bgp log-neighbor-changes
network 33.0.0.0 mask 255.255.255.0
neighbor 172.16.0.161 remote-as 200
neighbor 172.16.0.165 remote-as 200
no auto-summary
!
ip classless
ip route 2.0.0.0 255.255.255.0 Serial0/0 50
ip route 2.0.0.0 255.255.255.0 Serial0/1 100

Что бы заработал нужно поменять следуюшее

hostname RouterA
!
interface Serial0/0
ip address 172.32.0.165 255.255.255.252
!
interface Serial0/1
ip address 172.32.0.161 255.255.255.252
!
router bgp 200
neighbor 172.32.0.162 remote-as 100
neighbor 172.32.0.166 remote-as 100
!
!


hostname RouterС
!
interface Serial0/0
ip address 172.32.0.162 255.255.255.252
!
interface Serial0/1
ip address 172.32.0.166 255.255.255.252
!
router bgp 100
neighbor 172.32.0.161 remote-as 200
neighbor 172.32.0.165 remote-as 200

Ваше мнение и предложения, господа, для реализации BGP на линках из сети 172.16.0.0/16 и ту же сеть натить.

  Рекомендовать в FAQ | Cообщить модератору | Наверх

 Оглавление

  • BGP+NAT, ВОЛКА, 21:33 , 10-Дек-04, (1)  
    • BGP+NAT, yav, 13:25 , 11-Дек-04, (2)  
      • BGP+NAT, ВОЛКА, 14:41 , 11-Дек-04, (3)  
        • BGP+NAT, yav, 18:05 , 11-Дек-04, (4)  
          • BGP+NAT, Beginner, 10:50 , 13-Дек-04, (5)  
            • BGP+NAT, sh_, 19:43 , 13-Дек-04, (6)  

Индекс форумов | Темы | Пред. тема | След. тема
Сообщения по теме

1. "BGP+NAT" 
Сообщение от ВОЛКА emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 10-Дек-04, 21:33  (MSK)
172.16.0.161 255.255.255.252
172.32.0.162 255.255.255.252
находятся в разных сетях!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
  Рекомендовать в FAQ | Cообщить модератору | Наверх

2. "BGP+NAT" 
Сообщение от yav emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 11-Дек-04, 13:25  (MSK)
>172.16.0.161 255.255.255.252
>172.32.0.162 255.255.255.252
>находятся в разных сетях!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Тогда вопрос. Почему нельзя строить BGP сессию на 172.16.0.0

  Рекомендовать в FAQ | Cообщить модератору | Наверх

3. "BGP+NAT" 
Сообщение от ВОЛКА emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 11-Дек-04, 14:41  (MSK)
я твоя непонимай
  Рекомендовать в FAQ | Cообщить модератору | Наверх

4. "BGP+NAT" 
Сообщение от yav emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 11-Дек-04, 18:05  (MSK)
>я твоя непонимай

Если роутерA пирится по 172.16.0.165 172.16.0.161 с роутеромС на котором 172.16.0.162 172.16.0.166, то после добавления ната:

ip nat pool INET_PUBLIC 2.0.0.3 2.0.0.30 netmask 255.255.255.224
ip nat inside source list 10 pool INET_PUBLIC overload
!
access-list 10 permit 172.16.0.0 0.0.255.255
BGP сессия переходит в состояние active, это значит что она не установлена. Ферштейн?

Теперь вопрос: почему на адресах 172.16.0.165 172.16.0.161 со стороны RouterA и соответственно 172.16.0.162 172.16.0.166 RouterC, происходит разрыв сесси BGP (см. конфиг выше)

  Рекомендовать в FAQ | Cообщить модератору | Наверх

5. "BGP+NAT" 
Сообщение от Beginner emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 13-Дек-04, 10:50  (MSK)
>>я твоя непонимай
>
>Если роутерA пирится по 172.16.0.165 172.16.0.161 с роутеромС на котором 172.16.0.162 172.16.0.166,
>то после добавления ната:
>
>ip nat pool INET_PUBLIC 2.0.0.3 2.0.0.30 netmask 255.255.255.224
>ip nat inside source list 10 pool INET_PUBLIC overload
>!
>access-list 10 permit 172.16.0.0 0.0.255.255
>BGP сессия переходит в состояние active, это значит что она не установлена.
>Ферштейн?
>
>Теперь вопрос: почему на адресах 172.16.0.165 172.16.0.161 со стороны RouterA и соответственно
>172.16.0.162 172.16.0.166 RouterC, происходит разрыв сесси BGP (см. конфиг выше)


Насколько я понял ты натишь вместе со всей своей сетью и BGP сессию. Есно она рвется.

  Рекомендовать в FAQ | Cообщить модератору | Наверх

6. "BGP+NAT" 
Сообщение от sh_ Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 13-Дек-04, 19:43  (MSK)
Тебе же говорят, что в качестве нейборов ты указываешь:
neighbor 172.16.0.162 remote-as 100
neighbor 172.16.0.166 remote-as 100
т.е. адреса, которые ни на одном из рутеров не прописаны. С кем у тебя БГП поднимется?
  Рекомендовать в FAQ | Cообщить модератору | Наверх


Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Пожалуйста, прежде чем написать сообщение, ознакомьтесь с данными рекомендациями.




Партнёры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2024 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру