The OpenNET Project / Index page

[ новости /+++ | форум | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"Распараллеливание и резервирование каналов."
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"Распараллеливание и резервирование каналов." 
Сообщение от Agp emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 25-Фев-05, 14:09  (MSK)
Здравствуйте.
Пошлите, пожалуйста, в правильную сторону.
Имеется два офиса, соединённых двумя выделенными каналами 2Mb и 1Mb.
С одной стороны 3640, с другой 1720.
Требуется объединить их так, чтобы при работе обоих, данные распределялись по каналам, а при падении одного из них всё продолжало работать через один.
Спасибо.
  Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

 Оглавление

Индекс форумов | Темы | Пред. тема | След. тема
Сообщения по теме

1. "Распараллеливание и резервирование каналов." 
Сообщение от Nailer Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 25-Фев-05, 14:24  (MSK)
>Здравствуйте.
>Пошлите, пожалуйста, в правильную сторону.
>Имеется два офиса, соединённых двумя выделенными каналами 2Mb и 1Mb.
>С одной стороны 3640, с другой 1720.
>Требуется объединить их так, чтобы при работе обоих, данные распределялись по каналам,
>а при падении одного из них всё продолжало работать через один.
>
>Спасибо.

Поднимите динамическую маршрутизацию, на ospf или на eigrp.

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

2. "Распараллеливание и резервирование каналов." 
Сообщение от toor99 emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(ok) on 26-Фев-05, 15:11  (MSK)
>>Здравствуйте.
>>Пошлите, пожалуйста, в правильную сторону.
>>Имеется два офиса, соединённых двумя выделенными каналами 2Mb и 1Mb.
>>С одной стороны 3640, с другой 1720.
>>Требуется объединить их так, чтобы при работе обоих, данные распределялись по каналам,
>>а при падении одного из них всё продолжало работать через один.
>>
>>Спасибо.
>
>Поднимите динамическую маршрутизацию, на ospf или на eigrp.

И зачем чуть что - OSPF, EIGRP...
Есть такой вот трюк.
Скажем, у нас два сериальных интерфейса, s0 и s1; линк подключенный к s0 - 2 мегабита, к s1 - 1 мегабит.
Берем три
Дальше так:

ip route 10.0.0.1 255.255.255.255 S0
ip route 10.0.0.2 255.255.255.255 S0
ip route 10.0.0.3 255.255.255.255 S1
(адреса по вкусу)
Скажем, сеть в другом офисе - 111.222.333.0/24
Тогда делаем
ip route 111.222.333.0 255.255.255.0 10.0.0.1
ip route 111.222.333.0 255.255.255.0 10.0.0.2
ip route 111.222.333.0 255.255.255.0 10.0.0.3

Включаем CEF, и говорим
int S0
ip load-sharing per-packet
int S1
ip load-sharing per-packet

Всё будет балансироваться именно так, как заказано.

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

3. "Распараллеливание и резервирование каналов." 
Сообщение от Agp emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 15-Мрт-05, 13:22  (MSK)
>Поднимите динамическую маршрутизацию, на ospf или на eigrp.

Поднял ospf, но видно не до конца ...
Оба канала работают, но 'sh ip route' показывает только один (вроде так и должно быть). При отключении одного второй подсосался в работу секунд за 30-40, при включении назад роуты секунд за 10-15 вернулись назад, на лучший маршрут. Какая-то надёжность появилась.
Второе, попытался загрузить канал получилось процентов на 70 от 2Mbit, по второму так ничего и не полезло. Когда должно включаться балансирование, когда первый совсем переполнится?
Может я всё-таки чего-то не настроил ?

на первом роутере:
int loopback 0
ip address 192.168.253.1 255.255.255.252
router ospf 253
network 192.168.1.0 0.0.0.255 area 0

на втором:
int loopback 0
ip address 192.168.253.5 255.255.255.252
router ospf 253
network 192.168.2.0 0.0.0.255 area 0

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

4. "Распараллеливание и резервирование каналов." 
Сообщение от toor99 emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(ok) on 15-Мрт-05, 15:01  (MSK)
И не должно. Посмотрите на таблицу маршрутов - ваш резервный линк отсутствует в таблице. Если вам нужна балансировка в сочетании с протоколом маршрутизации, используйте EIGRP и variance. OSPF этого не умеет.
  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

7. "Распараллеливание и резервирование каналов." 
Сообщение от Олег Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 15-Мрт-05, 15:57  (MSK)
>И не должно. Посмотрите на таблицу маршрутов - ваш резервный линк отсутствует
>в таблице. Если вам нужна балансировка в сочетании с протоколом маршрутизации,
>используйте EIGRP и variance. OSPF этого не умеет.

Возражаю: OSPF это умеет!

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

9. "Распараллеливание и резервирование каналов." 
Сообщение от Сайко Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 15-Мрт-05, 16:11  (MSK)
Коллега Олег,

г-н toor99 в своем высказывании косвенно имеет ввиду Unequal Cost Path Load Balancing.

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

10. "Распараллеливание и резервирование каналов." 
Сообщение от Олег Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 15-Мрт-05, 17:45  (MSK)
Я понимаю, спасибо.
Однако высказывание указывало на то, что OSPF не умеет делать балансировку вообще...

>Если вам нужна балансировка в сочетании с протоколом маршрутизации,
>используйте EIGRP и variance. OSPF этого не умеет.

Я думаю, вопрос снят. Балансирует EIGRP однозначно лучше.

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

11. "Распараллеливание и резервирование каналов." 
Сообщение от Сайко Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 15-Мрт-05, 18:06  (MSK)
>Я понимаю, спасибо.
>Однако высказывание указывало на то, что OSPF не умеет делать балансировку вообще...
>Я думаю, вопрос снят. Балансирует EIGRP однозначно лучше.
Открою Вам еще один секрет - балансирует даже не OSPF, а CEF(Cisco Express Forwarding).

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

8. "Распараллеливание и резервирование каналов." 
Сообщение от Nailer emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 15-Мрт-05, 16:07  (MSK)
>>Поднимите динамическую маршрутизацию, на ospf или на eigrp.
>
>Поднял ospf, но видно не до конца ...
>Оба канала работают, но 'sh ip route' показывает только один (вроде так
>и должно быть). При отключении одного второй подсосался в работу секунд
>за 30-40, при включении назад роуты секунд за 10-15 вернулись назад,
>на лучший маршрут. Какая-то надёжность появилась.
>Второе, попытался загрузить канал получилось процентов на 70 от 2Mbit, по второму
>так ничего и не полезло. Когда должно включаться балансирование, когда первый
>совсем переполнится?
>Может я всё-таки чего-то не настроил ?
>
>на первом роутере:
>int loopback 0
>ip address 192.168.253.1 255.255.255.252
>router ospf 253
>network 192.168.1.0 0.0.0.255 area 0
>
>на втором:
>int loopback 0
>ip address 192.168.253.5 255.255.255.252
>router ospf 253
>network 192.168.2.0 0.0.0.255 area 0

Весь конфиг покажите.

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

12. "Распараллеливание и резервирование каналов." 
Сообщение от Agp emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 17-Мрт-05, 13:28  (MSK)
Я тут вот чего ещё хотел бы уточнить
А я куда должны быть направлены при этом default-gateway? на оба канала ?
  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

5. "Распараллеливание и резервирование каналов." 
Сообщение от Сайко Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 15-Мрт-05, 15:16  (MSK)
http://www.cisco.com/warp/public/105/loadbal_cef.html

OSPF allows only equal cost load balancing. To configure unequal cost load sharing, configure Enhanced Interior Gateway Routing Protocol/Interior Gateway Routing Protocol (EIGRP/IGRP) as your Interior Gateway Protocol (IGP). See How Does Unequal Cost Path Load Balancing (Variance) Work in IGRP and EIGRP? for further information.
http://www.cisco.com/warp/public/103/19.html

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

6. "Распараллеливание и резервирование каналов." 
Сообщение от Сайко Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 15-Мрт-05, 15:36  (MSK)
P.S. Кстати, я бы лично потренировался на MFR(FRF.16). Судя по FN и 3640 и 1720 это поддерживают.
  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

13. "Не выходит каменный цветок. Eigrp." 
Сообщение от AGP Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 27-Мрт-05, 18:13  (MSK)
И снова здравствуйте.
Всё таки не получается балансинг. Раскрутил eigrp. Вроде что-то работает, но весь трафик упорно прётся через широкую дыру. Смущает, что в таблице маршрутизации всё так же только один маршрут.
Мысль есть такая: метрика второго маршрута, между маршрутизаторами, больше feasible distance (но как посчитать конкетно участок, я чего-то не догнал).
Схема та же, поменял адресацию маленько, а так всё то же:
                     (default)
                         |
                       fa0/1   b=2048, d=2000, M=1764352 - FD, RD=28160
                         |      S3/0-----S1
(n1:10.1.1.0)-(fa0/0:10.1.1.100:r1)<     >(r2:10.1.2.100:fa0)-(10.1.2.0:n2)
                                S0/1-----S0
                               b=1024, d=2000, M=3014400 < var*FD, RD=28160
                                                                                          
Может посоветуете чего ?
--------------+++++++++++++++++++++++-----------------
                                                                                                                                                                                      
на первом роутере:
int loopback 0
ip address 192.168.253.1 255.255.255.252
router eigrp 253
variance 2
passive-interface FastEthernet0/0
passive-interface FastEthernet0/1
network 10.1.1.0 0.0.0.255
network 10.1.2.0 0.0.0.255
                                                                                          
на втором:
int loopback 0
ip address 192.168.253.5 255.255.255.252
router eigrp 253
variance 2
passive-interface FastEthernet0
network 10.1.1.0 0.0.0.255
network 10.1.2.0 0.0.0.255
--------------+++++++++++++++++++++++-----------------

router1#sh ip route
     10.0.0.0/24 is subnetted, 4 subnets
D       10.1.2.0 [90/1764352] via 10.1.2.100, 1d05h, Serial3/0
C       10.1.1.0 is directly connected, FastEthernet0/0
C       10.0.0.0 is directly connected, FastEthernet0/1
     192.168.253.0/30 is subnetted, 1 subnets
C       192.168.253.0 is directly connected, Loopback0
S*   0.0.0.0/0 [1/0] via 10.0.0.2
                                                                                          
router2##sh ip route
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C       10.1.2.0/24 is directly connected, FastEthernet0
D       10.1.1.0/24 [90/1764352] via 10.1.1.100, 1d04h, Serial1
D       10.0.0.0/8 is a summary, 1d04h, Null0
     192.168.253.0/30 is subnetted, 1 subnets
C       192.168.253.4 is directly connected, Loopback0
S*   0.0.0.0/0 is directly connected, Serial1
--------------+++++++++++++++++++++++-----------------
                                                                                          
Малость смущают то, что все маршруты с кодом P - passive.
                                                                                          
router1#sh ip eigrp topology
IP-EIGRP Topology Table for AS(253)/ID(10.1.1.100)
                                                                                          
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status
                                                                                          
P 10.1.2.0/24, 1 successors, FD is 1761792
         via 10.1.2.100 (1764352/28160), Serial3/0
         via 10.1.2.100 (3014400/28160), Serial0/1
P 10.1.1.0/24, 1 successors, FD is 28160
         via Connected, FastEthernet0/0
                                                                                          
router2#sh ip eigrp topology
IP-EIGRP Topology Table for AS(253)/ID(192.168.253.5)
                                                                                          
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - Reply status
                                                                                          
P 10.1.2.0/24, 1 successors, FD is 28160
         via Connected, FastEthernet0
P 10.1.1.0/24, 1 successors, FD is 1764352
         via 10.1.1.100 (1764352/28160), Serial1
         via 10.1.1.100 (3014400/28160), Serial0
P 10.0.0.0/8, 1 successors, FD is 28160
         via Summary (28160/0), Null0
--------------+++++++++++++++++++++++-----------------

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

14. "Не выходит каменный цветок. Eigrp." 
Сообщение от AGP Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 27-Мрт-05, 18:17  (MSK)
На всякий случай полные конфиги чтоб не думалось лишнего ....

router1:
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname router1
aaa new-model
enable secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
username AGP password 7 xxxxxxxxxxxxxxxxxxxxxx
clock timezone MSK 3
clock summer-time MSD recurring last Sun Mar 2:00 last Sun Oct 3:00
ip subnet-zero
!
no ip finger
!
interface Loopback0
ip address 192.168.253.1 255.255.255.252
!
interface FastEthernet0/0
ip address 10.1.1.100 255.255.255.0
ip helper-address 10.1.2.255
speed auto
full-duplex
!
interface FastEthernet0/1
description "Firewall canal"
ip address 10.0.0.100 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1
bandwidth 1024
ip unnumbered FastEthernet0/0
no ip mroute-cache
no fair-queue
compress stac
!
!
interface Serial3/0
bandwidth 2048
ip unnumbered FastEthernet0/0
no ip mroute-cache
!
router eigrp 253
variance 2
passive-interface FastEthernet0/0
passive-interface FastEthernet0/1
network 10.1.1.0 0.0.0.255
network 10.1.2.0 0.0.0.255
auto-summary
no eigrp log-neighbor-changes
!
ip default-gateway 10.0.0.2
ip classless
ip route 0.0.0.0 0.0.0.0 10.0.0.2
no ip http server
!
logging trap debugging
logging facility local3
logging 10.1.1.18
!
access-list 1 remark "Access to Router"
access-list 1 permit 10.1.1.18
snmp-server community xxxxxxxxxxx RO
!
line con 0
transport input none
line vty 0 4
access-class 1 in
exec-timeout 30 0
end
                                                                                          
router2:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname router2
aaa new-model
enable secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
username AGP password 7 xxxxxxxxxxxxxxxxxxxxxx
!
memory-size iomem 25
clock timezone MSK 3
clock summer-time MSD recurring last Sun Mar 2:00 last Sun Oct 3:00
ip subnet-zero
!
interface Loopback0
ip address 192.168.253.5 255.255.255.252
!
interface Serial0
bandwidth 1024
ip unnumbered FastEthernet0
fair-queue
compress stac
!
interface Serial1
bandwidth 2048
ip unnumbered FastEthernet0
!
interface FastEthernet0
ip address 10.1.2.100 255.255.255.0
ip directed-broadcast 190
speed auto
full-duplex
!router eigrp 253
variance 2
passive-interface FastEthernet0
network 10.1.1.0 0.0.0.255
network 10.1.2.0 0.0.0.255
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial1
no ip http server
!
logging facility local3
logging 10.1.1.18
!
access-list 1 remark "Access to Router"
access-list 1 permit 10.1.1.18
access-list 190 permit udp any host 10.1.2.255 eq netbios-dgm
!
snmp-server engineID local 00000009020000055E2E172F
snmp-server community xxxxxxxx RO
!
line con 0
transport input none
line vty 0 4
access-class 1 in
exec-timeout 30 0
!
end

  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх


Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Пожалуйста, прежде чем написать сообщение, ознакомьтесь с данными рекомендациями.




Партнёры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2024 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру