The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"php-extensions не собирается с mcrypt"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы WEB технологии (Public)
Изначальное сообщение [ Отслеживать ]

"php-extensions не собирается с mcrypt"  
Сообщение от winser (ok) on 13-Дек-08, 13:11 
Сервер FreeBSD 7.0
Установлен апач2, мускуль 5,0,45 и php-5.2.5

Суть проблемы в том что не могу пересобрать расширения для php (php-extensions), а в частности не собирается с модулем mcrypt. Собираю из портов.
Подскажите как победить :(

Вот:

# make deinstall
===>  Deinstalling for lang/php5-extensions
===>   Deinstalling php5-extensions-1.1


#make config (добавляю модулю в менюшке)

# make install clean
===>  Installing for php5-extensions-1.1
===>   php5-extensions-1.1 depends on file: /usr/local/include/php/main/php.h - found
===>   php5-extensions-1.1 depends on file: /usr/local/lib/php/20060613/ctype.so - found
===>   php5-extensions-1.1 depends on file: /usr/local/lib/php/20060613/dom.so - found
===>   php5-extensions-1.1 depends on file: /usr/local/lib/php/20060613/filter.so - found
===>   php5-extensions-1.1 depends on file: /usr/local/lib/php/20060613/hash.so - found
===>   php5-extensions-1.1 depends on file: /usr/local/lib/php/20060613/iconv.so - found
===>   php5-extensions-1.1 depends on file: /usr/local/lib/php/20060613/json.so - found
===>   php5-extensions-1.1 depends on file: /usr/local/lib/php/20060613/mcrypt.so - not found
===>    Verifying install for /usr/local/lib/php/20060613/mcrypt.so in /usr/ports/security/php5-mcrypt
===>   php5-mcrypt-5.2.5 depends on executable: phpize - found
===>   php5-mcrypt-5.2.5 depends on file: /usr/local/bin/autoconf-2.61 - found
===>   php5-mcrypt-5.2.5 depends on shared library: mcrypt.8 - found
===>   php5-mcrypt-5.2.5 depends on shared library: ltdl.4 - not found
===>    Verifying install for ltdl.4 in /usr/ports/devel/libltdl15
===>  Configuring for libltdl-1.5.24
checking for a BSD-compatible install... /usr/bin/install -c -o root -g wheel
checking whether build environment is sane... configure: error: newly created file is older than distributed files!
Check your system clock
===>  Script "configure" failed unexpectedly.
Please report the problem to ade@FreeBSD.org [maintainer] and attach the
"/usr/ports/devel/libltdl15/work/libtool-1.5.24/config.log" including the
output of the failure of your make command. Also, it might be a good idea to
provide an overview of all packages installed on your system (e.g. an `ls
/var/db/pkg`).
*** Error code 1

Stop in /usr/ports/devel/libltdl15.
*** Error code 1

Stop in /usr/ports/security/php5-mcrypt.
*** Error code 1

Stop in /usr/ports/lang/php5-extensions.
*** Error code 1

Stop in /usr/ports/lang/php5-extensions.

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "php-extensions не собирается с mcrypt"  
Сообщение от TyLLIKAH on 13-Дек-08, 17:26 
>newly created file is older than distributed files!

У тебя часы съехали

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2023 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру