The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Второй интерпретатор PHP"
Вариант для распечатки  
Пред. тема | След. тема 
Форум WEB технологии (PHP)
Изначальное сообщение [ Отслеживать ]

"Второй интерпретатор PHP"  +/
Сообщение от mvi (ok) on 16-Июн-10, 10:52 
Требуется установить (скомпилировать из исходников) второй интерпретатор PHP на CentOS,чтобы его установка никак не повлияла на первый (основной) интерпретатор. Как я делал:
- скачал исходники PHP
- взял опции старого интерпретатора из phpinfo()
- добавил нужные мне опции
- запустил ./configure с этими суммарными опциями
- make
- вместо make install просто скопировал sapi/cli/php в /bin/phpimap/php (не стал запускать make install, так как файлы скопируются поверх старого интерпретатора и будет только новый, а мне нужно сохранить старый)

пытаюсь запустить скрипт из shell /bin/phpimap/php /path/testscript.php, а он мне говорит, что не может инициализировать модули:

PHP Warning: PHP Startup: dbase: Unable to initialize module
Module compiled with module API=20050922, debug=0, thread-safety=0
PHP compiled with module API=20060613, debug=0, thread-safety=0
These options need to match
in Unknown on line 0

Как быть?

Заранее благодарен за любую помощь

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Второй интерпретатор PHP"  +/
Сообщение от Pahanivo (ok) on 16-Июн-10, 17:40 
>Требуется установить (скомпилировать из исходников) второй интерпретатор PHP на CentOS,чтобы его установка

какие проблемы?
>никак не повлияла на первый (основной) интерпретатор. Как я делал:

что значит влиять?
>- скачал исходники PHP
>- взял опции старого интерпретатора из phpinfo()
>- добавил нужные мне опции
>- запустил ./configure с этими суммарными опциями
>- make
>- вместо make install просто скопировал sapi/cli/php в /bin/phpimap/php (не стал >запускать

а сконфигурить его на инстал в альтернативный дир не догадался? жаль
иииии где по твоему он будет искать библы? и самое главно чъи, свои или того пыха на который он не должен повлиять?
>make install, так как файлы скопируются поверх старого интерпретатора и будет
>только новый, а мне нужно сохранить старый)

up
>
>пытаюсь запустить скрипт из shell /bin/phpimap/php /path/testscript.php, а он мне говорит, что
>не может инициализировать модули:

а ты чего ждал после этого? )
>PHP Warning: PHP Startup: dbase: Unable to initialize module
>Module compiled with module API=20050922, debug=0, thread-safety=0
>PHP compiled with module API=20060613, debug=0, thread-safety=0
>These options need to match
>in Unknown on line 0
>
>Как быть?

учится собирать софт ручками "граманта"

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру