The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Релиз видеоконвертера HandBrake 0.9.5

04.01.2011 16:26

После года разработки представлен релиз HandBrake 0.9.5, инструмента для многопоточного перекодирования видеофайлов из одного формата в другой. Программа доступна как в варианте, работающем в режиме командной строки, так и в виде GUI-интерфейса. Код проекта написан на языке Си и распространяется в рамках лицензии GPL, бинарные сборки можно загрузить для Fedora, Ubuntu, MacOS X и Windows.

Программа может перекодировать видео с BluRay/DVD-дисков, копий директории VIDEO_TS и любых файлов, формат которых поддерживается библиотеками libavformat и libavcodec из состава FFmpeg. На выходе могут быть сформированы файлы в таких форматах, как MP4 и MKV, для кодирования видео могут быть применены кодеки MPEG-4, H.264 и Theora, для звука - AAC, MP3, AC-3 или Vorbis. Из дополнительных функций присутствуют: калькулятор битрейта, предпросмотр в процессе кодирования, изменение размера и масштабирование картинки, интегратор субтитров, широкий набор профилей конвертации для заданных типов мобильных устройств.

Из представленных в HandBrake 0.9.5 новшеств можно отметить:

  • Поддержка структуры дисков BluRay;
  • Поддержка SSA-субтитров;
  • Обновление библиотек x264 и ffmpeg;
  • Возможность использования MP3-звука и субтитров VOBSUB в MP4-файлах;
  • Поддержка кодирования звука AC-3;
  • Поддержка сокращения числа звуковых каналов (downmixing), например, конвертация 5.1 звука в стерео;
  • В GUI-интерфейсе:
    • Обновлена панель расширенных настроек x264;
    • Добавлена поддержка сканирования группы файлов за раз;
    • Реализована опция для установки пиковой частоты кадров;
    • Возможность редактирования помещенных в очередь заданий;
    • Поддержка перекодирования части файла.


  1. Главная ссылка к новости (http://handbrake.fr/?article=1...)
Лицензия: CC-BY
Тип: Программы
Короткая ссылка: https://opennet.ru/29194-video
Ключевые слова: video, transcode, HandBrake
Поддержать дальнейшую публикацию новостей на OpenNET.


Обсуждение (37) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, Noldor (??), 16:52, 04/01/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • –3 +/
    Ему нужен моно под nix?
     
     
  • 2.4, Igor Kovalenko (?), 17:02, 04/01/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Судя по коду, - да. Во всяком случае, для версии под винду - точно.
     
  • 2.5, Аноним (-), 17:19, 04/01/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Нет.
    >Зависит от            : bzip2  hal  libnotify  libwebkit
     
     
  • 3.29, Zenitur (?), 04:51, 05/01/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Скоро и зависимость от hl'а уберут... В последние дни в portage этим активно занимаются
     
     
  • 4.37, Michael Shigorin (ok), 19:44, 09/01/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Имейте в виду, проект затачивается исключительно под самосбор:
    <s55> gvy, we patch many of the libraries we use, and require exact versions of all of them
    <s55> We already seen one idiot create a package for debian that used system libraries.  It broke badly

    В т.ч. по причине проблем с апстримами (включая сдохшие):
    <bogo_lode> for example
    <bogo_lode> libdvdread
    <bogo_lode> or libdvdnav
    <bogo_lode> hb has heavily patched those
    <bogo_lode> no distro uses new enough versions or provides allthe patches
    <bogo_lode> at least 2 patches prevent relatively common hangs
    <bogo_lode> x264? no one comes close to packaging as new as hb does.
    <bogo_lode> it goes on and on and on
    <bogo_lode> just build it the hb provided way
    <bogo_lode> or expect a broken build

    Ну и линуксовым портом там занимается целый один человек, поэтому пытаться упаковать это в дистрибутив, не будучи готовым помочь им с проталкиванием патчей в апстримы (или хотя бы тот же дистрибутив) -- полная безнадёга.

     
  • 2.6, User295 (?), 17:20, 04/01/2011 [^] [^^] [^^^] [ответить]  
  • –2 +/
    не нужен
     
  • 2.20, iZEN (ok), 20:02, 04/01/2011 [^] [^^] [^^^] [ответить]  
  • +/
    http://www.freshports.org/multimedia/handbrake/

    Required To Build: devel/jam, devel/pkg-config, devel/yasm, devel/gmake, devel/automake, devel/libtool
    Required Libraries: print/freetype2

     
  • 2.24, User294 (ok), 22:46, 04/01/2011 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > Ему нужен моно под nix?

    С чего вдруг ему понадобится mono? Он вроде как всю жизнь на си был?! oO

     

  • 1.2, cordatus (ok), 16:59, 04/01/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Отличная вещь. Понравилась функция автоматической обрезки. В будущем надеюсь добавят поддержку WebM. Также хотелось бы поддержку русского языка
     
  • 1.3, Igor Kovalenko (?), 17:00, 04/01/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    А чем оно лучше avidemux?
     
     
  • 2.8, Noldor (??), 17:22, 04/01/2011 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Может быть тем, что это конвертер, а не редактор?
     

  • 1.7, paulus (ok), 17:20, 04/01/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    а на чем он вообще написан? хоть бы уточнили, может плохо искал, но даже по ссылке не написано.
     
     
  • 2.9, samm (ok), 17:33, 04/01/2011 [^] [^^] [^^^] [ответить]  
  • +/
    На сях. Там есть трак на сайте вообще-то.
     

  • 1.10, ТОнкий (?), 17:42, 04/01/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    А avi контейнеры не поддерживает что ли?
     
     
  • 2.13, Alexey (??), 18:19, 04/01/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Раньше поддерживал, после того как удалили его - перестал пользоваться
     
  • 2.15, Аноним (-), 18:45, 04/01/2011 [^] [^^] [^^^] [ответить]  
  • –1 +/
    А их еще кто-то использует?
     
     
  • 3.33, Alexey (??), 14:40, 05/01/2011 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Телевизоры Philips
     

  • 1.11, Аноним (-), 17:48, 04/01/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    А есть такая софтина, которая в Theora и h.264 кодирует за 1 раз без лишнего кликанья по менюшкам? Охота сделать поддержку тега <video> как можно меньше заморачиваясь, ибо видео много. Ах, да, важна еще и кроссплатформенность, бо самые мощные компы у нас на которых будем кодировать - на виндах.
     
     
  • 2.14, Вова (?), 18:45, 04/01/2011 [^] [^^] [^^^] [ответить]  
  • +3 +/
    > А есть такая софтина, которая в Theora и h.264 кодирует за 1
    > раз без лишнего кликанья по менюшкам? Охота сделать поддержку тега <video>
    > как можно меньше заморачиваясь, ибо видео много. Ах, да, важна еще
    > и кроссплатформенность, бо самые мощные компы у нас на которых будем
    > кодировать - на виндах.

    ставьте линукс, ffpeg/mencoder/etc решит эту задачу БЕЗ ЕДИНОГО КЛИКА по менюшкам.

     
     
  • 3.16, Аноним (-), 18:50, 04/01/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > ставьте линукс, ffpeg/mencoder/etc решит эту задачу БЕЗ ЕДИНОГО КЛИКА по менюшкам.

    К сожалению, что ставить - не мне решать, а вот задачу перекодирования - мне. Пытаюсь как-нибудь извернуться, дабы приблизить светлое будущее с HTML5. :)

     
     
  • 4.17, filosofem (ok), 19:01, 04/01/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Под форточками в былые времена кошерно было ВиртуалДабом перекодировать, как сейчас даже не знаю, ибо под Линуксом ну намного удобнее инструментарий.
     
     
  • 5.19, Аноним (-), 19:22, 04/01/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > Под форточками в былые времена кошерно было ВиртуалДабом перекодировать, как сейчас даже не знаю, ибо под Линуксом ну намного удобнее инструментарий.

    Да, но он для быстрой пакетной обработки сразу в два типа формата мало приспособлен.

     
  • 3.23, gfh1gfh1 (ok), 22:29, 04/01/2011 [^] [^^] [^^^] [ответить]  
  • +/
    mencoder/mplayer/ffmpeg есть и под windows
     
  • 3.25, User294 (ok), 22:49, 04/01/2011 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > ставьте линукс, ffpeg/mencoder/etc решит эту задачу БЕЗ ЕДИНОГО КЛИКА по менюшкам.

    Ну, собссно, ffmpeg/mencoder есть под разные системы. Они весьма кроссплатформенные. Да, без единого клика по менюшкам - решат. Правда вот параметров у них чуть более чем дохрена. С другой стороны, параметров настолько дохрена что ни один гуй в принципе не способен их все вместить, для начала :)


     
  • 2.21, h31 (ok), 20:03, 04/01/2011 [^] [^^] [^^^] [ответить]  
  • +/
    В HandBrake можно сделать пресет.
    Для Theora мне нравятся OggConvert и ffmpeg2theora. Для h.264 программ, думаю, навалом.
     
  • 2.26, Аноним (-), 02:08, 05/01/2011 [^] [^^] [^^^] [ответить]  
  • +/
    При чём здесь устаревшая Theora и чуть более улучшившая её Thusnelda? Зачем Вам контейнер OGG/OGM? Связку VP8+Vorbis+Matroska=WebM сразу использовать не желаете? И наступит Вам счастье, с html5 и Web 2.0...
     
     
  • 3.30, Azelus (?), 08:05, 05/01/2011 [^] [^^] [^^^] [ответить]  
  • +4 +/
    Ну так подскажите нормальный инструмент для работы с VP8 и WebM.
     
     
  • 4.31, Wormik (ok), 12:35, 05/01/2011 [^] [^^] [^^^] [ответить]  
  • +/
    ffmpeg. Редактируешь видеопотоки больших размеров в формате PCM, а готовое видео сжимаешь в хорошем битрейте.
     
     
  • 5.34, Azelus (?), 17:12, 05/01/2011 [^] [^^] [^^^] [ответить]  
  • +/
    А что делать юзверям, не приученым к консоли?
     
  • 3.32, paulus (ok), 13:13, 05/01/2011 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Связку VP8+Vorbis+Matroska=WebM сразу использовать не желаете?

    +1 :-)


     

  • 1.12, gabin (ok), 17:52, 04/01/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Я не понял, она что на GTK+?
     
     
  • 2.18, el_torito (?), 19:14, 04/01/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > Я не понял, она что на GTK+?

    Именно. И это есть хорошо.

     
  • 2.27, prokoudine (??), 02:13, 05/01/2011 [^] [^^] [^^^] [ответить]  
  • –2 +/
    > Я не понял, она что на GTK+?

    А не всё равно?

     
     
  • 3.36, gabin (ok), 16:24, 06/01/2011 [^] [^^] [^^^] [ответить]  
  • –1 +/
    нет. Мне для KDE лучше когда на Qt.
     

  • 1.28, Zenitur (?), 04:50, 05/01/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • –3 +/
    Увы, TransKode лучше.
     
  • 1.35, LuckAs (ok), 22:50, 05/01/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Собрал последние сорцы в пакет под Мандриву 2010.0/64 попробовал, рабочая штука.
    Довольно шустро кодит. Только нужно бы добавить нормальных пресетов побольше (для разных случаев), встроенные в основном ориентированы на яблочников с IPa/od'дами.
     
     
  • 2.38, Michael Shigorin (ok), 19:46, 09/01/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > Собрал последние сорцы в пакет под Мандриву 2010.0/64

    См. выше.

     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:
    При перепечатке указание ссылки на opennet.ru обязательно



    Спонсоры:
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2022 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру