The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Релиз медиаплеера VLC 2.0.1

19.03.2012 19:39

Спустя месяц после выхода версии 2.0.0 представлен корректирующий релиз медиаплеера VLC 2.0.1, в котором устранено более 120 ошибок и регрессивных изменений, а также добавлено несколько небольших новшеств. Сообщается, что за месяц версия VLC 2.0.0 была загружена более 15 млн раз.

Из добавленных в новой версии улучшений отмечается реализация поддержки формата MxPEG, улучшение интерфейса для платформы Mac OS X, ускорение декодирования различных форматов, начальная реализация меню BluRay. Из исправлений отмечаются решение проблем в интерфейсе на базе Qt, устранение ошибок в коде поддержки HTTP Live Streaming, CDDB, UDP/RTP, RAR, Ogg и MKV.

Отдельно стоит обратить внимание на устранение двух уязвимостей: переполнение буфера в плагине с поддержкой потоков Real RTSP (libaccess_realrtsp_plugin.*) и переполнение стека в коде поддержки MMS (плагин libaccess_mms_plugin.*). Обе уязвимости позволяют организовать выполнение кода злоумышленника при открытии специальным образом скомпонованных данных.

  1. Главная ссылка к новости (http://www.videolan.org/news.h...)
  2. OpenNews: Релиз медиаплеера VLC 2.0.0
  3. OpenNews: Проект VideoLAN перевёл ядро VLC на лицензию LGPL
Лицензия: CC-BY
Тип: Программы
Короткая ссылка: https://opennet.ru/33391-vlc
Ключевые слова: vlc
При перепечатке указание ссылки на opennet.ru обязательно


Обсуждение (27) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, Аноним (-), 19:46, 19/03/2012 [ответить] [﹢﹢﹢] [ · · · ]  
  • +5 +/
    Неслабые изменения для 2.0.0 .> 2.0.1
     
     
  • 2.3, Аноным (ok), 19:59, 19/03/2012 [^] [^^] [^^^] [ответить]  
  • +/
    Если нумеровать датами, то вонь про цифры закончится или будет вонь: "Чё так мало сделано за такой промежуток?!?!"?
     
  • 2.4, ДеД (?), 20:07, 19/03/2012 [^] [^^] [^^^] [ответить]  
  • +9 +/
    по-моему это как раз нормальная нумерация версий. в отличии от "гонок за циферкой" хрома и фаерфокса
     
     
  • 3.6, paulus (ok), 20:43, 19/03/2012 [^] [^^] [^^^] [ответить]  
  • +7 +/
    Что вам так циферки сдались? За то в фф теперь быстрее попадают исправления и нововведения, которые раньше сто лет ждали... они из-за Гугло Хрома хоть чухаться быстрее стали.

    Рад за проект. Но даже в 2.1.0-git еще не научился останавливать xscreensaver, уже запарили баг не исправлять, который уже сто лет висит... :(

     
     
  • 4.7, ДеД (?), 21:12, 19/03/2012 [^] [^^] [^^^] [ответить]  
  • –2 +/
    В расширенных настройках в разделе Видео опция "Отключить заставку".
    Насчёт фф - главное, чтобы скорость нововведений не влияла на качество кода.
     
     
  • 5.9, paulus (ok), 21:25, 19/03/2012 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > В расширенных настройках в разделе Видео опция "Отключить заставку".

    Да не работает это c fluxbox + xscreensaver, разве что гномовский остановит... Номер не буду искать, но для VLC это только в далеких планах... Что это за проигрыватель, что не может сам заставку отключить?

    > Насчёт фф - главное, чтобы скорость нововведений не влияла на качество кода.

    согласен, недавно для перестраховки на день задержали 11 релиз ;)


     
     
  • 6.11, Motif (ok), 21:30, 19/03/2012 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Можно пускать скриптом:

    cd ~/.config/vlc
    sed -e 's/#disable-screensaver/disable-screensaver/g' vlcrc > v2
    rm vlcrc
    mv v2 vlcrc
    vlc "$1"

    Так нормально работает. Но костыли, конечно.

     
  • 6.14, ДеД (?), 21:42, 19/03/2012 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > Да не работает это c fluxbox + xscreensaver, разве что гномовский остановит...

    Сам сижу на fluxbox'e с xscreensaver'ом, но ни разу такой проблемы не замечал.
    Наверное зависит от того, как vlc откомпилен.
    Я ставлю пакеты от alienBOB'a под слаку и даже не знал, что у кого-то существут проблема с xscreensaver'ом.

     
  • 5.10, Motif (ok), 21:28, 19/03/2012 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Смешно. Было бы это так просто, то никто бы не возмущался. Да, оно работает, но достаточно закрыть и опять запустить vlc и он эту настройку забывает. Проблема в записи в конфиг, опция в любом случае закоментирована.
     
     
  • 6.15, ДеД (?), 23:21, 19/03/2012 [^] [^^] [^^^] [ответить]  
  • +/
    > Смешно. Было бы это так просто, то никто бы не возмущался. Да,
    > оно работает, но достаточно закрыть и опять запустить vlc и он
    > эту настройку забывает. Проблема в записи в конфиг, опция в любом
    > случае закоментирована.

    проверил конфиг ~/.config/vlc/vlcrc . всё запоминает. при disable-screensaver=0 строчка сохраняется раскомментированной.

    # Disable screensaver (boolean)
    disable-screensaver=0

    при disable-screensaver=1 автоматически конвертится в закомментированную строчку, так как по-идее это значение по-умолчанию

     
     
  • 7.16, Motif (ok), 23:58, 19/03/2012 [^] [^^] [^^^] [ответить]  
  • +/
    Ну дык, нужно как раз disable-screensaver=1, иначе скринсейвер не подавляется. Это и есть ошибка.


     

  • 1.2, Аноним (-), 19:49, 19/03/2012 [ответить] [﹢﹢﹢] [ · · · ]  
  • +2 +/
    У меня на 2.0.0 не отображались chapters в mkv, надеюсь, здесь починили.
     
  • 1.5, ua9oas (ok), 20:38, 19/03/2012 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Почему на официальном сайте нет его бинариков под линукс? Раздобыл тогда я его с зеркала репозитариев и поставил. Но версию "2.0" не возможно установить под мой Дебиан 6.04 (а 2.0.1 будет можно?). "2.0" что то пишет про неудовлетворенные зависимости, но у него нет проблем поставиться под свежую убунту. Когда я еще "2.0" тогда в нее ставил, то он мог там воспроизводить файлы с разширением VQF, хотя на официальном сайте про этот аудиоформат не написано. Сейчас у меня стоит "1.1.3", и он того не воспроизводит. И больше ни чем воспроизвести vqf не могу (а чем тогда еще в линуксе кроме "vlc" можно? (под винду заметно больше ПО, которое это может)).
     
     
  • 2.8, Аноним (-), 21:18, 19/03/2012 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > он мог там воспроизводить файлы с разширением VQF

    Где вы ЭТО выкапываете вообще? У вас там что, кладбище мамонтов под боком? Этот формат был актуален в эпоху начала расцвета мп3 и потом тихо сдох, так и не набрав никакой популярности :)

     
     
  • 3.12, paulus (ok), 21:30, 19/03/2012 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Где вы ЭТО выкапываете вообще?

    вопрос был не где взять, а как воспроизвести ;)


     
     
  • 4.18, Аноним (-), 00:32, 20/03/2012 [^] [^^] [^^^] [ответить]  
  • –1 +/
    У меня нет ни 1 файла в этом формате, поэтому я даже проверить не могу :).

    А вообще надо думать головой что и как кодируешь/что скачиваешь. Если нечто доступно только в "убер-крутом", напрочь проприетарном формате, на который не выложили спеки и дали только какой-то мутный бинарь делающий неизвестно что (т.к. он "убер-крутой", вам это знать не полагается) - вы должны бы заподозрить что при таких начальных данных у вас _будет_ проблема чем его играть через 10-20 лет. Операционки, их форматы бинарей и API вполне могут меняться. Вот поэтому форматы типа ворбиса на которые есть нормальные спеки и референсные сырцы - это хорошо. Потому что если захочется проиграть файл из далекого прошлого (детства с золочеными пряниками, далекой молодости, видео снятого еще дедушкой, ...) - можно будет пересобрать и раскодировать. Ну или накрайняк по описанию воссоздать декодер (это конечно больше поможет ученым/профи, но лучше чем никому вообще).

     
  • 4.26, Michael Shigorin (ok), 02:57, 21/03/2012 [^] [^^] [^^^] [ответить]  
  • +/
    >> Где вы ЭТО выкапываете вообще?
    > вопрос был не где взять, а как воспроизвести ;)

    Помнится, для xmms был плагин.

     
  • 2.13, paulus (ok), 21:35, 19/03/2012 [^] [^^] [^^^] [ответить]  
  • +/
    В sid и wheezy (testing) есть 2.0.0 будет и 2.0.1. Убунта всегда на sid, а LTS на testing вот и ставятся пакеты...
     
  • 2.19, Анонимаус (?), 00:55, 20/03/2012 [^] [^^] [^^^] [ответить]  
  • +/
    >а чем тогда еще в линуксе кроме "vlc" можно

    mplayer - морда к нему smplayer или umplayer

    >Почему на официальном сайте нет его бинариков под линукс?

    Потому что есть репозитории, где ментейнеры собрали его под ваш дистрибутив, а качать с офсайта - это лучше чем с файлопомоек, но виндовенько.

    >Но версию "2.0" не возможно установить под мой Дебиан 6.04 (а 2.0.1 будет можно?).

    *плачет и бьётся головой о стену*

     
  • 2.23, Аноним (-), 15:05, 20/03/2012 [^] [^^] [^^^] [ответить]  
  • +/
    Всё из-за невозможности сборки на старом gcc .Можешь добавить репозиторий с vlc  для 7 ветки, заменить на время сорслист 6 ветки на 7 , и попытаться обновиться,на свой страх и риск. В теории-ничего системного обновляться не должно,поэтому опасность -не большая.
     

  • 1.17, KOL (ok), 00:23, 20/03/2012 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    OSX. Откатился снова до 1.1.2. Crop так и не кропает, а скейлит, причем теперь не целиком, а частично, т.е. часть кропает, а часть скейлит. Остальное вроде пофиксили.
     
  • 1.21, non (??), 11:27, 20/03/2012 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Что-то обновили, а вот бага на моём нетбуке при полнометражном просмотре, ползунок уходит вправо так, что я его весь не вижу, перемотка работает на половину.
    (1024 X 600 / 32)
     
  • 1.22, anonymous (??), 13:06, 20/03/2012 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    А когда же в openSUSE обновится хотя бы до 2.0 версии? В пакмане который, а не в репе vlc. Читал, что рекомендуют ставить именно из пакмана.
     
  • 1.24, Александр (??), 20:35, 20/03/2012 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    пользую одновременно сеть vpn для просмотра IpTV и спутниковый интеренет, после установки этой версии плейера просто не могу найти строку "ИНТЕРФЕЙС ВЫВОДА IPv4 multicast" в "Модули Вывода" для прописи IP сети, что бы одновременно работать в интернет и смотреть ТВ. Её убрали за ненадобностью??!! в этой версии можно что-то сделать подобное?
     
  • 1.25, Александр (??), 20:37, 20/03/2012 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    может быть я не туда вопрос задал? ОС винда7
     
  • 1.27, Аноним (-), 07:25, 25/03/2012 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Кто-нибудь ответит на вопрос Александра? Ситуация аналогичная. ОС ВинХР.
     
  • 1.28, Аноним (-), 20:27, 25/03/2012 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Что ни в одном диске не заметил реализацию меню Blu-ray
     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    PostgresPro
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2022 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру