The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Выпуск пакетного менеджера RPM 4.18

21.09.2022 16:59

После года разработки состоялся релиз пакетного менеджера RPM 4.18.0. Проект RPM4 развивается компанией Red Hat и используется в таких дистрибутивах, как RHEL (включая производные проекты CentOS, Scientific Linux, AsiaLinux, Red Flag Linux, Oracle Linux), Fedora, SUSE, openSUSE, ALT Linux, OpenMandriva, Mageia, PCLinuxOS, Tizen и многих других. Ранее независимой командой разработчиков развивался проект RPM5, который непосредственно не связан с RPM4 и в настоящее время заброшен (не обновлялся с 2010 года). Код проекта распространяется под лицензиями GPLv2 и LGPLv2.

Наиболее заметные улучшения в RPM 4.18:

  • Предложена новая интерактивная оболочка "rpmspec --shell", поддерживающая работу с макросами и встроенным Lua (rpmlua).
  • Добавлена новая утилита командной строки rpmuncompress, упрощающая распаковку нескольких файлов.
  • Переработан код для обработки больших файлов, в который добавлена защита от уязвимостей, манипулирующих символическими ссылками в процессе установки, восстановления и очистки.
  • Добавлен новый OpenPGP-бэкенд для работы с подписями пакетов, основанный на проекте Sequoia (реализация OpenPGP на языке Rust).
  • Предложен более понятный макрос "%bcond" для определения условий при сборке.
  • При определении слабых зависимостей (weak dependency) реализована поддержка тегов "meta" и "pre".
  • В spec-файлы добавлена новая секция "%conf" для сборки файлов конфигурации.


  1. Главная ссылка к новости (http://lists.rpm.org/pipermail...)
  2. OpenNews: Выпуск пакетного менеджера RPM 4.17
  3. OpenNews: Выпуск пакетного менеджера RPM 4.16
  4. OpenNews: Fedora планирует перевести RPM с BerkeleyDB на SQLite
  5. OpenNews: Выпуск пакетного менеджера RPM 4.15
  6. OpenNews: Дистрибутив OpenMandriva переходит на RPMv4 и DNF
Лицензия: CC-BY
Тип: Программы
Короткая ссылка: https://opennet.ru/57809-rpm
Ключевые слова: rpm
При перепечатке указание ссылки на opennet.ru обязательно


Обсуждение (40) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, НяшМяш (ok), 17:50, 21/09/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • –4 +/
    > Добавлен новый OpenPGP-бэкенд для работы с подписями пакетов, основанный на проекте Sequoia (реализация OpenPGP на языке Rust)

    И этот поржавел. Праведному сяшечнику скоро компьютер нельзя будет включить, чтобы не зашквариться. /s

     
     
  • 2.6, Аноним (6), 18:05, 21/09/2022 [^] [^^] [^^^] [ответить]  
  • +3 +/
    Да и незачем будет его включать - все равно собрать трэшовую утилитку на нем не получится, нужно арендовать в амазоне пару сотен инстансов чтобы кое-как собрались все зависимости зависимостей.


    Но пока, к счастью, это ненужное-ненужно всего лишь дополнительный бэкэнд который придется еще и отдельно подключать, если так уж хочется собрать rpm с его поддержкой. А иначе опять немодный сишный gpg будет.

     
     
  • 3.22, Аноним (22), 21:32, 21/09/2022 [^] [^^] [^^^] [ответить]  
  • +/
    К сожалению с растом это очень существенная проблема. Хоть сколько-нибудь легковесного компилятора для него нет...
     
     
  • 4.26, Аноним (26), 22:19, 21/09/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Вы прям так жалуетесь, будто вас кто-то заставляет собирать весь свой инструментарий на своём компьтере из исходников.
     
     
  • 5.27, Аноним (27), 22:32, 21/09/2022 [^] [^^] [^^^] [ответить]  
  • +/
    это должен быть персональный ад для растоманов - сборка раста из исходников не на роллинге...
     
  • 5.28, Аноним (22), 22:50, 21/09/2022 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Вообще довольно часто приходится. Каких-то мелких патчей накинуть - обычное дело. Раст довольно сильно мешает тяжёлым компилятором (у плюсов тоже такая проблема).
    Си - совсем другое дело.
     
     
  • 6.41, n00by (ok), 07:49, 22/09/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Такая же проблема плюсов решается ccache, но не в случае rpm.
     
     
  • 7.55, мелкософта (?), 01:53, 23/09/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Решил такую проблему имеенно так. Чяднт?
     
     
  • 8.56, n00by (ok), 14:59, 23/09/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Специально собирали на локальной машине, а не вон там, где положено ... текст свёрнут, показать
     
  • 3.44, ryoken (ok), 09:12, 22/09/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    >> чтобы кое-как собрались все зависимости зависимостей

    уберите --with-bdeps=true :D

     

  • 1.10, ИмяХ (?), 18:56, 21/09/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • +2 +/
    >>проект RPM5, который непосредственно не связан с RPM4 и в настоящее время заброшен (не обновлялся с 2010 года).

    Ну и зачем его тогда каждый раз упоминать?

     
     
  • 2.23, Аноним (22), 21:33, 21/09/2022 [^] [^^] [^^^] [ответить]  
  • +3 +/
    Чтоб не думали, наверное, что 4.18 это что-то древнее с поддержкой на уровне секурити баги пофиксим.
     
  • 2.39, n00by (ok), 07:41, 22/09/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Что бы я каждый раз писал, что «разработчики» свеженькой Rosa долго рекламировали его среди пользователей как прогрессивный, а пару лет назад выкинули, поскольку не умеют исправлять тривиальные переполнения стека и вообще кодить.
     
     
  • 3.57, ИмяХ (?), 13:18, 24/09/2022 [^] [^^] [^^^] [ответить]  
  • +/
    >> а пару лет назад выкинули

    Какие пару лет? С 2010 года заброшен, уже давно пора его забыть.

     
     
  • 4.58, n00by (ok), 10:36, 25/09/2022 [^] [^^] [^^^] [ответить]  
  • +/
    >>> а пару лет назад выкинули
    > Какие пару лет? С 2010 года заброшен, уже давно пора его забыть.

    Это автор его тогда забросил. Потом местные деятели купили Mandriva Linux. Внедрили RPM5 вместо RPM4, что бы быть впереди планеты всей. Потом произошло разделение на OpenMandriva и Rosa. Первые вынужденно поддерживали RPM5, что-то там доделывали. Вторые слепо патчи копировали. Накопировали переполнение стека при установке пакета и не могли его исправить, это сделал за них я. Платформа 2016 была у них актуальна ещё год назад, там RPM5.

     

  • 1.13, Nikki Next (?), 19:12, 21/09/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • –5 +/
    RPM - это формат пакетов. Пакетный менеджер RPM - DNF. Почему RPM называют пакетным менеджером?
     
     
  • 2.15, Аноним (15), 19:21, 21/09/2022 [^] [^^] [^^^] [ответить]  
  • +2 +/
    rpm -ivh *.rpm
     
  • 2.21, Аноним (21), 21:19, 21/09/2022 [^] [^^] [^^^] [ответить]  
  • +3 +/
    > RPM - это формат пакетов. Пакетный менеджер RPM - DNF.

    Неверно. Формат пакетов — CPIO + RPM-специфичные доп. заголовки. А пакетный менеджер — RPM. Что касается DNF, то он просто докачивает недостающие RPM из прописанных репозиториев. Формально его тоже можно обозвать пакетным менеджером, но часть своего функционала он просто делегирует RPM.

     
  • 2.31, SilverCutePony (ok), 04:37, 22/09/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Да ну? Название расшифруй для начала
    https://en.wikipedia.org/wiki/RPM_Package_Manager
     

  • 1.14, Аноним (15), 19:20, 21/09/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    > Предложен более понятный макрос "%bcond" для определения условий при сборке.

    В сусе уже давно, весрии где-то с 12.2

     
  • 1.17, birdie (ok), 19:56, 21/09/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    > Fix %_minimize_writes regression (in 4.15.0)

    Всего 4 года фиксили или около того.

     
  • 1.20, BrainFucker (ok), 20:28, 21/09/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Никогда не пользовался, чем он лучше deb, стоит пробовать?
     
     
  • 2.24, Аноним (24), 21:44, 21/09/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Зачем пробовать, если вас устраивает ваш deb дистрибутив?

    Не понимаю людей вообще.

    Как и не понимаю как люди пользуются deb-based дистрибутивами - рядом с RPM не валялся по фичам.

     
     
  • 3.30, Аноним (30), 02:20, 22/09/2022 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > рядом с RPM не валялся по фичам

    что за фичи такие?

     
     
  • 4.43, n00by (ok), 09:01, 22/09/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Можно скопировать spec файлы из Fedora и scamпелировать дистрибутив с  ̶н̶е̶с̶к̶у̶ч̶н̶ы̶м̶и̶ ̶о̶б̶о̶я̶м̶и̶  трендовым сетом иконок.
     
  • 3.32, Аноним (32), 05:33, 22/09/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Не понимаю людей, которые пользуются rpm и deb дистрибутивами, когда есть tgz-дистрибутивы.
     
     
  • 4.45, ryoken (ok), 09:14, 22/09/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    У вас слишком много ошибок в слове "ebuild" :D.
     
     
  • 5.47, Аноним (47), 10:30, 22/09/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    У вас слишком много ошибок в слове по"ebuild" :D.

    Исправил, можешь не благодарить.

     
  • 2.25, Аноним (22), 22:00, 21/09/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Создавать rpm пакеты как мне кажется проще чем deb. Всего один spec-файл для пакета написать и всё.
    Хотя тут наверное дело привычки...
     
  • 2.29, Аноним (29), 23:45, 21/09/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Лучше ебилды попробуй.
     
     
  • 3.33, BrainFucker (ok), 05:39, 22/09/2022 [^] [^^] [^^^] [ответить]  
  • +/
    > Лучше ебилды попробуй.

    Нет столько свободного времени.

     
     
  • 4.34, Аноним (-), 06:29, 22/09/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Замени свой Эльбрус на Ryzen наконец.
     
     
  • 5.35, BrainFucker (ok), 06:32, 22/09/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Замени свой Эльбрус на Ryzen наконец.

    Свободному времени на зад-тство от этого неоткуда взяться.

     
  • 2.37, лютый ж.... (?), 07:17, 22/09/2022 [^] [^^] [^^^] [ответить]  
  • +/
    >чем он лучше deb

    dnf лучше apt, а нижний слой всё равно сплошной оверинжениринг

     
     
  • 3.38, BrainFucker (ok), 07:19, 22/09/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Я про формат больше, а не менеджер. Так-то с apt у меня и так нет сложностей, зависимости разруливает, о проблемах предупреждает до того как начнёт обновление.

    А вообще по возможности предпочитаю AppImage или просто тарбол бандлы.

     
     
  • 4.40, пох. (?), 07:48, 22/09/2022 [^] [^^] [^^^] [ответить]  
  • +5 +/
    На формат бинарного пакета всем кроме белок-истеричек начхать. (Хотя возможность одной командой вытащить интересующий файл а не распаковывать бессмысленную матрешку в несколько приемов все же иногда  удобна.)

    Но возможно до тебя когда-нибудь дойдет, что мы тут не все белки-истерички, неистово надр@4ивающие на шва6одку, и кто-то когда-то всерьез предпочитал опенсорс потому что мог его сделать для себя таким как ему удобно.

    Вот сборка .deb - это боль, унижение, страдания. Уе...щный формат (три разных формата), мильен загадочных хелперов без документации, еще и норовящих "устареть", куча мусора часть которого не предназначена для людей, зато вторая требует ручного ковыряния - отдельный привет тем кто привык при работе пользоваться vcs, невозможность быстро и просто поправить чужое.

    .spec - единственный обычно _мелкий_ файлик, вся сложная деятельность загнана под капот и оттуда не торчит, лазят туда только дистростроители, новый образуется cp старый от первого попавшего под руку пакета и быстрой правкой десятка идущих подряд очевидных строк с именем и версией для начала - тратить время на чтение документации тебе скорее всего не придется. На некоторые сложности напарываешься в сложных местах (типа сборки модуля для язычка с собственной нескучной пакетной системой), но обычно где-то в федорином сайте есть документация и на этот случай. Макро и хелперы сделаны в режиме автопилота а не т-пого робота-водителя - т.е. включаются явно, делают за тебя твою работу, при малейшем несогласии с тем как они это делают - просто отключаются. Хочешь - дергай %configure, не хочешь или просто не дочитал до этого места - запускаешь вручную, никаких "dh-override" когда сперва догадайся, ЧТО override.

     
     
  • 5.46, ryoken (ok), 09:16, 22/09/2022 [^] [^^] [^^^] [ответить]  
  • +/
    >>(Хотя возможность одной командой вытащить интересующий файл а не распаковывать бессмысленную матрешку в несколько приемов все же иногда  удобна.)

    Простите, а пользоваться mc и ходить им унутре пакетов вам совсем убеждения не позволяют?

     
     
  • 6.48, Аноним (26), 11:01, 22/09/2022 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Это ваше mc как-нибудь скриптуется или мне руками файлы готовить под плейбуки и прочие репаки каждый раз?
     
  • 4.49, Аноним (47), 11:06, 22/09/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Классическая ситуация, ты ставишь зависимости для сборки какого-то куска софта ч... большой текст свёрнут, показать
     
     
  • 5.50, пох. (?), 11:46, 22/09/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Ну это уже проблема не deb/dpkg - это проблема apt и она тоже в головах у тех кто его изначально разрабатывал, что хотя бы примитивный путь вручную прооверрайдить его зависимости зависимостей не то что не предусмотрен, а если даже ты голым dpkg их решишь, при следующем же запуске apt либо все сломается либо он тебе все сломает.

    Но тут можно долго рассуждать о вкусах - поскольку ни dnf, ни zypper тоже в общем звезд с неба в этой области не хватают.

     
  • 5.53, BrainFucker (ok), 22:25, 22/09/2022 [^] [^^] [^^^] [ответить]  
  • +/
    > Классическая ситуация, ты ставишь зависимости для сборки какого-то куска софта через классический apt-get build-dep имя_пакета, например, php. Классика же, да?

    Не совсем, что-то компилить самому редко приходится.
    Во-вторых, я не делаю build-dep на основной системе, предпочитаю компилить что либо в чруте, чтобы не засирать систему кучей *-dev пакетов (к слову, они и в rpm-based системах есть вроде как).


    > И дальше мудовые рыдания, а почему?

    Не было такого, если /etc/apt/sources.list.d не засран левыми репами, то проблем не бывает. Что убунтушные, что дебияновские репы обычно в нормальном состоянии.

    > потому что ты из него не можешь выбить причину заминки установки.

    Тут вовсе враньё, apt выдаёт подробную инфу что такой-то пакет не может быть установлен, потому что зависит от такого-то пакета такой-то версии, но его нет в репах или типа того. Но опять же, такая ситуация возникает только если система засрана левыми репозиториями или пакетами не из реп.

    > И эта всратость в apt-е присутствует уже очень давно,

    Давно это когда? Прост я с 2007г. пользуюсь уже ))

     

  • 1.52, InuYasha (??), 17:43, 22/09/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Когда слышу "рпм", вспоминаю вечные ожидания поиска зеркал yum. Это настолько раздражало что на всю жизнь запомнилось.
     
     
  • 2.54, Anonym88 (?), 23:40, 22/09/2022 [^] [^^] [^^^] [ответить]  
  • +4 +/
    И кто виноват в том, что ты не способен заменить строчку "mirrorlist" на "baseurl"?
     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    PostgresPro
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2022 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру