The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]



"Пропадает звук при блокировке экрана (Pulseaudio?)"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Открытые системы на рабочей станции (Звук / Linux)
Изначальное сообщение [ Отслеживать ]

"Пропадает звук при блокировке экрана (Pulseaudio?)"  +/
Сообщение от SB123 (?), 15-Янв-23, 09:43 
При блокировке экрана, если ничего не проигрывается, параметры звука (громкость и выключение) устанавливается в какие-то странные значения (на данный момент - 2% + "замьюченность")

При установке системы такого поведения не было около месяца, потом появилось
На старом ноуте была такая же ситуация
Установка каких-либо пакетов этому, вроде бы, не предшествовала в обоих случаях

Иногда (очень редко) эти значения могут меняться по непонятным причинам (например, когда-то было 30% + включённый звук)

Я пытался найти, где эти значения хранятся, но всё не то - даже удаление ~/.config/pulse не помогает

Также пытался отключить выключение pulseaudio при блокировке сессии (ведь при проигрывании музыки во время блокировки громкость не меняется)
Однако, настройка /etc/pulse/default.pa не помогла
Собственно, комментирование строк вроде
* load-module module-device-restore
* load-module module-switch-on-port-available
* load-module module-suspend-on-idle
Приводит к каким-то странным и неадекватным результатам (вроде игнорирования изменения громкости) или не приводит вообще ни к чему

По итогу для неизменения громкости перед блокировкой экрана приходится вынимать наушники, что, очевидно, неудобно
Есть идеи по решению этой проблемы?

Если что: Debian Unstable, LXQT, pipewire (раньше его не было, но проблема тоже была)
Могу сообщить и более конкретные версии ПО, но не думаю, что в этом есть смысл, т. к. проблема была на всех последних версиях

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения [Сортировка по времени | RSS]


1. "Пропадает звук при блокировке экрана (Pulseaudio?)"  +/
Сообщение от Аноним (1), 17-Янв-23, 15:29 
>[оверквотинг удален]
> * load-module module-suspend-on-idle
> Приводит к каким-то странным и неадекватным результатам (вроде игнорирования изменения
> громкости) или не приводит вообще ни к чему
> По итогу для неизменения громкости перед блокировкой экрана приходится вынимать наушники,
> что, очевидно, неудобно
> Есть идеи по решению этой проблемы?
> Если что: Debian Unstable, LXQT, pipewire (раньше его не было, но проблема
> тоже была)
> Могу сообщить и более конкретные версии ПО, но не думаю, что в
> этом есть смысл, т. к. проблема была на всех последних версиях

альса

Ответить | Правка | Наверх | Cообщить модератору

2. "Пропадает звук при блокировке экрана (Pulseaudio?)"  +/
Сообщение от SB123 (?), 17-Янв-23, 19:27 
> альса

Ну да, очевидно, что проблема может быть и в ней
Но как это проверить, для начала?

Ответить | Правка | Наверх | Cообщить модератору

3. "Пропадает звук при блокировке экрана (Pulseaudio?)"  +/
Сообщение от Аноним (-), 18-Янв-23, 21:27 
>> альса
> Ну да, очевидно, что проблема может быть и в ней
> Но как это проверить, для начала?

Очевидно же, выпилить пшшшаудио и проверить.

Ответить | Правка | Наверх | Cообщить модератору

4. "Пропадает звук при блокировке экрана (Pulseaudio?)"  +/
Сообщение от SB123 (?), 19-Янв-23, 11:50 
> Очевидно же, выпилить пшшшаудио и проверить.

После удаления pulseaudio эта проблема исчезла, но перестала работать настройка звука с клавиатуры и сломался значок с регулировкой звука (полагаю, это связанные вещи)
После установки (удаление было "вычищением" всех файлов удаляемых пакетов) всё вернулось снова, с теми же 2% и замьюченностью

Ответить | Правка | Наверх | Cообщить модератору

5. "Пропадает звук при блокировке экрана (Pulseaudio?)"  +/
Сообщение от Аноним (-), 21-Янв-23, 23:18 
>перестала работать настройка звука с клавиатуры и сломался значок с регулировкой звука (полагаю, это связанные вещи)

Не пользуйтесь значками, гвоздями прибитыми к пшшшаудио.

>После установки (удаление было "вычищением" всех файлов удаляемых пакетов) всё вернулось снова, с теми же 2% и замьюченностью

Поздравляю, вы нашли виновника.

Ответить | Правка | Наверх | Cообщить модератору

6. "Пропадает звук при блокировке экрана (Pulseaudio?)"  +/
Сообщение от SB123 (?), 22-Янв-23, 03:11 
> Не пользуйтесь значками, гвоздями прибитыми к пшшшаудио.

Это стандартный плагин панели
Да и alsa сама по себе работает как-то заторможенно (по крайней мере, если смотреть на использование плеера во время удалённой pulseaudio)
Так что не вариант

> Поздравляю, вы нашли виновника.

Только так и осталось непонятным - где написаны те значения, которые выставляются после (раз)блокировки экрана
Кроме того, если вручную запускать alsactl -L (re)store, то звук восстанавливается нормально и при pulseaudio - спрашивается, мб в этом и проблема, и как тогда её решить?

Ответить | Правка | Наверх | Cообщить модератору

7. "Пропадает звук при блокировке экрана (Pulseaudio?)"  +/
Сообщение от Anonim (??), 11-Апр-23, 14:20 
Преполагаю, знаю куда копать.

Есть https://www.freedesktop.org/wiki/Specifications/
В рамках этих правил софт общается через шину или ещё как.

И где-то есть код, который мьютит громкость, если система в локе.

Смотря что за софт, то софтину и настраивать. Вероятно, что это не аудио-подсистемы. Что-то кроме них шлёт в аудио-подсистему сигнал мьютить/размутить.

В пользу этого говорит независимость от Пульса или Пайпваре. А Алса себя ведёт, очевидно, как по дефолту поведение и фолбэк на более низкоуровневый компонент при отсутвии других средств.

В общем: видимо, какой-то софт умеет сообщать аудио-подсистеме уровень громкости, в нём эти числа и защиты, скорее всего. И это мог бы быть скринсейвер, например.

Ответить | Правка | Наверх | Cообщить модератору

8. "Пропадает звук при блокировке экрана (Pulseaudio?)"  +/
Сообщение от SB123 (?), 05-Сен-23, 22:40 
Пару недель назад решил ещё раз разобраться, и вроде нашёл причину
У меня стоит блокировщик экрана lightdm, он всем хорош (быстр, красив и не тащит кучу зависимостей), но почему-то некоторые приложения запускаются и работают от его имени, а не от пользователя, которого он (раз)блокирует

Так что решение: удалить папку /var/lib/lightdm/.config/pulse
Ну или что-то подобное, имеющее на конце pulse (сейчас я этого не нашёл, но у меня есть ощущение, что раньше .config была в одной из папок в lightdm/data, но сейчас data содержит только пустые папки с именами пользователей, что странно, но да ладно)

Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Партнёры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2024 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру