The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Обновление Debian 11.3 и 10.12

26.03.2022 22:45

Опубликовано третье корректирующее обновление дистрибутива Debian 11, в которое включены накопившиеся обновления пакетов и устранены недоработки в инсталляторе. Выпуск включает 92 обновления с устранением проблем со стабильностью и 83 обновления с устранением уязвимостей. Из изменений в Debian 11.3 можно отметить обновление до свежих стабильных версий пакетов apache2, clamav, dpdk, galera, openssl и rust-cbindgen, а также удаление пакетов angular-maven-plugin и minify-maven-plugin, потерявших актуальность.

Для загрузки и установки "с нуля" в ближайшее время будут подготовлены установочные сборки, а также live iso-hybrid c Debian 11.3. Системы, установленные ранее и поддерживаемые в актуальном состоянии, получают обновления, присутствующие в Debian 11.3, через штатную систему установки обновлений. Исправления проблем безопасности, включённые в новые выпуски Debian, доступны пользователям по мере выхода обновлений через сервис security.debian.org.

Одновременно доступен новый выпуск предыдущей стабильной ветки Debian 10.12, в который включено 78 обновлений с устранением проблем со стабильностью и 50 обновлений с устранением уязвимостей. Из репозитория исключены пакеты angular-maven-plugin и minify-maven-plugin. В OpenSSL включена проверка соответствия запрошенного алгоритма цифровой подписи выбранному уровню безопасности. Например, при попытке использования RSA+SHA1 при выставленном 2 уровне безопасности будет возвращена ошибка, так как данный алгоритм не поддерживается на 2 уровне. При необходимости уровень можно переопределить через указание параметра '-cipher "ALL:@SECLEVEL=1"' в командной строке или изменив настройки в файле /etc/ssl/openssl.cnf.

  1. Главная ссылка к новости (https://www.debian.org/News/20...)
  2. OpenNews: Обновление Debian 11.2
  3. OpenNews: Определена дата заморозки пакетной базы Debian 12
  4. OpenNews: Из Debian ушёл мэйнтейнер, несогласный с новой моделью поведения в сообществе
  5. OpenNews: Выпуск дистрибутива Linux Mint Debian Edition 5
  6. OpenNews: Выпуск дистрибутива Devuan 4.0, форка Debian без systemd
Лицензия: CC-BY
Тип: Программы
Короткая ссылка: https://opennet.ru/56916-debian
Ключевые слова: debian
При перепечатке указание ссылки на opennet.ru обязательно


Обсуждение (15) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, Ooiiii (?), 09:21, 27/03/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    У меня 10-ый, вчера когда в aptitude обновился, и появилось 100 с лишним пакетов обновлений, у меня челюсть отвисла, около полу-года ничего не было.
     
     
  • 2.14, Аноним (14), 13:09, 27/03/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    У меня вот челюсть отвисла когда dev-perl/XML-Parser обновился и потребовал под сотню дополнительных пакетов. Это зависимость dev-util/intltool и тот является гномозависимостью. Раньше перл никто не трогал и пакеты вебни в систему только иксы тащили (тут тоже спасибо гноморазрабам которые эту заразу в иксы пропихнули в прошлом году).
     
     
  • 3.15, Аноним (15), 14:56, 27/03/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Может у вас рекомендуемые зависимости включены как обязательные?
     
     
  • 4.16, Аноним (14), 15:14, 27/03/2022 [^] [^^] [^^^] [ответить]  
  • +/
    > Может у вас рекомендуемые зависимости включены как обязательные?

    Я так понял, это обязательная зависимость. 3 года назад так сделали, в дистрибутиве обновили только в прошлом месяце. Мне конечно нормально на версии 7 летней давности, но ПМ жалуется https://metacpan.org/release/TODDR/XML-Parser-2.46/source/Changes

     
  • 2.28, Аноним (-), 06:26, 29/03/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Отключите установку recommended, там бывает прописано все что не лень и можно скачать почти все пакеты из репы ради очередного тетриса.
     

  • 1.7, Аноним (7), 12:15, 27/03/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Где-то уже можно скачать Debian Trixie?
     
  • 1.17, Аноним (17), 16:57, 27/03/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • +3 +/
    Там никаких сюрпризов, вроде node-ipc, не появится?
     
     
  • 2.19, Аноним (19), 20:14, 27/03/2022 [^] [^^] [^^^] [ответить]  
  • +2 +/
    гарантии нет.
     
     
  • 3.23, Аноним (23), 16:56, 28/03/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Даже обновляться нет желания теперь, буду пока сидеть на системе с последним обновлением в середине февраля. Даже snap заморозил. Фаерфокс вон даже без обновления нагадить смог
     
     
  • 4.24, Аноним (24), 18:51, 28/03/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Ставим Яндекс.Браузер. Не мог даже подумать полгода назад, что скажу такое.
     
     
  • 5.26, Аноним (23), 19:25, 28/03/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Ну я яндекс поисковиком не пользуюсь, просто неприятно такое от фаерфокса. Всё же думаю мозила пока меньше нарушает приватность чем яндекс
     
  • 4.27, Аноним (27), 21:32, 28/03/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Смог - он такой. П1 из Европы его привёз, говорят? )
     
  • 2.20, Аноним (20), 20:33, 27/03/2022 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Сейчас впору организовывать доступ к чувствительным данным только через специальную программу/юзера/машину... Чтобы вот это всё новое в принципе не имело доступа, куда не надо.
     

  • 1.22, Смузихлёб (?), 15:05, 28/03/2022 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Не нужно. Всякие обновления вредны.
     
     
  • 2.25, Аноним (24), 18:53, 28/03/2022 [^] [^^] [^^^] [ответить]  
  • +/
    Не всякие. Но насчет серверов определенно.
     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    PostgresPro
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2022 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру