The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Настройка PPPoE сервера на базе ОС Linux и клиента на базе ОС Windows

10.10.2006 11:12

В статье описана настройка доступа абонентов в сеть по протоколу PPPoE, на примере сервера rp-pppoe (в KERNEL MODE) под управлением ОС Gentoo Linux и клиента raspppoe.

Авторизация абонентов производится по протоколу RADIUS через централизованное хранилище учетной информации.

Материал изложен в виде пошаговой инструкции, что крайне полезно если необходимо быстро запустить PPPoE.

  1. Главная ссылка к новости (http://www.netup.ru/articles.p...)
Автор новости: NetUP
Тип: яз. русский / Практикум
Короткая ссылка: https://opennet.ru/8493-pppoe
Ключевые слова: pppoe
Поддержать дальнейшую публикацию новостей на OpenNET.


Обсуждение (8) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, VecH (ok), 13:31, 10/10/2006 [ответить]  
  • +/
    Там настройку PPPoE клиента нужно делать в Win9x или Win2000
    в винда версий выше WinXP и т.д. PPPoE клиент есть уже по умолчанию и соединение создается штатным мастером
     
     
  • 2.2, goodini (?), 14:15, 10/10/2006 [^] [^^] [^^^] [ответить]  
  • +/
    Кстати, насчет штатного PPPoE клиента в 2003 просвети плиз. Он умеет делать поиск доступных PPPoE серверов в сети ?
     
     
  • 3.4, VecH (ok), 15:34, 10/10/2006 [^] [^^] [^^^] [ответить]  
  • +/
    >Кстати, насчет штатного PPPoE клиента в 2003 просвети плиз. Он умеет делать
    >поиск доступных PPPoE серверов в сети ?
    Я про поиск ничего не говорил, если уж спросил то могу сказать на 100% что такой фишки в штатном клиенте в WinXP_2k3 нет
     

  • 1.3, Painbringer (?), 14:52, 10/10/2006 [ответить]  
  • +/
    ботва. а на ранлевел типа добавлять не надо?
     
  • 1.5, Аноним (-), 21:21, 10/10/2006 [ответить]  
  • +/
    а какой версии этот самый pppd был использован в инсталяции? потому как были попытки завести pppoe на pppd последних версий (2.4.3) - связка rp-pppoe+pppd не работает, ругается на LCP. заработал только 2.4.2 собраный из исходников.
     
     
  • 2.6, chester (?), 22:40, 10/10/2006 [^] [^^] [^^^] [ответить]  
  • +/
    Судя по логам из доки:

    Oct  7 22:27:29 zavidovo pppd[18595]: RP-PPPoE plugin version 3.3 compiled against pppd 2.4.3

    на самом деле действительно есть некий элемент мистики при взаимодействии rp-pppoe с pppd - могут понадобиться шаманские танцы с бубном ...

     
     
  • 3.8, Alex (??), 10:21, 31/10/2006 [^] [^^] [^^^] [ответить]  
  • +/
    Танцев с бубном не надо, надо просто пересобрать rp-pppoe с тем ppp, который установлен.
     
  • 2.7, chester (?), 22:41, 10/10/2006 [^] [^^] [^^^] [ответить]  
  • +/
    да и еще, попробуйте rp-pppoe в KERNEL MODE как по доке - скорее всего поможет для pppd 2.4.3
     
     Добавить комментарий
    Имя:
    E-Mail:
    Текст:
    При перепечатке указание ссылки на opennet.ru обязательно



    Спонсоры:
    PostgresPro
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2022 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру